Subject: [T2TRG] Next WISHI call: October 11th 7:00-8:30 AM PDT

From: Ari Keränen <[email-masked]>
Date: Wed, 10 Oct 2018 19:58:43 +0000

Reminder: the next WISHI call is tomorrow, October 11th 7:00-8:30 AM PDT (16:00-17:30 CEST).

Draft agenda:
* Notes on Semantics and Engineering Principles (Michael, Ari, et al)
* WISHI hackathon plans for IETF 103

Join the call here: https://jitsi.tools.ietf.org/t2trg-wishi

Dial-in details: https://jitsi.tools.ietf.org/static/dialInInfo.html?room=t2trg-wishi

Notes: https://etherpad.tools.ietf.org/p/notes-t2trg-wishi-20181011

Latest agenda: https://github.com/t2trg/wishi/wiki/Agenda-items

Cheers,
Ari

---

From: William_J_G Overington <[email-masked]>
Date: Thu, 11 Oct 2018 16:47:03 +0100 (BST)

Thank you for an interesting discussion this afternoon.

In case some readers are not aware of them, may I please mention the Annotation Characters that are already encoded in Unicode in case they might be helpful in the research.

They are described in The Unicode Standard, Chapter 23, starting at page 883 and finishing on page 885.

http://www.unicode.org/versions/Unicode11.0.0/ch23.pdf

Please note that page numbering is sequential for the whole publication, the Chapter 23 document starts at page 855 and goes through to page 890.

There is a code chart available that includes the Annotation Characters.

http://www.unicode.org/charts/PDF/UFFF0.pdf

William Overington

Thursday 11 October 2018

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 11 Oct 2018 17:54:09 +0200

> In case some readers are not aware of them, may I please mention the Annotation Characters that are already encoded in Unicode in case they might be helpful in the research.

I don’t think they are.  We do not have the problem of inserting textual annotations into Unicode text documents.

The semantic annotations that we have been discussing are meant for machine processing, and they usually attach to structural elements of a serialized (e.g., in JSON or CBOR) data structure.  Unicode does occur in these structures, but is not usually annotated in the Unicode sense.  Whether the serialization uses Unicode (JSON does) is not relevant here.

Grüße, Carsten

---

From: William_J_G Overington <[email-masked]>
Date: Thu, 11 Oct 2018 17:46:39 +0100 (BST)

In the discussion about regular languages I mentioned Esperanto, a constructed language invented for humans to use.

It may well be that the concept of a regular language being referred to in the discussion was not about a language in the sense of French, English and German being languages and that I was mistaken.

In the discussion it was established that I was thinking in terms of human to machine communication, the idea being that Esperanto could be easier for a device to decode.

In case any readers do not know of Esperanto and might like to know how the word is spelled and something about it I am posting this note.

https://en.wikipedia.org/wiki/Esperanto

http://www.users.globalnet.co.uk/~ngo/song1023.htm

William Overington

Thursday 11 October 2018