Subject: Re: [T2TRG] Semantic extractor languages

From: Ari Keränen <[email-masked]>
Date: Mon, 7 Jan 2019 09:26:29 +0000

Hi William,

> On 24 Dec 2018, at 12.31, [email-masked] wrote:
> 
> Hi
> 
>> I think we should not restrict ourselves to URI-addressable things 
>> only
> since some of the interesting ones seem to be lacking URI format today.
> 
> I am fairly new to this and so I seek your advice please.
> 
> During the summer I made some posts, in particular there is the thread 
> as follows.
> 
> Localizable sentences for thing to thing communication
> 
> There are seven posts in that thread, six of them from me.
> 
> Could you possibly consider whether it is relevant to include my idea of 
> localizable sentences (possibly embedded within a JSON file) in your 
> list please?

I think localizable sentences would be out of scope for this since it probably makes sense to focus on IoT-related formats that are already widely in use and/or actively developed in relevant SDOs.

Cheers,
Ari 

> The following post perhaps gives the best idea,
> 
> https://mailarchive.ietf.org/arch/msg/t2trg/MxFYh3WwccNvKOE0sNR3cyY5Vw4
> 
> with a correction in the following post.
> 
> https://mailarchive.ietf.org/arch/msg/t2trg/nKhC4fvWoz6NtmbZ7LJIXCa9RRw
> 
> Best regards,
> 
> William Overington
> 
> Monday 24 December 2018
> 
> 
> 
> 
> 
> ------ Original Message ------
> From: "Ari Keränen" <[email-masked]>
> To: "Christian Amsüss" <[email-masked]>; "[email-masked]" 
> <[email-masked]>
> Sent: Saturday, 2018 Dec 22 At 17:01
> Subject: Re: [T2TRG] Semantic extractor languages
> 
> Hi Christian,
> 
> On 11/10/2018 18.43, Christian Amsüss wrote:
>> Hello WISHI participants,
>> 
>> Follow-up question on the topic of extractors that we discussed as the
>> first item in today's meeting:
>> 
>> Could we collect some of candidate target lanuages? AFAIR mentioned 
>> plus
>> what comes to my mind:
>> 
>> * modbus
>> * JSON data from Alexa
>> * HTML?
>> * OCF data
>> * CoRE-interfaces batches for devices that don't understand them
>> * Extracting data from CoRAL for devices that don't understand it
> 
> Collecting these makes lots of sense. Thank you for starting with this!
> 
> Bluetooth could be added to the list and Michael mentioned about ZigBee
> too. Also I think OPC UA (binary) is interesting, although there we
> could perhaps get away easier by using/translating to the (standard)
> XML/JSON formats.
> 
> I wonder if there's also interest e.g., in the BACnet community to try
> our this approach?
> 
> But overall, if we take a few examples of JSON/XML formats and a few
> binary formats, we should be able to get some good insights already.
> 
>> Just to get some idea of the problem space we want to address.
>> 
>> As modbus is, as I understand it, typically not something that comes
>> around when dreferencing a URI, do we expect accessing things that are
>> not URI addressable (yet)?
> 
> I think we should not restrict ourselves to URI-addressable things only
> since some of the interesting ones seem to be lacking URI format today.
> But looking into defining new URI formats and media types when needed
> sounds like a good idea.
> 
> 
> Cheers,
> Ari
> 
> _______________________________________________
> T2TRG mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/t2trg

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 7 Jan 2019 10:00:02 +0000 (GMT)

AK > I think localizable sentences would be out of scope for this since 
it probably makes sense to focus on IoT-related formats that are already 
widely in use and/or actively developed in relevant SDOs.

What does SDO mean in the above please?

I have tried to find out.

https://acronyms.thefreedictionary.com/SDO

But why out of scope please?

It seems that your opinion is based not upon whether it would work nor 
whether it would be useful in The Internet of Things but upon the fact 
that it is not already in use nor being actively developed in relevant 
SDOs.

That seems to be deeming it to be out of scope because it is a new idea 
not already implemented. Now I am retired and just at home with a laptop 
computer and some budget software and a small personal webspace hosted 
by a United Kingdom Internet Service Provider. So I do what I can but I 
am restricted in what I can do myself.

It seems to me that if the idea could be of benefit then it should be 
given fair consideration on its merits and maybe some way of progressing 
could be found, such as, for just one example,  a group project for some 
students somewhere to have a go at developing it.

Yet your previous post had the following.

>> only since some of the interesting ones seem to be lacking URI format 
>> today. But looking into defining new URI formats and media types when 
>> needed sounds like a good idea.

As I wrote before, I am new to this field. If my ideas are found to be 
out of scope when a scientific  assessment of what they would do in the 
The Internet of Things is made then so be it.

William Overington

Monday 7 January 2019

------ Original Message ------
From: "Ari Keränen" <[email-masked]>
To: "William_J_G Overington" <[email-masked]>
Cc: "Christian Amsüss" <[email-masked]>; "[email-masked]" 
<[email-masked]>
Sent: Monday, 2019 Jan 7 At 09:26
Subject: Re: [T2TRG] Semantic extractor languages

Hi William,

> Could you possibly consider whether it is relevant to include my idea 
> of localizable sentences (possibly embedded within a JSON file) in 
> your list please?

I think localizable sentences would be out of scope for this since it 
probably makes sense to focus on IoT-related formats that are already 
widely in use and/or actively developed in relevant SDOs.

Cheers,
Ari

---

From: Ari Keränen <[email-masked]>
Date: Mon, 7 Jan 2019 11:04:16 +0000

> On 7 Jan 2019, at 12.00, [email-masked] wrote:
> 
> AK > I think localizable sentences would be out of scope for this since it probably makes sense to focus on IoT-related formats that are already widely in use and/or actively developed in relevant SDOs.
> 

I was referring to standards developing organisations, such as the IETF, or OCF, Bluetooth SIG, etc.

> But why out of scope please?

In this exercise I think (chair hat off) it makes sense to focus on a few models where we see the biggest bang for the buck, i.e., models that are already widely in use and/or we envision being used widely for IoT. Of course if the T2TRG community feels we should have a wider scope, I'm open to that.

> It seems that your opinion is based not upon whether it would work nor whether it would be useful in The Internet of Things but upon the fact that it is not already in use nor being actively developed in relevant SDOs.

In this case, yes.

> That seems to be deeming it to be out of scope because it is a new idea not already implemented. Now I am retired and just at home with a laptop computer and some budget software and a small personal webspace hosted by a United Kingdom Internet Service Provider. So I do what I can but I am restricted in what I can do myself.

We certainly welcome contributions from all individuals. For example, implementing an instance of a semantic extractor language for a common IoT data model should not require more than a laptop and budget (free) software, and that would be very useful for this work.

> It seems to me that if the idea could be of benefit then it should be given fair consideration on its merits and maybe some way of progressing could be found, such as, for just one example,  a group project for some students somewhere to have a go at developing it.

I'm not at all against this.

>>> I think we should not restrict ourselves to URI-addressable things only since some of the interesting ones seem to be lacking URI format today. But looking into defining new URI formats and media types when needed sounds like a good idea.
> 
> As I wrote before, I am new to this field. If my ideas are found to be out of scope when a scientific  assessment of what they would do in the The Internet of Things is made then so be it.

If we define the scope for this work item as "models that are already widely in use and/or we envision being used widely for IoT" (as discussed above), then, to best of my knowledge, the specific idea of localizable sentences as a target language would be out of scope. But I'm happy to be proven wrong.

In the quoted text above I was referring to formats that are common for IoT-like deployments but don't have yet standardized URI formats (e.g., Modbus).

Cheers,
Ari

> Cc: "Christian Amsüss" <[email-masked]>; "[email-masked]" <[email-masked]>
>> During the summer I made some posts, in particular there is the thread as follows.
>> 
>> Could you possibly consider whether it is relevant to include my idea of localizable sentences (possibly embedded within a JSON file) in your list please?
> 
>> To: "Christian Amsüss" <[email-masked]>; "[email-masked]" <[email-masked]>
>>> Could we collect some of candidate target lanuages? AFAIR mentioned plus
>>> what comes to my mind:
>>> 
>>> * modbus
>>> * JSON data from Alexa
>>> * HTML?
>>> * OCF data

---

From: ivaylo petrov <[email-masked]>
Date: Mon, 14 Jan 2019 09:49:15 +0100

Dear all,

In Acklio we are working on extractors and encoders that can transform
binary data to/from JSON-LD. They are based on the YANG modeling language.
We have been discussing having a small test system where people will be
able to test the language and provide feedback. I will let you know as soon
as we have something more concrete (a running test system for example).

Cheers,
--
Ivaylo Petrov
Chief Architect
ivaylo at ackl.io

www.ackl.io

1137A avenue des Champs Blancs,
35510 Cesson Sévigné
FRANCE

Phone: +33 (0)2 22 06 05 77

IMPORTANT NOTICE: The contents of this email and any attachments are
confidential and may also be privileged. If you are not the intended
recipient, please notify the sender immediately and do not disclose the
contents to any other person, use it for any purpose, or store or copy the
information in any medium. Thank you!