Subject: Re: [T2TRG] IoT Edge Challenges and Functions

From: Rute Sofia <[email-masked]>
Date: Mon, 3 Feb 2020 10:35:33 +0000

Dear Xavier,

a couple of comments/suggestions:

-        Section 3.3, where edge it is mentioned that computing/storage are placed “at the edge of the Internet”, I would suggest saying “the closest to data sources”. The definition of “closest proximity” should also be defined, given that this may not always mean physical proximity.

“It works on both downstream data on behalf of cloud
   services and upstream data on behalf of IoT services.

-        “

o   I get the idea; however, perhaps this could be made more clear…IoT services are also cloud based. Maybe you mean IoT devices?

“An edge device is any computing or networking resource residing

   between data sources and cloud-based datacenters”

o   The edge device here is being defined as a functional entity, computational or network. However, the definition is confusing (any computing or networking resource residing between data sources and cloud-based datacenters). Are you instead referring to networking and computing services?

o   Later, in section 4 you refer to “edge computing node”. Perhaps the “node” terminology would serve best the definition of an edge entity, than “device”?

o   An edge device can be an end-user device…the current definition, stating that end-user devices consume and produce data; and that edge devices do the processing of services and computation/storage goes against the possibility of having end-user devices actually also processing services and providing computation/storage…

-        Section 4, I would suggest also addressing Mobility as a challenge; and also the required support for decentralised services (micro-service architectures)

o   On the Time sensitivity, there is also the issue of having to handle, on the edge, multiple types of traffic (TT and event-driven, for instance) across different mediums (wired *and* wireless).

o   4.4, on privacy and security for the Industrial example, the issue is a bit more complex. Industrial environments can and often integrate third-party suppliers, and therefore, the issue is accountability, in particular, decentralised accountability, and not just dumping data from ioT devices into the cloud (which is actually often done).

o   In Figure 1, IMO making a clear split between an end-user device and an edge device means that the edge device (node) notions being described are not taking into consideration the fact that end-user devices, such as smartphones, can actually today process, store, and route data…

Best regards,

Rute Sofia

From: T2TRG <[email-masked]> On Behalf Of Xavier de Foy
Sent: 18 January 2020 01:13
To: [email-masked]
Subject: [T2TRG] IoT Edge Challenges and Functions

Hi all,

  In this new revision of draft-hong-t2trg-iot-edge-computing we developed  section 5 on model and functions, made minor changes to the rest of the document, and reorganized the sections.

  Comments and suggestions are welcome. The document should be ready for review (some people volunteered to do so in the Singapore T2TRG meeting).

  Best Regards,

Xavier, on behalf of all co-authors

---

A new version of I-D, draft-hong-t2trg-iot-edge-computing-02.txt
has been successfully submitted by Xavier de Foy and posted to the IETF repository.

Name:draft-hong-t2trg-iot-edge-computing
Revision:02
Title:IoT Edge Challenges and Functions
Document date:2020-01-17
Group:Individual Submission
Pages:29
URL:            https://www.ietf.org/internet-drafts/draft-hong-t2trg-iot-edge-computing-02.txt
Status:         https://datatracker.ietf.org/doc/draft-hong-t2trg-iot-edge-computing/
Htmlized:       https://tools.ietf.org/html/draft-hong-t2trg-iot-edge-computing-02
Htmlized:       https://datatracker.ietf.org/doc/html/draft-hong-t2trg-iot-edge-computing
Diff:           https://www.ietf.org/rfcdiff?url2=draft-hong-t2trg-iot-edge-computing-02

Abstract:
   Many IoT applications have requirements that cannot be met by
   the traditional Cloud (aka Cloud computing).  These include time
   sensitivity, data volume, uplink cost, operation in the face of
   intermittent services, privacy and security.  As a result, the IoT is
   driving the Internet toward Edge computing.  This document outlines
   the requirements of the emerging IoT Edge and its challenges.  It
   presents a snapshot of the state-of-the-art, a general model, and
   major components of the IoT Edge, with the goal to provide a common
   base for future discussions in T2TRG and other IETF WGs and RGs.

---

From: Xavier de Foy <[email-masked]>
Date: Mon, 3 Feb 2020 17:28:37 -0500

Hi Rute, thanks for the comments. Please see below.
Best Regards,
Xavier

---------- Forwarded message ---------
From: Rute Sofia <[email-masked]>
Date: Mon, Feb 3, 2020 at 5:35 AM
Subject: RE: [T2TRG] IoT Edge Challenges and Functions
To: Xavier de Foy <[email-masked]>, [email-masked] <[email-masked]>

Dear Xavier,

-        Section 3.3, where edge it is mentioned that computing/storage are
placed “at the edge of the Internet”, I would suggest saying “the closest
to data sources”. The definition of “closest proximity” should also be
defined, given that this may not always mean physical proximity.

-        “

o   I get the idea; however, perhaps this could be made more clear…IoT
services are also cloud based. Maybe you mean IoT devices?

o   The edge device here is being defined as a functional entity,
computational or network. However, the definition is confusing (any
computing or networking resource residing between data sources and
cloud-based datacenters). Are you instead referring to networking and
computing services?

o   Later, in section 4 you refer to “edge computing node”. Perhaps the
“node” terminology would serve best the definition of an edge entity, than
“device”?

o   An edge device can be an end-user device…the current definition,
stating that end-user devices consume and produce data; and that edge
devices do the processing of services and computation/storage goes against
the possibility of having end-user devices actually also processing
services and providing computation/storage…

[xavier] Thank you about your comments on section 3.3, we will think on how
to clarify the top part of the section in a future revision.

Section 4, I would suggest also addressing Mobility as a challenge; and
also the required support for decentralised services (micro-service
architectures)

[xavier] I agree mobility and decentralized service support are important
challenges. The way we have structured the draft so far, these discussions
should be in section 5 (IMO, based on the following).

Our goal was to list in section 4 the challenges in IoT, which lead to the
emergence of edge/fog computing. We placed the discussion of the challenges in
developing edge computing in section 5, integrated with the functional
decomposition.

Mobility/decentralization are mentioned to some extent in section 5 (and
can be improved there): section 5.1.4. is on decentralized service support.
A mobility related challenge is listed in 5.2.3 ("relocating an instance
from one compute node to another").

o   On the Time sensitivity, there is also the issue of having to handle,
on the edge, multiple types of traffic (TT and event-driven, for instance)
across different mediums (wired **and** wireless).

[xavier] Thanks, I am not completely sure this needs to be reflected in the
text (the existing latency/jitter guarantees challenge may be sufficient as
it is, the fact that there are multiple traffic types to handle does not
seem to further require edge computing).

o   4.4, on privacy and security for the Industrial example, the issue is a
bit more complex. Industrial environments can and often integrate
third-party suppliers, and therefore, the issue is accountability, in
particular, decentralised accountability, and not just dumping data from
ioT devices into the cloud (which is actually often done).

[xavier] Thanks, we should mention in 4.4. the additional risk from
integrating devices from third-party suppliers, in a future revision.

o   In Figure 1, IMO making a clear split between an end-user device and an
edge device means that the edge device (node) notions being described are
not taking into consideration the fact that end-user devices, such as
smartphones, can actually today process, store, and route data…

[xavier] Agreed (plan to address in future revision).

Best regards,

Rute Sofia

*From:* T2TRG <[email-masked]> *On Behalf Of *Xavier de Foy
*Sent:* 18 January 2020 01:13
*To:* [email-masked]
*Subject:* [T2TRG] IoT Edge Challenges and Functions

Hi all,

  In this new revision of draft-hong-t2trg-iot-edge-computing we developed
section 5 on model and functions, made minor changes to the rest of the
document, and reorganized the sections.

  Comments and suggestions are welcome. The document should be ready for
review (some people volunteered to do so in the Singapore T2TRG meeting).

  Best Regards,

---

A new version of I-D, draft-hong-t2trg-iot-edge-computing-02.txt
has been successfully submitted by Xavier de Foy and posted to the IETF
repository.

Name:draft-hong-t2trg-iot-edge-computing
Revision:02
Title:IoT Edge Challenges and Functions
Document date:2020-01-17
Group:Individual Submission
Pages:29
URL:
https://www.ietf.org/internet-drafts/draft-hong-t2trg-iot-edge-computing-02.txt
Status:
https://datatracker.ietf.org/doc/draft-hong-t2trg-iot-edge-computing/
Htmlized:
https://tools.ietf.org/html/draft-hong-t2trg-iot-edge-computing-02
Htmlized:
https://datatracker.ietf.org/doc/html/draft-hong-t2trg-iot-edge-computing
Diff:
https://www.ietf.org/rfcdiff?url2=draft-hong-t2trg-iot-edge-computing-02

Abstract:

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 10 Feb 2020 16:20:41 +0000 (GMT)

Hi

The Unicode Language Tag character and The Internet of Things

Here is a link to a post in the Unicode public mailing list that I wrote 
earlier today.

https://www.unicode.org/mail-arch/unicode-ml/y2020-m02/0009.html

Any replies to the Unicode public mailing list will become automatically 
placed in the archive and linked from the following web page.

https://www.unicode.org/mail-arch/unicode-ml/y2020-m02/index.html

William Overington

Monday 10 February 2020