Subject: Re: [T2TRG] OpenAPI/AsyncAPI discussion from April 24th WISHI online meeting

From: Jonathan Beri <[email-masked]>
Date: Thu, 11 Jun 2020 14:50:39 -0700

I'd like to continue the discussion around OpenAPI & CoAP. I've been
spending some time analyzing both CoAP (and related CoRE specs) as well as
OpenAPI in the hopes to create a report of some sorts, as well as a few
examples. What's the best way to connect with the other interested parties
from previous calls, especially as it relates to WoT?

On Sun, Apr 26, 2020 at 5:06 PM Jonathan Beri <[email-masked]> wrote:

> During the last WISHI meeting I brought up interest in exploring the
> adaptation of API specifications OpenAPI (openapis.org) and AsyncAPI (
> asyncapi.com) to CoAP. The discussion starts at line 164 of the notes (
> https://hackmd.io/lY_ktzBjTuSu_5oh3u20Bg?both.)
>
> Michael K. & Michael M. suggested a few action items:
>
>    - Create an example Thing Description and see how semantics map to
>    OpenAPI/Async
>    - Identify use cases for developers in WoT, such as Node-Red
>    - Document scope and overlap between different specs
>
> A few follow-ups from me:
>
>    - Are others who weren't on the call interested in collaborating on
>    this topic?
>    - What should be next steps? Should we target an upcoming meeting?
>
> Many thanks.
>
> --
> Jonathan Beri
> linkedin.com/in/jonathanberi <https://www.linkedin.com/in/jonathanberi/>
>

-- 
Jonathan Beri
linkedin.com/in/jonathanberi <https://www.linkedin.com/in/jonathanberi/>

---

From: Ari Keränen <[email-masked]>
Date: Fri, 12 Jun 2020 06:04:33 +0000

Hi Jonathan,

Sounds good I think a good way is to continue discussion in the next WISHI call. We have this on the draft agenda on the 30th:
https://github.com/t2trg/wishi/wiki/Agenda-items#wishi-online-meeting

We have folks from W3C WoT joining too.

Cheers,
Ari

On 12.6.2020, 0.51, "T2TRG on behalf of Jonathan Beri" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

I'd like to continue the discussion around OpenAPI & CoAP. I've been spending some time analyzing both CoAP (and related CoRE specs) as well as OpenAPI in the hopes to create a report of some sorts, as well as a few examples. What's the best way to connect with the other interested parties from previous calls, especially as it relates to WoT?

On Sun, Apr 26, 2020 at 5:06 PM Jonathan Beri <[email-masked]<mailto:[email-masked]>> wrote:
During the last WISHI meeting I brought up interest in exploring the adaptation of API specifications OpenAPI (openapis.org<https://protect2.fireeye.com/v1/url?k=92eadff0-cc4a3f6e-92ea9f6b-86ee86bd5107-b06f497f4b53f832&q=1&e=c0cc4f49-fb83-4cad-8754-a238f2e35cbb&u=http%3A%2F%2Fopenapis.org%2F>) and AsyncAPI (asyncapi.com<https://protect2.fireeye.com/v1/url?k=b1506c03-eff08c9d-b1502c98-86ee86bd5107-e8e3841c4ae29f7e&q=1&e=c0cc4f49-fb83-4cad-8754-a238f2e35cbb&u=http%3A%2F%2Fasyncapi.com%2F>) to CoAP. The discussion starts at line 164 of the notes (https://hackmd.io/lY_ktzBjTuSu_5oh3u20Bg?both.)

Michael K. & Michael M. suggested a few action items:
· Create an example Thing Description and see how semantics map to OpenAPI/Async
· Identify use cases for developers in WoT, such as Node-Red
· Document scope and overlap between different specs
A few follow-ups from me:
· Are others who weren't on the call interested in collaborating on this topic?
· What should be next steps? Should we target an upcoming meeting?
Many thanks.

--
Jonathan Beri
linkedin.com/in/jonathanberi<https://protect2.fireeye.com/v1/url?k=9cf36e3a-c2538ea4-9cf32ea1-86ee86bd5107-8c0e24e45275cac5&q=1&e=c0cc4f49-fb83-4cad-8754-a238f2e35cbb&u=https%3A%2F%2Fwww.linkedin.com%2Fin%2Fjonathanberi%2F>

--
Jonathan Beri
linkedin.com/in/jonathanberi<https://protect2.fireeye.com/v1/url?k=d50b335e-8babd3c0-d50b73c5-86ee86bd5107-c668b4b69ca9a23c&q=1&e=c0cc4f49-fb83-4cad-8754-a238f2e35cbb&u=https%3A%2F%2Fwww.linkedin.com%2Fin%2Fjonathanberi%2F>

---

From: Jonathan Beri <[email-masked]>
Date: Fri, 12 Jun 2020 12:39:18 -0700

Perfect! I'll have some content to share for the discussion.

On Thu, Jun 11, 2020 at 11:04 PM Ari Keränen <[email-masked]>
wrote:

> Hi Jonathan,
>
>
>
> Sounds good I think a good way is to continue discussion in the next WISHI
> call. We have this on the draft agenda on the 30th:
>
> On 12.6.2020, 0.51, "T2TRG on behalf of Jonathan Beri" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>
>
> adaptation of API specifications OpenAPI (openapis.org
> <https://protect2.fireeye.com/v1/url?k=92eadff0-cc4a3f6e-92ea9f6b-86ee86bd5107-b06f497f4b53f832&q=1&e=c0cc4f49-fb83-4cad-8754-a238f2e35cbb&u=http%3A%2F%2Fopenapis.org%2F>)
> and AsyncAPI (asyncapi.com
> <https://protect2.fireeye.com/v1/url?k=b1506c03-eff08c9d-b1502c98-86ee86bd5107-e8e3841c4ae29f7e&q=1&e=c0cc4f49-fb83-4cad-8754-a238f2e35cbb&u=http%3A%2F%2Fasyncapi.com%2F>)
> to CoAP. The discussion starts at line 164 of the notes (
> linkedin.com/in/jonathanberi
> <https://protect2.fireeye.com/v1/url?k=9cf36e3a-c2538ea4-9cf32ea1-86ee86bd5107-8c0e24e45275cac5&q=1&e=c0cc4f49-fb83-4cad-8754-a238f2e35cbb&u=https%3A%2F%2Fwww.linkedin.com%2Fin%2Fjonathanberi%2F>
>
>
>
>
> --
>
> Jonathan Beri
>
> linkedin.com/in/jonathanberi
> <https://protect2.fireeye.com/v1/url?k=d50b335e-8babd3c0-d50b73c5-86ee86bd5107-c668b4b69ca9a23c&q=1&e=c0cc4f49-fb83-4cad-8754-a238f2e35cbb&u=https%3A%2F%2Fwww.linkedin.com%2Fin%2Fjonathanberi%2F>
>