Subject: [T2TRG] ASDF BOF (Fwd: [Asdf] New Non-WG Mailing List: asdf)

From: Carsten Bormann <[email-masked]>
Date: Tue, 7 Jul 2020 17:37:32 +0200

At IETF 108, there will be a BOF with the intent to make the OneDM SDF effort known to the IETF community, and ultimately to win support for taking this protocol to an Internet Standards document in the IETF.

Since much of the IRTF/IETF discussion of SDF so far happened here, I would like to point out that we plan to discuss this in earnest on the mailing list provided, [email-masked], as described below.  Please subscribe if you want to be a part of this discussion (link below).

If you want to prepare yourself for this discussion, please also have a look at https://onedm.org/ <https://onedm.org/> .
This website is still in the process of being set up, but you will find the information needed to understand the SDF format and the desire to standardize it in ASDF.
(And it is about as no-nonsense as it gets, when it comes to websites like this.)

See you all at the BOF at Tuesday, 2020-07-28 11:00 UTC.
Info/Materials: https://datatracker.ietf.org/wg/asdf/meetings/ <https://datatracker.ietf.org/wg/asdf/meetings/>
Calendar entry: https://datatracker.ietf.org/meeting/108/session/28223.ics
Your local time: https://www.timeanddate.com/worldclock/fixedtime.html?msg=ASDF%20BOF&iso=20200728T11&ah=2 <https://www.timeanddate.com/worldclock/fixedtime.html?msg=ASDF%20BOF&iso=20200728T11&ah=2>

Grüße, Carsten

> Begin forwarded message:
> 
> Subject: [Asdf] New Non-WG Mailing List: asdf
> Cc: [email-masked], [email-masked], [email-masked]
> Archived-At: <https://mailarchive.ietf.org/arch/msg/asdf/fcpSGLCFRsPEYvLS6qM1AQVBd7k>
> 
> A new IETF non-working group email list has been created.
> 
> List address: [email-masked]
> Archive: https://mailarchive.ietf.org/arch/browse/asdf/
> To subscribe: https://www.ietf.org/mailman/listinfo/asdf
> 
> Purpose:
> One of the hard problems of building large-scale IoT systems is the
> lack of common data models for IoT and IoT devices. Each IoT standards
> organization, and many IoT platform vendors, have created their own
> version of an IoT data model framework, each with a bespoke meta-model
> and representation language. To achieve the goal of arriving at a
> common set of data and interaction models that describe IoT devices,
> the first step to take was to have a common way how to write down a
> model. The SDF (Semantic Description Format) has been created in the
> One Data Model initiative to serve this purpose. SDF Version 1.0 has
> been used to collect some 200 models describing various kinds of IoT
> devices, the further development and harmonization of which is what
> OneDM will now focus on. The OneDM participants are looking to IETF
> to develop SDF to a fully specified, highly interoperable standard
> that can serve the IoT community in building systems that cross the
> established ecosystems.
> 
> This list belongs to IETF area: ART
> 
> For additional information, please contact the list administrators.
> 
> -- 
> Asdf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/asdf

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 7 Jul 2020 15:32:43 -0500

Hi Carsten,

On Tue, Jul 7, 2020 at 10:37 AM Carsten Bormann <[email-masked]> wrote:

> At IETF 108, there will be a BOF with the intent to make the OneDM SDF
> effort known to the IETF community, and ultimately to win support for
> taking this protocol to an Internet Standards document in the IETF.
>
> Since much of the IRTF/IETF discussion of SDF so far happened here, I
> would like to point out that we plan to discuss this in earnest on the
> mailing list provided, [email-masked], as described below.  Please
> subscribe if you want to be a part of this discussion (link below).
>
> If you want to prepare yourself for this discussion, please also have a
> look at https://onedm.org/ .
> This website is still in the process of being set up, but you will find
> the information needed to understand the SDF format and the desire to
> standardize it in ASDF.
> Info/Materials: https://datatracker.ietf.org/wg/asdf/meetings/
> Your local time:
> https://www.timeanddate.com/worldclock/fixedtime.html?msg=ASDF%20BOF&iso=20200728T11&ah=2
>
> Grüße, Carsten
>
>
>
I could not locate the trac.ietf.org page for ASDF BOF. In fact if you try
to go
https://trac.ietf.org/trac/ietf/meeting/wiki/ietf108
you get an error.

Regards,
Behcet

> Begin forwarded message:
>
> *Subject: **[Asdf] New Non-WG Mailing List: asdf*
> *Cc: [email-masked], [email-masked], [email-masked]
> *Archived-At: *<
> https://mailarchive.ietf.org/arch/msg/asdf/fcpSGLCFRsPEYvLS6qM1AQVBd7k>
>
> _______________________________________________
> T2TRG mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/t2trg
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 8 Jul 2020 06:35:00 +0200

On 2020-07-07, at 22:32, Behcet Sarikaya <[email-masked]> wrote:
> 
> I could not locate the trac.ietf.org page for ASDF BOF. In fact if you try to go

Interesting.

Anyway, the BOF wiki entry for ASDF is at the usual place:

https://trac.tools.ietf.org/bof/trac/wiki#ASDFproposal

Grüße, Carsten

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 8 Jul 2020 09:38:48 -0500

Hi Carsten,

> https://trac.tools.ietf.org/bof/trac/wiki#ASDFproposal

Yes I read it. I don't understand why it is non WG-forming?

Regards.
Behcet