Subject: [T2TRG] T2TRG/WISHI/ASDF/CoRE hackathon @ IETF111: Monday 19th 1400Z

From: Carsten Bormann <[email-masked]>
Date: Sun, 18 Jul 2021 21:26:59 +0200

For the IETF 111 hackathon, we are planning some activities that relate to T2TRG (and its WISHI activity), ASDF, and CoRE.  We are cognizant that many will be on vacation that week, but we still want to get some work done ahead of the IETF111 happening the following week.

We’ll run a kickoff at 1400Z on this Monday (today/tomorrow depending on your timezone: https://www.timeanddate.com/worldclock/fixedtime.html?msg=IETF111+hackathon+T2TRG-WISHI-ASDF-CoRE&iso=20210719T14&ah=1 ).

The main purpose is to see who is planning to do what and to set up collaboration points.
We also want to agree on a time (approximately, but not necessarily exactly 1400Z again) where we have a day sync call Tue to Fri; we’ll announce this here, so if Monday doesn’t work for you, you can chime in later.

You may want to pre-fill below’s CodiMD with any additional information that might be useful for the kickoff (or during the week).  You may also want to register for the hackathon at https://registration.ietf.org/111/new/hackathon/ .

Grüße, Carsten

# T2TRG/WISHI/ASDF/CoRE hackathon @ IETF111

Kickoff: Monday, 2021-07-19, 1400Z (60 min max)

Notes: https://codimd.ietf.org/hackathon-2021-t2trg-111-monday

Meetecho: https://meetings.conf.meetecho.com/interim/?short=5903310f-3a8d-4f3a-93c4-5dbb1c9cb768

Note that we will use meetecho for this meeting.
Please check whether your datatracker account works; if it doesn’t, reset its password or get a new one at:

https://datatracker.ietf.org/accounts/create/

(It is worth doing this ahead of time as there may need to be an interaction with the IETF secretariat.)

## Areas of work

### SDF related

* tools (e.g., sdf compact)
* definition(s) of equivalence
* converters (translations) from SDF to X, from X to SDF
    * YANG (sdf-yang-converter.org) (*)
    * WoT (sdf-wot-converter.org)
    * IPSO/LwM2M (https://github.com/EricssonResearch/ipso-odm)
    * OCF?
    * Azure DTDL (*)
        * curl --data-urlencode [email-masked] http://wishi.nomadiclab.com:8083/odm2dtdl
* CI pipeline to keep translations up to date?

### CoRE related

* CoRE resource directory? (*)
* CoRAL, particularly -href (CRIs) (*)

### Others?

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 19 Jul 2021 18:39:54 +0200

Today, we scheduled the next daily meeting for

https://codimd.ietf.org/hackathon-2021-t2trg-111-tuesday
start time: 2021-07-20 14:00:00 UTC max duration: 60
(We needed 45 min today.)

https://www.timeanddate.com/worldclock/fixedtime.html?msg=IETF111+hackathon+T2TRG-WISHI-ASDF-CoRE&iso=20210720T14&ah=1

https://meetings.conf.meetecho.com/interim/?short=d49f0f3b-52d5-4a30-8a75-e2f2effec8b0

Notes from today’s meeting are at https://codimd.ietf.org/hackathon-2021-t2trg-111-monday

Grüße, Carsten

> On 2021-07-18, at 21:26, Carsten Bormann <[email-masked]> wrote:
> 
> _______________________________________________
> T2TRG mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/t2trg

---

From: <[email-masked]>
Date: Mon, 19 Jul 2021 17:45:30 +0100

Hi Carsten,

OCF converters are available:
https://github.com/openconnectivityfoundation/SDFtooling

Kind Regards,
Wouter

-----Original Message-----
From: ASDF <[email-masked]> On Behalf Of Carsten Bormann
Sent: Monday 19 July 2021 17:40
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Asdf] [T2TRG] T2TRG/WISHI/ASDF/CoRE hackathon @ IETF111: Tuesday 20th 1400Z

https://codimd.ietf.org/hackathon-2021-t2trg-111-tuesday
start time: 2021-07-20 14:00:00 UTC max duration: 60 (We needed 45 min today.)

Grüße, Carsten

> Meetecho: 
> https://meetings.conf.meetecho.com/interim/?short=5903310f-3a8d-4f3a-9
> 3c4-5dbb1c9cb768
> 
>        * curl --data-urlencode [email-masked] 
> http://wishi.nomadiclab.com:8083/odm2dtdl

--
ASDF mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/asdf

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 19 Jul 2021 18:49:38 +0200

> https://github.com/openconnectivityfoundation/SDFtooling

Thanks!
I put that into today’s notes:

https://codimd.ietf.org/hackathon-2021-t2trg-111-monday?edit

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 20 Jul 2021 15:08:11 +0200

[narrowed to t2trg/asdf]

When ingesting and processing SDF, the processing may need the resolved result of using sdfRef.
Beside the namespace juggling, there also is the possibility that the named qualities map that contains the sdfRef also has overrides [1].

[1]: https://www.ietf.org/archive/id/draft-ietf-asdf-sdf-07.html#section-4.4-5

I ran a quick script against the playground to find out what those overrides might be.
I found a lot of places that have “label” overrides that are totally redundant with the name of the named quality the sdfRef is used in.
I think we may want to reconsider if this redundant information should be in those references; we’d have mostly clean (non-overridden) references otherwise.  I think I’d rather get rid of “label” than have these redundant entries.

The other recurring pattern is providing a “default” override.  Now that is very similar to your typical constructor parameter:  This essentially provides an initial value to the instance.  So far, this is used in only two models:

DEFAULT: 0 Zigbee Alliance ./sdfObject/sdfobject-level.sdf.json
DEFAULT: 0 Zigbee Alliance ./sdfObject/sdfobject-level.sdf.json
DEFAULT: [] Zigbee Alliance ./sdfObject/sdfobject-level.sdf.json
DEFAULT: 0 Zigbee Alliance ./sdfObject/sdfobject-onoff.sdf.json
DEFAULT: 0 Zigbee Alliance ./sdfObject/sdfobject-onoff.sdf.json

Maybe we don’t want to lump instantiation parameters like this in the general override mechanism?

It is also a bit unclear to me what “default” actually means; the spec is a bit terse here, only saying “specifies the default value for initialization”.  Here we are again, “initialization”!

All the “default” qualities are on named sdfProperties; as these are essentially instance variables of the containing sdfObject, the analogy to “initialization” actually does make sense.  It is less clear what the default quality would mean for, say, sdfOutputData, or, worse, nested in compound data types or choices buried in dataqualities.

Grüße, Carsten

> On 2021-07-19, at 18:39, Carsten Bormann <[email-masked]> wrote:
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 21 Jul 2021 14:34:03 +0200

… and today’s meeting is at

https://codimd.ietf.org/hackathon-2021-t2trg-111-wednesday
start time: 2021-07-21 14:00:00 UTC max duration: 60

https://www.timeanddate.com/worldclock/fixedtime.html?msg=IETF111+hackathon+T2TRG-WISHI-ASDF-CoRE&iso=20210721T14&ah=1

https://meetings.conf.meetecho.com/interim/?short=757a6832-77c3-43e6-8d06-a980949ea7dd

Notes from yesterday’s meeting are at https://codimd.ietf.org/hackathon-2021-t2trg-111-tuesday

See you in 90 min...

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 22 Jul 2021 15:19:28 +0200

https://codimd.ietf.org/hackathon-2021-t2trg-111-thursday
start time: 2021-07-22 14:00:00 UTC duration: 60

https://www.timeanddate.com/worldclock/fixedtime.html?msg=IETF111+hackathon+T2TRG-WISHI-ASDF-CoRE&iso=20210722T14&ah=1

https://meetings.conf.meetecho.com/interim/?short=f993baa2-1946-4ee9-ba92-1f5b9a107329

We’ll mostly focus on CI work for getting converter outputs disseminated.

Notes from yesterday’s meeting are at https://codimd.ietf.org/hackathon-2021-t2trg-111-wednesday

See you in 40 min...

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 23 Jul 2021 15:49:17 +0200

… and the last one for this hackathon week:

https://codimd.ietf.org/hackathon-2021-t2trg-111-friday
start time: 2021-07-23 14:00:00 UTC duration: 60

https://meetings.conf.meetecho.com/interim/?short=199772c0-3880-461b-993b-94828a1239dd

https://www.timeanddate.com/worldclock/fixedtime.html?msg=IETF111+hackathon+T2TRG-WISHI-ASDF-CoRE&iso=20210723T14&ah=1

We’ll mostly focus on wrapping up and presenting results in the evenening hackathon finale.

Notes from yesterday’s meeting are at https://codimd.ietf.org/hackathon-2021-t2trg-111-thursday

See you in 10 min...

Grüße, Carsten