Subject: Re: [T2TRG] arguments for Edge

From: Aaron Ding <[email-masked]>
Date: Sat, 03 Jul 2021 09:15:11 +0200

Nice deduction and bufferbloat hint.

For colleagues interested, this 'Revisit Edge' is now on IEEE Internet 
Computing:
https://ieeexplore.ieee.org/document/9470987

Aaron

On 27.06.2021 13:10, Dave Taht wrote:
> I think the arguments for re-invigorating the edge are stronger than 
> ever.
> 
> But first up, we gotta fix the bufferbloat everywhere.
On 27.06.2021 17:20, Phillip Hallam-Baker wrote:
> The paper states typical latency is 30ms
> 
> Thus we are limited to 15 round trips per second.
> 
> I have a 960Gbs = 120 GBs Internet connection
> 
> Assuming 1260 byte packets, that means 95238 packets a second
> 
> So we must have an average of 3174 packets unacknowledged at 30ms 
> latency
> 
> Get latency down to 1ms and the number of unacknowledged packets goes 
> down
> to 100.
> 
> On Sun, Jun 27, 2021 at 5:15 AM Aaron Ding wrote:
>> 
>> Is the motive for Edge (i.e., latency) diminishing since its first
>> concepts were formulated more than a decade ago?
>> 
>> A recent work to share on "Revisiting the Arguments for Edge Computing
>> Research":
>> https://arxiv.org/pdf/2106.12224.pdf

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sat, 3 Jul 2021 12:08:31 -0400

I haven't really thought about routing since doing my undergrad thesis 35
years ago. And that wasn't on Internet routing. Since I have been focused
on the application layer and above, I haven't really thought about routing
as something which is mutable. So I learned how it worked, and that is it.

Having had occasion to do a writeup on BGP etc for a client recently, it
occurs to me that there is more that could be done if we were to relearn
some of the original principles of the Internet that Einar Stefferud used
to do a very good presentation on.

The Internet is a network of networks and that is NOT the same as a
network. So the Internet needs to be really really simple. Just take a
packet, do a lookup, shove it down a pipe.

But on the way, we have acquired a number of assumptions that are actually
false:

1) The End to End principle should only apply across the origin and final
destination.
2) Communications should be Internet Protocol start to finish.
3) Every packet needs a source address.
4) DNS is the only naming system we need.
5) ASNs are just an optimization to compress routing.
6) Multicast proves nothing can be done at the routing level because it
can't be deployed.

For the past two and a half years, I have been working on re-engineering
the security side of the Internet and have come up with an architecture and
implementation that addresses what I see as the biggest, most urgent
security problem today: securing Data At Rest. To solve this problem, I had
to solve the problem of how to manage private keys which is actually the
real roadblock to applying PKI to user side security.

There is one really big security issue I haven't addressed in the Mesh and
it is going to be an increasingly big one as we face nation state level
attacks: Denial of Service. To date we have only come up with mitigations.

If we are going to come up with a DoS defense that is effective against
nation state level actors, we are going to need to change the way routing
is done.

What I would like is some sort of forum that is more like a room in 545
Tech square with a lot of whiteboards and conversation under Chatham house
rules and 'there are no stupid proposals' rules.

Also, I think we need to go back to look at buffer bloat and ask how it
actually occurs and whether it is a routing level or a TCP level issue. I
have a feeling there is a bit more going on there.