Subject: [T2TRG] I-D Action: draft-irtf-t2trg-rest-iot-09.txt

From: [email-masked]
Date: Sat, 26 Feb 2022 12:49:59 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Thing-to-Thing RG of the IRTF.

        Title           : Guidance on RESTful Design for Internet of Things Systems
        Authors         : Ari Keranen
                          Matthias Kovatsch
                          Klaus Hartke
	Filename        : draft-irtf-t2trg-rest-iot-09.txt
	Pages           : 35
	Date            : 2022-02-26

Abstract:
   This document gives guidance for designing Internet of Things (IoT)
   systems that follow the principles of the Representational State
   Transfer (REST) architectural style.  This document is a product of
   the IRTF Thing-to-Thing Research Group (T2TRG).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-t2trg-rest-iot/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-irtf-t2trg-rest-iot-09.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-irtf-t2trg-rest-iot-09

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Ari Keränen <[email-masked]>
Date: Sat, 26 Feb 2022 21:00:17 +0000

This was a (long overdue) update with fixes to the nits from Carsten's chair review (https://github.com/t2trg/t2trg-rest-iot/pull/59) and clarification on PUT side effects (https://github.com/t2trg/t2trg-rest-iot/pull/58). Next, we plan to make PRs of the more substantial chair review comments for RG review.

Cheers,
Ari

T2TRG <[email-masked]> on behalf of [email-masked] <[email-masked]> Saturday, February 26, 2022 10:49 PM