Subject: [tao-discuss] First draft of new version

From: Niels ten Oever <[email-masked]>
Date: Thu, 31 May 2018 17:07:10 +0200

Dear all,

I have made a first pass over the Tao and sought to make some
improvements. I will make another pass but I also wanted to see whether
people have suggestions or improvement on this new versions.

Comments are very welcome here (txt with my edits attached, as well as
the current Tao), but also pull requests on github:
https://github.com/nllz/Tao-of-the-IETF/blob/master/Tao.txt

Else expect a new version before IETF102.

Best,

Niels

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 31 May 2018 18:57:54 +0100

Niels,

Thanks for summoning the energy for this work. The Tao is immensely important as a gateway to the IETF and facilitates an understanding of our peculiar "culture" and so makes participation by newcomers much easier.

Here are a few thoughts with my ISE hat on.

Cheers,
Adrian.

1.
You have: "RFCs are the IETF's main technical documentation series,"
This may give the impression that you are defining RFCs, but they have wider scope.
How about...
"The IETF publishes its main technical documentation as RFC,"

2.2.5
s/the RFC Editor and IANA involved/the RFC Editor and IANA are involved/

2.2.5
All Internet-Drafts are posted under the same copyright, IPR, and other rules, so it may be better to change as...
OLD
The RFC Editor edits, formats, and publishes Internet-Drafts as RFCs, working in conjunction
with the IESG for IETF drafts, the IRTF Chair for IRTF drafts, the IAB for IAB drafts, and the 
Independent Submissions Editor for Independent Submission drafts, and of course the
work with the author(s).
NEW
The RFC Editor edits, formats, and publishes Internet-Drafts as RFCs, working in conjunction
with the IESG for IETF RFCs, the IRTF Chair for IRTF RFCs, the IAB for IAB RFCs, and the 
Independent Submissions Editor for Independent Submission RFC, and of course 
working with the authors.
END

2.2.5 
I think this may be the right place to cover another significant misconception. We should certainly cover it somewhere and this looks as good a place as any. Something like...
"Another misconception common in the IETF and across the industry as a whole is that all RFCs are the work of the IETF. In fact, of the four sources of RFCs listed above (IETF, IAB, IRTF, and Independent Submissions), only those coming direct from the IETF  through working groups or sponsored by ADs are capable of having IETF consensus and being described as IETF specifications or standards."

4.3
s/WG drafts and independent drafts/WG drafts and individual drafts/
s/discuss independent drafts/discuss individual drafts/
(or "personal drafts")

6.
I think it would be helpful to clarify the scope of this section with text like...
"This section discusses Internet-Drafts and RFCs in the IETF stream, that is, it describes how documents are produced and advanced within the IETF. For a brief note on other RFC streams, see Section 2.2.5."

> -----Original Message-----
> From: tao-discuss [mailto:[email-masked]] On Behalf Of Niels ten
> Oever
> Sent: 31 May 2018 16:07
> To: [email-masked]
> Subject: [tao-discuss] First draft of new version
> 
> Dear all,
>

---

From: Russ Housley <[email-masked]>
Date: Thu, 31 May 2018 14:57:21 -0400

> On May 31, 2018, at 11:07 AM, Niels ten Oever <[email-masked]> wrote:
> 
> Dear all,
> 

Thanks for your work on the Tao.  I appreciate it.

RFC 6722 says that the Tao will be available at https://www.ietf.org/tao.html <https://www.ietf.org/tao.html>.  It is not being redirected to https://www.ietf.org/about/participate/tao/ <https://www.ietf.org/about/participate/tao/>, which seems fine, but the document should point to the same URL as RFC 6722.

Russ

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 1 Jun 2018 14:13:41 +1200

Niels,

Thanks. I made myself a side-by-side diff, so I've attached it for
anybody else's convenience.

A few comments, somewhat random:

> The current Areas and abbreviations are shown below (more information
> can be found here: https://www.ietf.org/topics/areas/).

I wonder about including the current list of Areas. They do change, and
apparently more often than the Tao changes. Maybe it would be better
just to include the pointer?

> Because the IESG has a great deal of influence on whether
> Internet-Drafts become RFCs, many people look at the ADs as somewhat
> godlike creatures. IETF participants sometimes reverently ask Area
> Directors for their opinion on a particular subject. However, most ADs
> are nearly indistinguishable from mere mortals and rarely speak from
> mountaintops. In fact, when asked for specific technical comments, the
> ADs may often defer to IETF participants whom they feel have more
> knowledge than they do on that topic.

I can see why you might not like the tone of this paragraph, but
I think it makes an important point, and should be rewritten rather
than deleted. Newcomers really need to understand that ADs are just
people.

> The RFC Editor edits, formats, and publishes Internet-Drafts as RFCs,
> working in conjunction with the IESG for IETF drafts, the IRTF Chair for
> IRTF drafts, the IAB for IAB drafts, and the Independent Submissions
> Editor for Independent Submission drafts, and of course the work with
> the author(s). An important secondary role is to provide one definitive
> repository for all RFCs 

Actually I don't think the repository role is secondary at all; it's
essential.

> The Sunday is an excellent day to join the meeting...

How about :

  If you are not attending the hackathon, Sunday is an excellent day to
join the meeting...

> It's worth noting that neither attendee names and addresses nor IETF
> mailing lists are ever offered for sale.

You've deleted that, but I think it should be replaced by a pointer
to the privacy policy that was just updated for GDPR.

> One of the most important (depending on your point of view) things the
> host does is provide unfethered Internet access for the meeting

If this is a reference to RFC 1149, there is a spelling mistake.

> , continental breakfast on Monday through Friday
> mornings (depending on the meeting venue),

Why delete that? It's still true.

Regards,
     Brian

Regards
   Brian Carpenter