Subject: [tao-discuss] Fwd: Re: what to do about missing cites and encouraging better citing

From: Brian E Carpenter <[email-masked]>
Date: Wed, 27 Jun 2018 08:36:17 +1200

Forwarding this because it includes:

> I think a note on the IETF norms for referencing other RFCs to be a good 
> thing to include in the Tao.

And maybe some of the waffle in https://tools.ietf.org/html/draft-carpenter-whats-an-author would also fit in the Tao?

   Brian

-------- Forwarded Message --------
Subject: Re: what to do about missing cites and encouraging better citing
Date: Tue, 26 Jun 2018 13:24:12 -0700
From: Heather Flanagan (RFC Series Editor) <[email-masked]>
To: [email-masked]

On 6/25/18 12:52 AM, John C Klensin wrote:
>
> --On Sunday, June 24, 2018 17:14 -0700 Randy Bush
> <[email-masked]> wrote:
>
>>> but didn't detect great enthusiasm in the community for
>>> dealing with authorship ethics in general.
>> how embarrassing and shameful
> Randy,
>
> While I agree that this is embarrassing and shameful (and could
> add other words), I question one aspect of your earlier note.
>
> At least until the IAB decides to micromanage that, an erratum
> and its appropriateness is determined by the discretion of the
> RFC Series Editor.  The term is arguably not precisely correct
> for the way we use the things and I've seen many of them whose
> subject matter or content would not be appropriate if the
> classic publisher definition were used.
>
> So I would recommend a conversation with Heather (copied) and
> use of the errata mechanism, at least unless she strongly
> disagrees and wants to propose another mechanism.  That would at
> least get citation on the record.  While I'm not optimistic, if
> author(s) are shamed sufficiently to not omit such citations in
> the future, that would be A Good Thing.  I think all of us
> should be encouraged to watch for obvious omissions on Last Call
> and would encourage document shepherds and responsible ADs (in
> the IETF Stream) and reviewers (in others) to pay attention to
> the issue.

Heather does not disagree - the errata system is the best mechanism we 
have at this time, and it does allow an author to respond as needed.

>
> I would suggest to Heather that a mention of this as the Style
> Guide evolves would probably also be a good thing -- it isn't as
> if adding relevant citations is difficult or costly.

This is going to be a bit trickier. I'm supportive of adding something 
about author ethics, but it would be along the lines of "the RFC Editor 
will not be checking on this; you should do this because it's the right 
thing." We don't have the resources to do a full-on review of the 
literature; if the IETF wants that as a priority, we'll need to talk 
about costs and/or reprioritizing other RFC Editor activities.

I think a note on the IETF norms for referencing other RFCs to be a good 
thing to include in the Tao.

-Heather

>
> We will probably never get everything right, but we can try
> harder.
>
> best,
>     john
>

---

From: Niels ten Oever <[email-masked]>
Date: Wed, 27 Jun 2018 14:12:23 +0200

Sounds good to me. Would you have concrete suggestions?

Best,

Niels

On 06/26/2018 10:36 PM, Brian E Carpenter wrote:
> _______________________________________________
> tao-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tao-discuss
> 

-- 
Niels ten Oever
Researcher and PhD Candidate
Datactive Research Group
University of Amsterdam

PGP fingerprint	   2458 0B70 5C4A FD8A 9488
                   643A 0ED8 3F3A 468A C8B3

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 30 Jun 2018 14:31:14 +1200

Niels,

Sorry, I'm out of time before the IETF but you are very welcome to
cut & paste any of my text that you want.

Regards
   Brian