Subject: Re: [tao-discuss] New Version of the Tao of the IETF

From: Niels ten Oever <[email-masked]>
Date: Thu, 3 Oct 2019 16:16:45 +0200

Thanks Corinne,

Am sending this to tao-discuss, where the Tao is being discussed, to ensure your valuable review does not get lost.

I made the changes in:
https://github.com/nllz/Tao-of-the-IETF/blob/master/Tao.md

@Greg and Kathleen - are these changes minor enough that we can direcly change them, or should we wait for a new version before we can push this?

Please find my comments in-line:

On 9/23/19 6:35 PM, Corinne Cath wrote:
> Hi,
> 
> Thanks for all the work Niels & Kathleen. Some nits: 
> 
> 1. has the Tao been updated to include the new mailinglist that arose out of the flurry of emails on the ietf@ietf mailing list? should it?

Sorry, I have missed this conversation - which emaillist are you referring to?

> 
> 2. related, the current text says that "the ietf discussion list is unmoderated" is that correct? it seems like there is some moderation going on, with interventions from the SAA's (leaving aside the debate about how much moderation is good moderation) which you mention later on in that paragraph.
> 

I think the colloquial understanding of 'unmoderated mailinglist' is:

A moderated mailing list requires each subscriber and message to be approved by the "owner" of a list.

(from: https://www.calvin.edu/~rbobeldy/tutorials/email/elistserv4.htm)

In that sense ietf@ietf is unmoderated.

> 3. "For many people, IETF meetings are a breath of fresh air when compared to the standard computer industry conferences." I am sure this is true, yet  for many people IETF meetings are not necessarily the most pleasant of places, as was reflected in the debate about newcomer experiences during the plenary some 3 or 4 IETFs ago? I understand what you are saying - but maybe some text can be found that takes both those extreme ends into consideration?
> 

Isn't that addressed a couple of paras later when we write:

Newcomers to IETF face-to-face meetings often expect them to be like other standards bodies, or like computer conferences. Fortunately, many new attendees get quite animated about how much fun they are having. On the other hand, IETFers can sometimes be surprisingly direct, sometimes verging on rude. To build a climate in which people of many different backgrounds are treated with dignity, decency, and respect, the IETF has an <a href=“https://www.ietf.org/blog/ietf-anti-harassment-policy/”>anti-harassment policy</a>y, <a href="https://tools.ietf.org/html/rfc7154”>guidelines for conduct</a> and an <a href="https://www.ietf.org/contact/ombudsteam/“>ombudsteam.</a>.

> 4. s/ombudsteam/Ombudsteam
> 

Thanks, will fix

> 5. "If you are participating an IETF meeting for the first time">> insert "in" an 
> 

Thanks, will fix

> 6. s/high volumen/high volume
> 

Thanks, will fix

> 7. s/to the chairs of the working group your/you are
> 

Thanks, will fix

> 8. Okay granted this one is a bit of a gripe, but "dress for the weather" should maybe be dress for hotel A/C and/or the weather, but definitely the A/C, because that one is a given.  

I made that mistake several times as well. Can I propose the following:

At meetings people generally dress informally. Newcomers are sometimes out of place when they show up Monday morning in suits. The general rule is "dress for the weather" (unless you plan to work so hard that you won't go outside, in which case, "dress for comfort (and the hotel A/C!)" is the rule!).

> 
> 9. "3.6 Seeing Spots Before Your Eyes", this strikes me as a Dutchism but maybe I am wrong? Either way it make more sense to change it to "seeing dots"?
> 

This hails back from a time before a Dutch editor, so I think it is not a Dutchism. Can other people weigh in on this?

> 10. (Members of the press wear orange tinted badges with the word 'press' on it.) s/it/them bc badges = plural
> 

Good point, will fix.

> 11. I am a bit confused about this language re:what the terminal room is for: "Although preparation far in advance of the meeting is encouraged, there may be some unavoidable "last minute" things that can be accomplished in the terminal room." makes it sounds a lot more exciting than I have found it to be: a quiet working space where people can print stuff or complain about the network.
> 

Not sure what is confusing here? What could the terminal room be more?

> 12. s/If sponsorship for it is secure/ If sponsorship for it is secured
> 

Thanks, will fix.

> 13. "Small-sized agendas are available for pickup at the registration desk for those with good eyesight who want to keep a copy in their pocket or attached to the back of their badge." Not sure this is necessary: "for those with good eyesight"
>  

This is because the print on these agendas is very small.

> 14. s/behooves/behoves

Thanks, will fix.

> 15. s/This is a hopefully-final time fo/ This is a hopefully-final time for
> 

Thanks, will fix.

> 16. s/and your more likely to receive comments and feedback on your work/ and you are more likely to receive comments and feedback on your work.
> 

Thanks, will fix.

> 17. s/query is not availble/ available 
>  

Thanks, will fix.

> Hope this is helpful!

Yes, very helpful! Thanks a lot for this thorough review!

Best,

Niels

> CCS
> 
> 
> On Thu, May 23, 2019 at 6:45 PM Niels ten Oever <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
>     On May 22, 2019 19:17, Job Snijders <[email-masked] <mailto:[email-masked]>> wrote:
>     >
>     <<snip>>
>     >
>     > Ps Would it be possible to make the Table of Contents listing clickable URIs to anchors, so that one can link directly to a section or paragraph?
>     >
> 
>     Fixed!
> 
>     > On Wed, May 22, 2019 at 19:05 Niels ten Oever <[email-masked] <mailto:[email-masked]>> wrote:
>     >>
>     >> Dear all,
>     >>
>     >> Since 1993 the Tao of the IETF has functioned as a guide for new attendees to the IETF. Over time both the IETF and the Tao have changed. The last revision of the Tao was in 2012, which led us to believe it might be time for a new version. This new version is what we would like to present to you today.
>     >>
>     >> https://ietf.org/tao.html
>     >>
>     >> We, the editors, have built on the work of great editors before us, and benefited greatly from suggestions, comments, and reviews from the community in general, and from the tao-discuss list [0] and the IESG specifically.
>     >>
>     >> We hope you will deem the new version of the Tao an improvement, and above all we hope this will help and stimulate new participants to become part of our community.
>     >>
>     >> Translations of previous versions of the Tao [1] have been contributed by several organizations. If you or your organization would be interested in contributing a translation of this updated version, please contact the IETF Chair.
>     >>
>     >> If you have comments, questions or suggestions, these are all very welcome on the tao-discuss list [0], and we are also very happy with suggestions in the form of pull requests on Github [2].
>     >>
>     >> Best,
>     >>
>     >> Niels ten Oever & Kathleen Moriarty
>     >> Editors of the Tao of the IETF
>     >>
>     >> [0] https://www.ietf.org/mailman/listinfo/tao-discuss
>     >> [1] http://www.ietf.org/tao-translations.html
>     >> [2] https://github.com/nllz/Tao-of-the-IETF/blob/master/Tao.md
>     >> --
>     >> Niels ten Oever
>     >> Researcher and PhD Candidate
>     >> Datactive Research Group
>     >> University of Amsterdam
>     >>
>     >> PGP fingerprint    2458 0B70 5C4A FD8A 9488 
>     >>                    643A 0ED8 3F3A 468A C8B3
>     >>
> 
> 
> 
> -- 
> Corinne Cath - Speth
> Ph.D. Candidate, Oxford Internet Institute & Alan Turing Institute
> 
> Web: www.oii.ox.ac.uk/people/corinne-cath <http://www.oii.ox.ac.uk/people/corinne-cath>
> Email: [email-masked] <mailto:[email-masked]> & [email-masked] <mailto:[email-masked]>
> Twitter: @C_CS

-- 
Niels ten Oever
Researcher and PhD Candidate
DATACTIVE Research Group
University of Amsterdam

PGP fingerprint	   2458 0B70 5C4A FD8A 9488  
                   643A 0ED8 3F3A 468A C8B3

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 3 Oct 2019 23:01:46 +0100

Niels,

FWIW most of the IETF lists have assigned "moderators". Those moderators are responsible for handling messages that don’t make it through (for whatever reason) and usually for handling posts from unsubscribed senders.
I think the term "moderator" is used for the person who has these responsibilities by the list management package.
Whether that means those lists are moderated is therefore something we could discuss. But maybe it is better not to?

Furthermore, in IRC the term "moderation" usually happens post facto and is similar to what Corinne notes the SAAs doing.

I would suggest that the Tao explicitly says what it means. The price of a few extra words for the removal of what turns out to be an ambiguous term (which is, in any case, a buzz word with which some people might not be familiar).

Best,
Adrian

PS. The new mailing list that Corinne is referring to was just announced by Barry Liebe on [email-masked], and is [email-masked]

>> 2. related, the current text says that "the ietf discussion list is unmoderated" is that correct? it seems
>> like there is some moderation going on, with interventions from the SAA's (leaving aside the debate
>> about how much moderation is good moderation) which you mention later on in that paragraph.
>

---

From: Corinne Cath <[email-masked]>
Date: Fri, 4 Oct 2019 05:42:19 +0300

Hi Adrian,

Thank you for the follow up! A quick comment in-line:

On Fri, Oct 4, 2019 at 1:01 AM Adrian Farrel <[email-masked]> wrote:

> Niels,
>
> FWIW most of the IETF lists have assigned "moderators". Those moderators
> are responsible for handling messages that don’t make it through (for
> whatever reason) and usually for handling posts from unsubscribed senders.
>

So maybe it makes sense to add this explainer to the Tao and avoid the
rabbit hole?

> I think the term "moderator" is used for the person who has these
> responsibilities by the list management package.
> Whether that means those lists are moderated is therefore something we
> could discuss. But maybe it is better not to?
>
> Furthermore, in IRC the term "moderation" usually happens post facto and
> is similar to what Corinne notes the SAAs doing.
>
> I would suggest that the Tao explicitly says what it means. The price of a
> few extra words for the removal of what turns out to be an ambiguous term
> (which is, in any case, a buzz word with which some people might not be
> familiar).
>
> Best,
> Adrian
>
> PS. The new mailing list that Corinne is referring to was just announced
> by Barry Liebe on [email-masked], and is [email-masked]
>

Web: www.oii.ox.ac.uk/people/corinne-cath
Email: [email-masked] & [email-masked]
Twitter: @C_CS

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 4 Oct 2019 10:37:35 +0100

I just noticed I wrote…

> I would suggest that the Tao explicitly says what it means.

Shockingly poor use of English!

I meant…

I would suggest that the Tao should say explicitly what it means.

Best,

Adrian

From: Corinne Cath <[email-masked]> 
Sent: 04 October 2019 03:42
To: [email-masked]
Cc: Niels ten Oever <[email-masked]>; Kathleen Moriarty <[email-masked]>; Greg Wood <[email-masked]>; [email-masked]
Subject: Re: [tao-discuss] New Version of the Tao of the IETF

Hi Adrian, 

On Fri, Oct 4, 2019 at 1:01 AM Adrian Farrel <[email-masked] <mailto:[email-masked]> > wrote:

Niels,

So maybe it makes sense to add this explainer to the Tao and avoid the rabbit hole? 

Best,
Adrian

PS. The new mailing list that Corinne is referring to was just announced by Barry Liebe on [email-masked] <mailto:[email-masked]> , and is [email-masked] <mailto:[email-masked]> 

 

-- 

Corinne Cath - Speth

---

From: Kathleen Moriarty <[email-masked]>
Date: Fri, 4 Oct 2019 11:50:53 -0400

I am fine with the suggested edits and following Adrian's guidance.

Bets regards,
Kathleen

On Fri, Oct 4, 2019 at 5:37 AM Adrian Farrel <[email-masked]> wrote:

> *From:* Corinne Cath <[email-masked]>
> *Sent:* 04 October 2019 03:42
> *To:* [email-masked]
> *Cc:* Niels ten Oever <[email-masked]>; Kathleen Moriarty <
> [email-masked]>; Greg Wood <[email-masked]>;
> [email-masked]
> *Subject:* Re: [tao-discuss] New Version of the Tao of the IETF
>
>
>
> Hi Adrian,
>
>
>

-- 

Best regards,
Kathleen

---

From: Niels ten Oever <[email-masked]>
Date: Fri, 4 Oct 2019 22:10:25 +0200

Cool - text suggestions would be appreciated :)

On 10/4/19 5:50 PM, Kathleen Moriarty wrote:
> On Fri, Oct 4, 2019 at 5:37 AM Adrian Farrel <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     I just noticed I wrote…____
> 
>     __ __
> 
>     > I would suggest that the Tao explicitly says what it means.____
> 
>     __ __
> 
>     Shockingly poor use of English!____
> 
>     __ __
> 
>     I meant…____
> 
>     I would suggest that the Tao should say explicitly what it means.____
> 
>     __ __
> 
>     Best,____
> 
>     Adrian____
> 
>     __ __
> 
>     *From:*Corinne Cath <[email-masked] <mailto:[email-masked]>>
>     *To:* [email-masked] <mailto:[email-masked]>
>     *Cc:* Niels ten Oever <[email-masked] <mailto:[email-masked]>>; Kathleen Moriarty <[email-masked] <mailto:[email-masked]>>; Greg Wood <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
>     *Subject:* Re: [tao-discuss] New Version of the Tao of the IETF____
> 
>     __ __
> 
>     Hi Adrian, ____
> 
>     __ __
> 
>     Thank you for the follow up! A quick comment in-line: ____
> 
>     __ __
> 
>     On Fri, Oct 4, 2019 at 1:01 AM Adrian Farrel <[email-masked] <mailto:[email-masked]>> wrote:____
> 
>         Niels,
> 
>         FWIW most of the IETF lists have assigned "moderators". Those moderators are responsible for handling messages that don’t make it through (for whatever reason) and usually for handling posts from unsubscribed senders.____
> 
>     __ __
> 
>     So maybe it makes sense to add this explainer to the Tao and avoid the rabbit hole? ____
> 
>         PS. The new mailing list that Corinne is referring to was just announced by Barry Liebe on [email-masked] <mailto:[email-masked]>, and is [email-masked] <mailto:[email-masked]>
> 
>         > In that sense ietf@ietf is unmoderated.____
> 
> 
>     ____
> 
>     __ __
> 
>     -- ____
> 
>     Corinne Cath - Speth
>     Twitter: @C_CS____