Subject: [tap] Fwd: New pgTAP, pgTAP Site

From: Aristotle Pagaltzis <[email-masked]>
Date: Fri, 19 Sep 2008 01:39:19 +0200

> From: "David E. Wheeler" <[email-masked]>
> To: Perl QA <[email-masked]>
> Subject: New pgTAP, pgTAP Site
> Date: Thu, 18 Sep 2008 16:12:19 -0700
> Message-Id: <[email-masked]>
> 
> Howdy,
>
> I've released a new version of pgTAP, 0.10. Grab it here:
>
>   http://pgfoundry.org/frs/?group_id=1000389
>
> Changes mainly include lots of new functions for testing a schema (has_table(), has_view(), has_col(), has_pk(), 
> has_fk(), col_is_pk(), col_is_fk(), fk_ok(), etc.) and portability as far back as PostgreSQL 8.0.
>
> I've also created a Web site for the project. Feedback would be
> greatly appreciated:
>
>   http://pgtap.projects.postgresql.org/
>
> Enjoy!
>
> David
_______________________________________________
tap mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tap

---

From: "David E. Wheeler" <[email-masked]>
Date: Fri, 19 Sep 2008 12:26:10 -0700

On Sep 18, 2008, at 16:39, Aristotle Pagaltzis wrote:

>> Changes mainly include lots of new functions for testing a schema  
>> (has_table(), has_view(), has_col(), has_pk(),

I've now also added an "Integration" section, with instruction on how  
to run pgTAP tests in a Perl test suite, and placeholders for doing  
the same in Python and PHP. Know how to do that? Send me the  
instructions!

Best,

David

PS: Thanks for the reminder that I should send messages to this list,  
too, Aristotle!
_______________________________________________
tap mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tap