Subject: [tap] testanything.org is up! (Was: Re: testanything.org is down)

From: Salve J Nilsen <[email-masked]>
Date: Tue, 16 Apr 2013 14:53:04 +0200 (CEST)

Heya, folks!

Just to keep you updated: Andy Armstrong fixed testanything.org and related 
websites while at the Perl QA hackathon in Lancaster (England) this 
weekend. Yay! :)

   http://testanything.org/wiki/index.php/Main_Page   # works now

There was a LOT of spam removed (several thousand pages! o_O), and Andy has 
set up a few measures to stop this from ruining the site again. Maybe he 
can share some details? :)

- Salve

Salve J Nilsen said:
> 
> Hi Bruno & all,
>
> [Cc: Andy, since he's hosting the domain]
>
> Bruno P. Kinoshita said:
>> 
>> Hi all, 
>> 
>> For the last three weeks or so, testanything.org has been down. I tried 
>> pinging the tap mailing list, but got no response. Tried to contact 
>> Test::More maintainer to see if he knew someone with karma to update the 
>> web site but got no response so far.
>> 
>> This is the last message I found in my inbox regarding TAP, so I apologize 
>> beforehand for bothering you all :-)
>> 
>> Does anybody know where I can find one of the testanything.org 
>> administrators, please? 
>
> $ whois testanything.org | grep ^Admin | grep -v :$
>
> Admin ID:tulY0yUXw7Xkuxmn
> Admin Name:Andy Armstrong
> Admin Organization:Hexten
> Admin Street1:Bridge End Barn
> Admin City:Garrigill
> Admin State/Province:Cumbria
> Admin Postal Code:CA93DR
> Admin Country:GB
> Admin Phone:+44.01434381641
> Admin Email:[email-masked]
>
> Apparently Andy's pretty busy these days. He also hasn't been on the 
> #perl-qa IRC channel on irc.perl.org either in a while (TAP is discussed now 
> and then in that channel).
>
> Maybe Andy can tell us a little about what's going on? :)
>
>
> - Salve J. Nilsen
>
>

-- 
#!/usr/bin/perl
sub AUTOLOAD{$AUTOLOAD=~/.*::(\d+)/;seek(DATA,$1,0);print#  Salve Joshua Nilsen
getc DATA}$"="'};&{'";@_=unpack("C*",unpack("u*",':4@,$'.#     <[email-masked]>
'2!--"5-(50P%$PL,!0X354UC-PP%/0\`'."\n"));eval "&{'@_'}";   __END__ is near! :)

---

From: Leon Timmermans <[email-masked]>
Date: Tue, 16 Apr 2013 15:22:09 +0200

It seems it didn't only lose a couple of years in updates, but also in its
user database. I don't seem to have an account anymore and user
registration seems disabled.

Leon

On Tue, Apr 16, 2013 at 2:53 PM, Salve J Nilsen <[email-masked]> wrote:

> Heya, folks!
>
> Just to keep you updated: Andy Armstrong fixed testanything.org and
> related websites while at the Perl QA hackathon in Lancaster (England) this
> weekend. Yay! :)
>
>   http://testanything.org/wiki/**index.php/Main_Page<http://testanything.org/wiki/index.php/Main_Page>  # works now
>
> There was a LOT of spam removed (several thousand pages! o_O), and Andy
> has set up a few measures to stop this from ruining the site again. Maybe
> he can share some details? :)
>
>
> - Salve
>
> Salve J Nilsen said:
>
>>
>> Hi Bruno & all,
>>
>>> This is the last message I found in my inbox regarding TAP, so I
>>> apologize beforehand for bothering you all :-)
>>>
>>> Does anybody know where I can find one of the testanything.orgadministrators, please?
>>>
>>
>> #perl-qa IRC channel on irc.perl.org either in a while (TAP is discussed
>> now and then in that channel).
>>
> sub AUTOLOAD{$AUTOLOAD=~/.*::(\d+)**/;seek(DATA,$1,0);print#  Salve
> Joshua Nilsen
> getc DATA}$"="'};&{'";@_=unpack("C***",unpack("u*",':4@,$'.#     <
> [email-masked]>
> '2!--"5-(50P%$PL,!0X354UC-PP%/**0\`'."\n"));eval "&{'@_'}";   __END__ is
> near! :)
> ______________________________**_________________
> tap mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/tap<https://www.ietf.org/mailman/listinfo/tap>
>

---

From: "Bruno P. Kinoshita" <[email-masked]>
Date: Tue, 16 Apr 2013 06:28:49 -0700 (PDT)

Thanks for working on this! I maintain Jenkins TAP Plug-in and Java library tap4j. Whenever users file bug reports, we (the user too) use testanything.org as reference, or some Perl module documentation as second choice. 
It seems that some information that I'd included about tap4j is missing too, but I'll take a look later and will include it again, if necessary. 
Thanks again!

Bruno P. Kinoshita

http://kinoshita.eti.br

http://tupilabs.com

--- Em ter, 16/4/13, Leon Timmermans <[email-masked]> escreveu:

De: Leon Timmermans <[email-masked]>
Assunto: Re: [tap] testanything.org is up! (Was: Re: testanything.org is down)
Para: "Salve J Nilsen" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Data: Terça-feira, 16 de Abril de 2013, 10:22

It seems it didn't only lose a couple of years in updates, but also in its user database. I don't seem to have an account anymore and user registration seems disabled.

Leon

Heya, folks!

Just to keep you updated: Andy Armstrong fixed testanything.org and related websites while at the Perl QA hackathon in Lancaster (England) this weekend. Yay! :)

There was a LOT of spam removed (several thousand pages! o_O), and Andy has set up a few measures to stop this from ruining the site again. Maybe he can share some details? :)

- Salve

Salve J Nilsen said:

Hi Bruno & all,

Bruno P. Kinoshita said:

Hi all, 

For the last three weeks or so, testanything.org has been down. I tried pinging the tap mailing list, but got no response. Tried to contact Test::More maintainer to see if he knew someone with karma to update the web site but got no response so far.

This is the last message I found in my inbox regarding TAP, so I apologize beforehand for bothering you all :-)

Does anybody know where I can find one of the testanything.org administrators, please? 

Admin City:Garrigill

Admin Postal Code:CA93DR

Admin Country:GB

Apparently Andy's pretty busy these days. He also hasn't been on the #perl-qa IRC channel on irc.perl.org either in a while (TAP is discussed now and then in that channel).

- Salve J. Nilsen

-- 

#!/usr/bin/perl

_______________________________________________

tap mailing list

[email-masked]

https://www.ietf.org/mailman/listinfo/tap

-----Anexo incorporado-----

_______________________________________________
tap mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tap

---

From: Andy Armstrong <[email-masked]>
Date: Tue, 16 Apr 2013 16:02:40 +0100

> It seems it didn't only lose a couple of years in updates, but also in its user database. I don't seem to have an account anymore and user registration seems disabled.

Ah - sorry Leon - the reCAPTCHA plugin I had installed didn't seem to be adequate to stop spammy registrations so I've turned them off for now. 

Could you send me a mail to [email-masked] with your preferred user name and I'll set up a new account for you.

-- 
Andy Armstrong, Hexten

---

From: Andy Armstrong <[email-masked]>
Date: Tue, 16 Apr 2013 16:07:49 +0100

> It seems that some information that I'd included about tap4j is missing too, but I'll take a look later and will include it again, if necessary. 

I'm sorry about that Bruno. Obviously I tried to keep any legitimate content but it was badly tangled up with spam.

You may need me to elevate your privileges so you can edit - if so please ask me - [email-masked].

Thanks.

-- 
Andy Armstrong, Hexten