Subject: Re: [Taps] [TAPS] Call for agenda items

From: Anna Brunstrom <[email-masked]>
Date: Mon, 5 Mar 2018 20:14:05 +0100

Hi Zahed, Aaron, all,

On 2018-03-01 15:54, Brian Trammell wrote:
> hi Zahed, Aaron, all,
>
> > On 27 Feb 2018, at 18:28, Tommy Pauly <[email-masked]> <mailto:[email-masked]&gt>; wrote:
> > 
> > Hi Zahed & Aaron,
> > 
> > We’ve posted the first of three new documents proposed for milestone 3, "An Architecture for Transport Services” (please go read it, everyone!):
> > 
> > https://datatracker.ietf.org/doc/draft-pauly-taps-arch
> > https://tools.ietf.org/html/draft-pauly-taps-arch-00
> > 
> > The API and Implementation documents are forthcoming, and will be posted before the submission deadline.
>
> And now we have posted the second document (please go read it, everyone!):

Now also the Implementation document is posted (please have a look at 
that one as well!):

https://datatracker.ietf.org/doc/draft-brunstrom-taps-impl/

This document provides implementation guidance on how to build a system 
that provides a Transport Services API as described in the API document.

If we could have 10-15 minutes to also introduce implementation aspects 
after the API presentation this would be great. Discussion for all three 
documents go together.

Cheers,
Anna

> https://datatracker.ietf.org/doc/draft-trammell-taps-interface.
>
> The document combines concepts of the Post Sockets, NEAT, and Socket Intents approaches to provide an interface to the architecture in the first document at the level of a language-independent, abstract asynchronous interface definition.
>
> We'd like 10-15 minutes after Tommy to build on the architecture and introduce the concepts. ISTM (though I haven't discussed with Tommy, Anna, and Micheal, the other editors) that the discussion time for these documents can probably be combined.
>
> Cheers,
>
> Brian
>
> > I’d like a slot to go over the Architecture document and approach itself. A 15/20-minute talk with flexible discussion time would likely be good. I imagine we’d also want slots to discuss the API and Implementation documents to present them to the whole group as well.
> > 
> > Thanks,
> > Tommy
> > 
> >> On Feb 27, 2018, at 1:13 AM, Zaheduzzaman Sarker <[email-masked]> 
> <mailto:[email-masked]&gt>; wrote:
> >> 
> >> Hi TAPS,
> >> 
> >> Your chairs are planning for the IETF 101 London Session. Please send your proposal(s) for agenda item and also mention what points you would like to discuss during the IETF101 meeting during your timeslot.
> >> 
> >> BR
> >> 
> >> Zahed & Aaron
> >> _______________________________________________
> >> Taps mailing list
> >> [email-masked] <mailto:[email-masked]>
> >> https://www.ietf.org/mailman/listinfo/taps
> > 
> > _______________________________________________
> > Taps mailing list
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/taps
>

---

From: Tommy Pauly <[email-masked]>
Date: Mon, 05 Mar 2018 11:28:21 -0800

> On Mar 5, 2018, at 11:14 AM, Anna Brunstrom <[email-masked]> wrote:
> 
> Hi Zahed, Aaron, all,
>> > https://datatracker.ietf.org/doc/draft-pauly-taps-arch <https://datatracker.ietf.org/doc/draft-pauly-taps-arch>
>> > https://tools.ietf.org/html/draft-pauly-taps-arch-00 <https://tools.ietf.org/html/draft-pauly-taps-arch-00>
>> > 
> Now also the Implementation document is posted (please have a look at that one as well!):
> 
> https://datatracker.ietf.org/doc/draft-brunstrom-taps-impl/ <https://datatracker.ietf.org/doc/draft-brunstrom-taps-impl/>
> 
> This document provides implementation guidance on how to build a system that provides a Transport Services API as described in the API document.
> 
> If we could have 10-15 minutes to also introduce implementation aspects after the API presentation this would be great. Discussion for all three documents go together.

+ 1 to adding implementation to the list for the three new drafts.

I think we can reduce the time for the transport security survey a bit to make room! ~15 minutes for that.

Best,
Tommy

> 
> Cheers,
> Anna
> 
>> https://datatracker.ietf.org/doc/draft-trammell-taps-interface <https://datatracker.ietf.org/doc/draft-trammell-taps-interface>.
>> 
>> >> On Feb 27, 2018, at 1:13 AM, Zaheduzzaman Sarker <[email-masked]> <mailto:[email-masked]&gt>; wrote:
>> >> 
>> >> Hi TAPS,
>> >> 
>> >> https://www.ietf.org/mailman/listinfo/taps <https://www.ietf.org/mailman/listinfo/taps>
>> > 
>> > https://www.ietf.org/mailman/listinfo/taps <https://www.ietf.org/mailman/listinfo/taps>
>> 
> 
> [email-masked]

---

From: Christopher Wood <[email-masked]>
Date: Mon, 5 Mar 2018 12:03:22 -0800

+1 to the reduction in time for the security survey. I think we ought
to spend more time on the big three.

Best,
Chris

On Mon, Mar 5, 2018 at 11:28 AM, Tommy Pauly <[email-masked]> wrote:
>> On 27 Feb 2018, at 18:28, Tommy Pauly <[email-masked]>; wrote:
>>
>> Hi Zahed & Aaron,
>>
>> We’ve posted the first of three new documents proposed for milestone 3,
>> "An Architecture for Transport Services” (please go read it, everyone!):
>>
> This document provides implementation guidance on how to build a system that
> provides a Transport Services API as described in the API document.
>
> The document combines concepts of the Post Sockets, NEAT, and Socket Intents
> approaches to provide an interface to the architecture in the first document
> at the level of a language-independent, abstract asynchronous interface
> definition.
>
> We'd like 10-15 minutes after Tommy to build on the architecture and
> introduce the concepts. ISTM (though I haven't discussed with Tommy, Anna,
> and Micheal, the other editors) that the discussion time for these documents
> can probably be combined.
>
> Cheers,
>
> Brian
>
>> I’d like a slot to go over the Architecture document and approach itself.
>> A 15/20-minute talk with flexible discussion time would likely be good. I
>> imagine we’d also want slots to discuss the API and Implementation documents
>> to present them to the whole group as well.
>>
>> Thanks,
>> Tommy
>>
>>> On Feb 27, 2018, at 1:13 AM, Zaheduzzaman Sarker
>>> <[email-masked]>; wrote:
>>>
>>> Hi TAPS,
>>>
>>> Your chairs are planning for the IETF 101 London Session. Please send
>>> your proposal(s) for agenda item and also mention what points you would like
>>> to discuss during the IETF101 meeting during your timeslot.
>>>
>>> BR
>>>
>>> Zahed & Aaron