Subject: Re: [Taps] Transport Services (taps) WG Virtual Meeting: 2019-01-15

From: "Aaron Falk" <[email-masked]>
Date: Wed, 09 Jan 2019 18:17:07 -0500

Reminder that we have an interim call scheduled for next week.

Since the last wg meeting there has been a fair amount of activity on 
GitHub around the three interface docs. Can the authors expand on the 
‘unresolved architecture topics’ you’d like to discuss (preferably 
with a volunteer to lead the discussion)?

Also, are there any additional topics to add to the agenda?

--aaron

On 19 Nov 2018, at 10:05, IESG Secretary wrote:

> The Transport Services (taps) Working Group will hold a virtual 
> interim meeting on 2019-01-15 from 11:00 to 13:00 America/New_York.
>
> Agenda:
> Draft agenda:
> 1. Unresolved architecture topics
> 2. TAPS Registry proposal
> 3. Use of GitHub
>
> Information about remote participation:
> https://ietf.webex.com/meet/taps | Access code: 316 448 940

---

From: Theresa Enghardt <[email-masked]>
Date: Thu, 10 Jan 2019 18:03:11 +0100

Hi Aaron,

> Also, are there any additional topics to add to the agenda?

We are starting a TAPS implementation project [0], and we will continue
working on it at the hackathon in Prague.

I would like 5 minutes at the end to briefly announce this project and
ask who else is interested/joining the hackathon, please.

Thanks!

Best,
Theresa

[0] Not Socket Intents, but a new implementation based on Python
asyncio, which will probably follow the API document rather closely:
https://github.com/fg-inet/python-asyncio-taps - So far mostly our
student Max Franke is working on this, who I'm supervising together with
Philipp.

---

From: "Aaron Falk" <[email-masked]>
Date: Thu, 10 Jan 2019 12:52:32 -0500

Thanks, Theresa.  That’s exciting news and I’m interested in 
learning more.  We’ll put it on the agenda.

--aaron

---

From: "Aaron Falk" <[email-masked]>
Date: Fri, 11 Jan 2019 11:35:55 -0500

<nudge> Brian, Michael, Tommy: do we have any ‘unresolved 
architectural topics’ to discuss next week? </n>

On 9 Jan 2019, at 18:17, Aaron Falk wrote:

> ‘unresolved architecture topics’ you’d like to discuss 
> (preferably with a volunteer to lead the discussion)?
>

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Fri, 11 Jan 2019 17:37:04 +0100

IMO the architecture is pretty solid, the unresolved issues currently under discussion are primarily interface details (a couple of which we should bring out of github to the list)...

Cheers,

Brian

> On 11 Jan 2019, at 17:35, Aaron Falk <[email-masked]> wrote:
> 
> <nudge> Brian, Michael, Tommy: do we have any ‘unresolved architectural topics’ to discuss next week? </n>
> 
> 
> 
> Since the last wg meeting there has been a fair amount of activity on GitHub around the three interface docs. Can the authors expand on the ‘unresolved architecture topics’ you’d like to discuss (preferably with a volunteer to lead the discussion)?
> 
> The Transport Services (taps) Working Group will hold a virtual interim meeting on 2019-01-15 from 11:00 to 13:00 America/New_York.
> 
> Agenda:
> Draft agenda:

---

From: Michael Welzl <[email-masked]>
Date: Fri, 11 Jan 2019 20:50:30 +0100

Hi,

I agree.

Regarding the API, to make a concrete proposal: one of the things we didn’t get to, in Bangkok, is caching:

Slide 4: https://datatracker.ietf.org/meeting/103/materials/slides-103-taps-4-draft-ietf-taps-archimplinterface-topics-00
There’s this PR that’s been open for a long time now: https://github.com/taps-api/drafts/pull/244
and the related issue: https://github.com/taps-api/drafts/issues/45

We could discuss this for a bit, see if we can make some progress.

Cheers,
Michael

> On Jan 11, 2019, at 5:37 PM, Brian Trammell (IETF) <[email-masked]> wrote:
>