Subject: [Taps] API drafts repository has been migrated

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Tue, 5 Mar 2019 23:06:52 +0100

Greetings, all,

The API drafts repository is now at:

https://github.com/ietf-tapswg/api-drafts

To update your working directories to point to the new repo:

git remote set-url origin [email-masked]:ietf-tapswg/api-drafts

(Or, as with all things git, just re-clone if you want to be sure :) )

CircleCI support for autobuilding drafts should be up sometime tomorrow (it's late here); please let me know if you notice any problems with the migration.

Thanks, cheers,

Brian

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 05 Mar 2019 14:09:37 -0800

Fantastic, thanks for getting this done!

Now, to make some PRs before the Prague submission deadlines =)

Best,
Tommy

> On Mar 5, 2019, at 2:06 PM, Brian Trammell (IETF) <[email-masked]> wrote:
> 
> Greetings, all,
> 
> 
> _______________________________________________
> Taps mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/taps

---

From: "Aaron Falk" <[email-masked]>
Date: Tue, 05 Mar 2019 17:15:58 -0500

Many thanks to Brian & Zahed!

On 5 Mar 2019, at 17:09, Tommy Pauly wrote:

>> CircleCI support for autobuilding drafts should be up sometime 
>> tomorrow (it's late here); please let me know if you notice any 
>> problems with the migration.
>>
>> Thanks, cheers,
>>
>> Brian

---

From: Theresa Enghardt <[email-masked]>
Date: Wed, 6 Mar 2019 13:28:59 +0100

Thanks for migrating the repo!

>         tomorrow (it's late here); please let me know if you notice
>         any problems with the migration.
>
Not sure if problem or intended, but:

As a member of the organization, I used to be allowed to create and push
branches directly to the api-drafts repository.
However, on the new organization, this did not work just now, see below.

Is this intentional, in which case I will just fork the repo and push
the branch there?
Or is this a bug in the configuration of the new organization?

---

$ git push -u origin theri-api-usage-example
ERROR: Permission to ietf-tapswg/api-drafts.git denied to theri.
fatal: Konnte nicht vom Remote-Repository lesen.

Bitte stellen Sie sicher, dass die korrekten Zugriffsberechtigungen bestehen
und das Repository existiert.

$ git remote -v
origin    [email-masked]:ietf-tapswg/api-drafts (fetch)
origin    [email-masked]:ietf-tapswg/api-drafts (push)

--

(It says that it could not read from the remote repository and that I
should check if I have the correct permissions and that the repository
exists.)

Cloning the entire repository again in a different directory did not help.

"git pull" works as usual.

Best,
Theresa

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Wed, 6 Mar 2019 13:50:44 +0000

Hi,

Just changed the base member permission to write, that should solve your problem. Can you confirm that?

BR
Zahed

On 2019-03-06, 13:29, "Taps on behalf of Theresa Enghardt" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

On Mar 5, 2019, at 2:06 PM, Brian Trammell (IETF) <[email-masked]><mailto:[email-masked]> wrote:

Not sure if problem or intended, but:
As a member of the organization, I used to be allowed to create and push branches directly to the api-drafts repository.
However, on the new organization, this did not work just now, see below.

Is this intentional, in which case I will just fork the repo and push the branch there?
Or is this a bug in the configuration of the new organization?

---

$ git remote -v
origin    [email-masked]:ietf-tapswg/api-drafts<mailto:[email-masked]:ietf-tapswg/api-drafts> (fetch)
origin    [email-masked]:ietf-tapswg/api-drafts<mailto:[email-masked]:ietf-tapswg/api-drafts> (push)
--

(It says that it could not read from the remote repository and that I should check if I have the correct permissions and that the repository exists.)

Best,
Theresa

---

From: Theresa Enghardt <[email-masked]>
Date: Wed, 6 Mar 2019 15:07:00 +0100

Hi Zahed,

> your problem. Can you confirm that?
Yes, it works now. Thanks!

Best,
Theresa

>  
>
> On 2019-03-06, 13:29, "Taps on behalf of Theresa Enghardt"
> <[email-masked] <mailto:[email-masked]> on behalf of
> [email-masked] <mailto:[email-masked]>> wrote:
>
>  
>
>             On Mar 5, 2019, at 2:06 PM, Brian Trammell (IETF)
>             <[email-masked]> <mailto:[email-masked]> wrote:
>
>             CircleCI support for autobuilding drafts should be up
>             sometime tomorrow (it's late here); please let me know if
>             you notice any problems with the migration.
>
> As a member of the organization, I used to be allowed to create and
> push branches directly to the api-drafts repository.
>
> origin    [email-masked]:ietf-tapswg/api-drafts
> <mailto:[email-masked]:ietf-tapswg/api-drafts> (fetch)
> origin    [email-masked]:ietf-tapswg/api-drafts
> <mailto:[email-masked]:ietf-tapswg/api-drafts> (push)
>
> --
>
>  
>

-- 
Theresa Enghardt
Wissenschaftliche Mitarbeiterin / Research Assistant
Phone: +49 30 314 78628
Office: MAR 4.032

FG / Group "Internet Network Architectures" (INET)
Technische Universität Berlin
Sekr. MAR 4-4, Marchstraße 23, 10587 Berlin