Subject: Re: [tcmtf] Satellite-sensors scenario: new figure

From: "Jose Saldana" <[email-masked]>
Date: Thu, 4 Oct 2012 14:27:12 +0200

I have been thinking about the satellite-sensors scenario. Taking into account all your feedback, I think some statements are clear:

	- If the satellite link is the only one, then there better compression schemes exist.
	- TMCTF is only interesting if a number of hops is required, one of them being the satellite one.
	- Header compressing requires high processing capacity.
	- Compression should be deployed where enough processing capacity is available.

Nother idea: although many sensor networks do not use IP, there are some of them using it. Nowadays, "internet of things" is a trending topic. "The basic idea of this concept is the pervasive presence around us of a variety of things or objects – such as Radio-Frequency IDentification (RFID) tags, sensors, actuators, mobile phones, etc. – which, through unique addressing schemes, are able to interact with each other and cooperate with their neighbors to reach common goals." (http://www.sciencedirect.com/science/article/pii/S1389128610001568).

Another concept is "IP to the Field" paradigm where technologies applied in the Internet domain percolate right up to the field devices (http://www.kom.tu-darmstadt.de/research-results/projects/siemens-ip-to-the-field/).

Thinking about the IP sensors scenario, I have done three different figures:

a) http://diec.unizar.es/~jsaldana/personal/tcmtf_figures/satellite_scenario_multimux_v2.pdf

	Each WSN multiplexes and compresses its packets. And finally the gateway simply sends them. In this case, the processing capacity should be in the three multiplexers-compressors

b) http://diec.unizar.es/~jsaldana/personal/tcmtf_figures/satellite_scenario_v2.pdf

	In this case, there is a single multiplexer-compressor, which is located near the antenna, and does all the work for the three WSNs.

c) http://diec.unizar.es/~jsaldana/personal/tcmtf_figures/satellite_scenario_multimux_separate_v2.pdf

 	A third option could include task distribution: each WSN compresses its flows, and the shared gateway does multiplexing and tunneling. Perhaps the most CPU intensive task is header compression.

If sensors are not IP, perhaps some of the scenarios would still be interesting: you may use IP for distinguishing between different sensor networks, or different server destinations.

What do you think? Does this make sense? Which figure would be better?

Thanks for your valuable feedback,

Jose

---

From: FERNANDO PASCUAL BLANCO <[email-masked]>
Date: Tue, 09 Oct 2012 07:17:51 +0000

Hi Jose,

        Figures 1 and 2 make more sense for me. I would even include a 4th figure
with an only box (TCMTF, gateway and satellite antenna) per WSN.

Regards,

Fernando Pascual Blanco
Telefónica Global Resources
Network Automation and Dynamization
TECHNOLOGY PEOPLE GROUP
F +34913128779
M +34682005168
[email-masked]

On 04/10/12 14:27, "Jose Saldana" <[email-masked]> wrote:

>I have been thinking about the satellite-sensors scenario. Taking into
>account all your feedback, I think some statements are clear:
>
>Nother idea: although many sensor networks do not use IP, there are some
>of them using it. Nowadays, "internet of things" is a trending topic.
>"The basic idea of this concept is the pervasive presence around us of a
>variety of things or objects  such as Radio-Frequency IDentification
>(RFID) tags, sensors, actuators, mobile phones, etc.  which, through
>unique addressing schemes, are able to interact with each other and
>cooperate with their neighbors to reach common goals."
>(http://www.sciencedirect.com/science/article/pii/S1389128610001568).
>
>Another concept is "IP to the Field" paradigm where technologies applied
>in the Internet domain percolate right up to the field devices
>(http://www.kom.tu-darmstadt.de/research-results/projects/siemens-ip-to-th
>e-field/).
>
>
>
>a)
>http://diec.unizar.es/~jsaldana/personal/tcmtf_figures/satellite_scenario_
>multimux_v2.pdf
>
>       Each WSN multiplexes and compresses its packets. And finally the gateway
>simply sends them. In this case, the processing capacity should be in the
>three multiplexers-compressors
>
>
>b)
>http://diec.unizar.es/~jsaldana/personal/tcmtf_figures/satellite_scenario_
>v2.pdf
>
>       In this case, there is a single multiplexer-compressor, which is located
>near the antenna, and does all the work for the three WSNs.
>
>
>c)
>http://diec.unizar.es/~jsaldana/personal/tcmtf_figures/satellite_scenario_
>multimux_separate_v2.pdf
>
>       A third option could include task distribution: each WSN compresses its
>flows, and the shared gateway does multiplexing and tunneling. Perhaps
>the most CPU intensive task is header compression.
>
>
>If sensors are not IP, perhaps some of the scenarios would still be
>interesting: you may use IP for distinguishing between different sensor
>networks, or different server destinations.
>
>
>_______________________________________________
>tcmtf mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/tcmtf

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx