Subject: [tcmtf] Improvements in TCM-TF according to the received comments: Problem 2: Path MTU

From: "Jose Saldana" <[email-masked]>
Date: Wed, 5 Feb 2014 13:06:02 +0100

Problem:
 
Gorry: Perhaps we should also look at PMTU issues?
Al: Yes. The operations considerations should be thought about.
 
Solution: (see this thread:
<http://www.ietf.org/mail-archive/web/tcmtf/current/msg00422.html>
http://www.ietf.org/mail-archive/web/tcmtf/current/msg00422.html)
The current charter talks about MTU in number 7.

Jose

---

From: Luigi Iannone <[email-masked]>
Date: Mon, 10 Feb 2014 16:40:29 +0100

Hi,

> Gorry: Perhaps we should also look at PMTU issues?

In TCMTF?  I would avoid that. MTU is a common problem for any tunnelling mechanism I would more support a “tunnel-spefici-independent” solution (probably to be discussed elsewhere).

ciao

L.

> Solution: (see this thread: http://www.ietf.org/mail-archive/web/tcmtf/current/msg00422.html)
> _______________________________________________
> tcmtf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcmtf

---

From: "Jose Saldana" <[email-masked]>
Date: Tue, 18 Feb 2014 09:38:53 +0100

Luigi,
 
In some research papers we have somewhat considered the problem of the MTU.
I mean, let' suppose you have a high number of flows to be optimized
together. Then, you define a period to multiplex them. But it may happen
that, before ending the period, you have enough small packets so as to fill
an MTU-sized multiplexed one. At that point, you should end that period,
send the packet and start a new period. If you include a size threshold in
addition to the period, the method is better.
 
However, perhaps this is just an implementation issue. Do you think we
should recommend this in the documents:
- know the maximum MTU
- use it in addition to the Period in order to trigger the sending of the
multiplexed packet.
 
Thanks!
 
Jose
 
De: Luigi Iannone [mailto:[email-masked]] 
Enviado el: lunes, 10 de febrero de 2014 16:40
Para: Jose Saldana
CC: [email-masked]; [email-masked]
Asunto: Re: [tcmtf] Improvements in TCM-TF according to the received
comments: Problem 2: Path MTU
 
Hi,
 
On 5 Feb. 2014, at 13:06 , Jose Saldana < <mailto:[email-masked]>
[email-masked]> wrote:

Problem:

In TCMTF?  I would avoid that. MTU is a common problem for any tunnelling
mechanism I would more support a "tunnel-spefici-independent" solution
(probably to be discussed elsewhere).
 
ciao
 
L.

Jose 
 
_______________________________________________
tcmtf mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/tcmtf>
https://www.ietf.org/mailman/listinfo/tcmtf