Subject: [tcmtf] BoF preparation: Improvements in TCM-TF according to the received comments

From: "Jose Saldana" <[email-masked]>
Date: Wed, 5 Feb 2014 13:05:24 +0100

Hi all,
 
In order to prepare the BoF in London, I have tried to summarize the
questions that have been discussed, in order to include the improvements in
the charter and in the two drafts.
 
On behalf of clarity, I will send different messages with the solutions for
each problem.
 
If you think there are other problems, please start a new thread.

Problems discussed in the BoF:
 
1) TCP multiplexing and effect on TCP dynamics. (I think this was the main
problem).
 
2) Path MTU discovery issues
 
3) Are we adding latency and complexity to save relatively little bandwidth?
 
4) Do vendors want standards in this space?

Problems discussed in the list:
 
5) Why is ROHC not a solution?

Jose

---

From: <[email-masked]>
Date: Wed, 12 Feb 2014 10:59:11 +0000

<< Conjointly, transport protocols such as SCTP, DCCP, MPTCP, UDP-Lite and the LEDBAT congestion control mechanism offer a large number of services to applications in addition to the long-standing two services provided by TCP and UDP. For an application programmer, using protocols other than TCP or UDP is hard>>

One thing I think would be useful is to analyse this as a migration problem. I know lots of people have thought about why migration is hard. My take is that the crucial issues are to make sure there is incremental benefit (the party migrating gets a benefit now and not when everyone else has migrated) and to try and ensure migration can be one party at a time (so others don't have to care - 'party' is most obviously one end host, but in some circumstances can be eg 'Apple iOS'). There's some quite nice stuff in RFC5218.

Best wishes
Phil

From: tsv-area [mailto:[email-masked]] On Behalf Of Jose Saldana
Sent: 05 February 2014 12:05
To: [email-masked]
Cc: [email-masked]
Subject: BoF preparation: Improvements in TCM-TF according to the received comments

Hi all,

In order to prepare the BoF in London, I have tried to summarize the questions that have been discussed, in order to include the improvements in the charter and in the two drafts.

On behalf of clarity, I will send different messages with the solutions for each problem.

1) TCP multiplexing and effect on TCP dynamics. (I think this was the main problem).

Jose

---

From: "Jose Saldana" <[email-masked]>
Date: Thu, 13 Feb 2014 17:36:28 +0100

Phil,
 
Thanks for the ideas.
 
With the “migration problem”, do you mean that a TCM-TF tunnel including a
number of flows could be useful for connecting two “domains” using different
protocols?
 
Thanks for the link to RFC5218. It contains good tips of advice.
 
Jose
PS: Regarding SCTP, DCCP, TCP, UDP, etc., a BoF proposing an API that would
automatically select the best one for an application is being held in London
(Transport Services)
https://sites.google.com/site/transportprotocolservices/
 
De: tcmtf [mailto:[email-masked]] En nombre de [email-masked]
Enviado el: miércoles, 12 de febrero de 2014 11:59
Para: [email-masked]; [email-masked]
CC: [email-masked]
Asunto: Re: [tcmtf] BoF preparation: Improvements in TCM-TF according to the
received comments
 
<< Conjointly, transport protocols such as SCTP, DCCP, MPTCP, UDP-Lite and
the LEDBAT congestion control mechanism offer a large number of services to
applications in addition to the long-standing two services provided by TCP
and UDP. For an application programmer, using protocols other than TCP or
UDP is hard>>
 
One thing I think would be useful is to analyse this as a migration problem.
I know lots of people have thought about why migration is hard. My take is
that the crucial issues are to make sure there is incremental benefit (the
party migrating gets a benefit now and not when everyone else has migrated)
and to try and ensure migration can be one party at a time (so others don’t
have to care – ‘party’ is most obviously one end host, but in some
circumstances can be eg ‘Apple iOS’). There’s some quite nice stuff in
RFC5218. 
 
Best wishes
Phil
 
From: tsv-area [mailto:[email-masked]] On Behalf Of Jose Saldana
Sent: 05 February 2014 12:05
To: [email-masked]
Cc: [email-masked]
Subject: BoF preparation: Improvements in TCM-TF according to the received
comments
 
Hi all,

 

 

 

Jose