Subject: [tcpm] draft-ietf-tcpm-ecnsyn-04

From: Sally Floyd <[email-masked]>
Date: Mon, 11 Feb 2008 17:45:43 -0800

The revised version of draft-ietf-tcpm-ecnsyn-04 was submitted on
January 8, and from the authors' perspective, this is ready for Working
Group Last Call.  It is available from:
"http://tools.ietf.org/html/draft-ietf-tcpm-ecnsyn-04".

The changes from the previous draft are as follows:

    Changes from draft-ietf-tcpm-ecnsyn-03:

    * General editing.  This includes using the terms "initiator"
      and "responder" for the two ends of the TCP connection.
      Feedback from Alfred Hoenes.

    * Added some text to the backwards compatibility discussion,
      now in Appendix B, about the pros and cons of using a TCP
      flag for the TCP initiator to signal that it understands
      ECN-Capable SYN/ACK packets.  The consensus at this time is
      not to use such a flag.  Also added a recommendation that
      TCP implementations include a management interface to turn
      off the use of ECN for SYN/ACK packets.  From email from
      Bob Briscoe.

The second issue (of backwards compatibility with TCP clients
that understand ECN, but that don't understand ECN-Capable
SYN/ACK packets) was discussed at the December IETF,
and on the mailing list since then, under the subject heading
"[tcpm] Re: draft-ietf-tcpm-ecnsyn-03.txt backwards compatibility"

As far as the authors are concerned, this has been ready for
Working Group Last Call since it was submitted in January...

Many thanks,
- Sally
http://www.icir.org/floyd/

_______________________________________________
tcpm mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/tcpm

---

From: Sally Floyd <[email-masked]>
Date: Mon, 11 Feb 2008 19:00:08 -0800

> Group Last Call.

Sorry, I should have said that the document went through Working Group
Last Call in December, and the revision draft-ietf-tcpm-ecnsyn-04 was
to address issues raised in WGLC.  So the question is whether this is
ready to move on the next stage...

Apologies,
- Sally

---

From: Mark Allman <[email-masked]>
Date: Mon, 11 Feb 2008 23:01:34 -0500

> ready to move on the next stage...

Sally-

I thought I had sent a note to the list announcing that we believe there
to be consensus on this document and that it passed WGLC.  However, it
seems as though I did not.  My apologies.

I need to write a PROTO statement for this document and I have been
tardy on this.  I was supposed to do it last week, but it slipped the
queue.  I will try to get to it soon.

Thanks!

allman

---

From: Yoshifumi Nishida <[email-masked]>
Date: Thu, 14 Feb 2008 04:36:00 +0900 (JST)

Hello, Sorry for disturbing, but I hope it would be usefull for some people.
A new stable version of tcpillust: a graphical TCP connection analysis tool
is available at: 

   http://www.jp.nishida.org/tcpillust/tcpillust-2.01.tar.gz

Tcpillust takes tcpdump file(s) specified at the command line 
and draws pictures like figures in the ``TCP/IP Illustrated'' series.

If you're interested, please check the following web site:
    http://www.jp.nishida.org/tcpillust/index.html
You can see sample screen images of tcpillust or screen guide.

If you have any problem, please let me know.
Also, feedbacks, comments, suggestions and bug-reports are very welcome.

Thanks,
--
Yoshifumi Nishida
[email-masked]