Subject: [tcpm] ftp IP TOS Usage

From: "Agarwal, Anil" <[email-masked]>
Date: Fri, 22 Jan 2010 21:36:28 -0500

Can someone please describe (or point to a document) why ftp uses non-zero IP TOS values (0x10 and 0x08) for non-SYN TCP segments of the control and data TCP connections, but uses IP TOS = 0 in TCP SYN segments?

telnet seems to use TOS = 0x10 in all TCP segments.

ssh and sftp seem to use TOS = 0 for SYN and the first few data segments, then switch to a non-zero TOS value (0x08).

(Above observations are based on Linux).

Thanks,
Anil

Anil Agarwal
ViaSat Inc.
Germantown, MD 20876

---

From: "Chaks Chigurupati (chaks)" <[email-masked]>
Date: Sun, 24 Jan 2010 12:00:30 -0800

Just a guess on my part. The differences could be due to the way setsockopt for TOS is done, i.e. if you set the TOS as soon as the socket is created but before the connection is established, then SYN segments will carry the programmed TOS. Telnet could be setting the TOS before the connection is established. Ssh and sftp could be setting it after the connection is established.

Chaks

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Agarwal, Anil
> Sent: Friday, January 22, 2010 6:36 PM
> To: [email-masked]
> Subject: [tcpm] ftp IP TOS Usage
> 
> 
> Can someone please describe (or point to a document) why ftp 
> uses non-zero IP TOS values (0x10 and 0x08) for non-SYN TCP 
> segments of the control and data TCP connections, but uses IP 
> TOS = 0 in TCP SYN segments?
> 
> ssh and sftp seem to use TOS = 0 for SYN and the first few 
> data segments, then switch to a non-zero TOS value (0x08).
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm
>

---

From: <[email-masked]>
Date: Wed, 27 Jan 2010 15:35:40 -0000

The ToS field has been redefined several times and now consists of the 6 bit Diffserv codepoint field and the 2 bit ECN field. 

Have a look at: http://h30097.www3.hp.com/docs/base_doc/DOCUMENTATION/V51B_HTML/MAN/MAN4/0055____.HTM

And p.21 of RFC1060 which might explain why telnet uses 0x100. 0x08 implies that the segments are being sent with the "reliability" flag in the parlance of RFC1349.

Not sure if that helps at all...

Toby

____________________________________________________________________ 
Toby Moncaster, Senior Researcher, BT Network Infrastructure Practice
B54/70 Adastral Park, Ipswich, IP53RE, UK.  +44 7918 901170 

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Agarwal, Anil
> Sent: 23 January 2010 02:36
> To: [email-masked]
> Can someone please describe (or point to a document) why ftp uses non-
> zero IP TOS values (0x10 and 0x08) for non-SYN TCP segments of the
> control and data TCP connections, but uses IP TOS = 0 in TCP SYN
> segments?
> 
> ssh and sftp seem to use TOS = 0 for SYN and the first few data
> segments, then switch to a non-zero TOS value (0x08).
>