Subject: [tcpm] Last Call: draft-ietf-tcpm-tcp-auth-opt (The TCP Authentication Option) to Proposed Standard

From: The IESG <[email-masked]>
Date: Wed, 24 Feb 2010 09:24:57 -0800 (PST)

The IESG has received a request from the TCP Maintenance and Minor 
Extensions WG (tcpm) to consider the following document:

- 'The TCP Authentication Option '
   <draft-ietf-tcpm-tcp-auth-opt-10.txt> as a Proposed Standard

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action.  Please send substantive comments to the
[email-masked] mailing lists by 2010-03-10. Exceptionally, 
comments may be sent to [email-masked] instead. In either case, please 
retain the beginning of the Subject line to allow automated sorting.

The file can be obtained via
http://www.ietf.org/internet-drafts/draft-ietf-tcpm-tcp-auth-opt-10.txt

IESG discussion can be tracked via
https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=16685&rfc_flag=0

---

From: "Smith, Donald" <[email-masked]>
Date: Fri, 26 Feb 2010 12:45:00 -0700

I have commented numerous times that with a paragraph that specifically provides vendors to make "connection-less resets == attack packets" this will not get much if any use among ISPs or other bgp speakers.

Those statements have pretty much been ignored.

I do not support this draft and believe I have wasted my time trying to explain why to someone that is unwilling to compromise with even a "a vendor MAY maintain state to allow connectionless resets to work".

(coffee != sleep) & (!coffee == sleep)
[email-masked] gcia

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of The IESG
> Sent: Wednesday, February 24, 2010 10:25 AM
> To: IETF-Announce
> Cc: [email-masked]
> Subject: [tcpm] Last Call: draft-ietf-tcpm-tcp-auth-opt (The
> TCP Authentication Option) to Proposed Standard
>
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm
>

This communication is the property of Qwest and may contain confidential or
privileged information. Unauthorized use of this communication is strictly
prohibited and may be unlawful.  If you have received this communication
in error, please immediately notify the sender by reply e-mail and destroy
all copies of the communication and any attachments.

---

From: "Eddy, Wesley M. (GRC-MS00)[ASRC AEROSPACE CORP]" <[email-masked]>
Date: Fri, 26 Feb 2010 17:18:20 -0600

Hi Donald, as the document shepherd, I need to set the record straight on this, as your statement is simply false.

In checking that the WGLC comments had been handled in the following document update, I looked at both the email thread you participated in and the updated document.  In this case, the editor very clearly responded to your inputs and made significant changes to the document.

You can find an entirely new section (9.7 Connectionless Resets) starting in version 09 of the draft, which specifically responds to your comments with resolutions that were discussed on the mailing list.  This section discusses maintenance of the traffic keys across reboots which answers your concern and makes the practice a "SHOULD" which is stronger even than the "MAY" that you mention below.

I do not understand why you feel like your inputs were ignored, but I hope that you'll agree that this was not the case.

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Smith, Donald [[email-masked]]
Sent: Friday, February 26, 2010 2:45 PM
To: [email-masked]'; 'IETF-Announce'
Cc: [email-masked]'
Subject: Re: [tcpm] Last Call: draft-ietf-tcpm-tcp-auth-opt (The        TCP     Authentication Option) to Proposed Standard

---

From: "Smith, Donald" <[email-masked]>
Date: Fri, 26 Feb 2010 16:30:00 -0700

Hi Wesley, I stand red faced and corrected.
The last version I saw did not address this (I think that was either 08 or 09) and I assumed the .10 didn't either.
I withdraw my objection and apologize for having missed this significant rewrite!!

> From: Eddy, Wesley M. (GRC-MS00)[ASRC AEROSPACE CORP]
> [mailto:[email-masked]]
> Sent: Friday, February 26, 2010 4:18 PM
> To: Smith, Donald; [email-masked]'
> Cc: [email-masked]'
> Subject: RE: [tcpm] Last Call: draft-ietf-tcpm-tcp-auth-opt
> (The TCP Authentication Option) to Proposed Standard
>
> Hi Donald, as the document shepherd, I need to set the record
> straight on this, as your statement is simply false.
>
> In checking that the WGLC comments had been handled in the
> following document update, I looked at both the email thread
> you participated in and the updated document.  In this case,
> the editor very clearly responded to your inputs and made
> significant changes to the document.
>
> You can find an entirely new section (9.7 Connectionless
> Resets) starting in version 09 of the draft, which
> specifically responds to your comments with resolutions that
> were discussed on the mailing list.  This section discusses
> maintenance of the traffic keys across reboots which answers
> your concern and makes the practice a "SHOULD" which is
> stronger even than the "MAY" that you mention below.
>
> I do not understand why you feel like your inputs were
> ignored, but I hope that you'll agree that this was not the case.
>
>
> From: [email-masked] [[email-masked]] On Behalf
> Of Smith, Donald [[email-masked]]
> Subject: Re: [tcpm] Last Call: draft-ietf-tcpm-tcp-auth-opt
> (The        TCP     Authentication Option) to Proposed Standard
>
> I have commented numerous times that with a paragraph that
> specifically provides vendors to make "connection-less resets
> == attack packets" this will not get much if any use among
> ISPs or other bgp speakers.
>
> I do not support this draft and believe I have wasted my time
> trying to explain why to someone that is unwilling to
> compromise with even a "a vendor MAY maintain state to allow
> connectionless resets to work".
>
>
>