Subject: Re: [tcpm] [Editorial Errata Reported] RFC5681 (2074)

From: Mark Allman <[email-masked]>
Date: Tue, 16 Mar 2010 09:54:13 -0400

> The following errata report has been submitted for RFC5681,
> "TCP Congestion Control".
> 
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=5681&eid=2074
> 
> --------------------------------------
> Type: Editorial
> Reported by: Herbie Robinson <[email-masked]>
> 
> Section: 3.1
> 
> Original Text
> -------------
>    A detailed rationale and discussion of the IW setting is provided in
>    [RFC3390].
> 
> 
> Corrected Text
> --------------
>    A detailed rationale and discussion of the IW setting is provided
>    in [RFC3390].  The IW value for the case when (SMSS > 1095 bytes)
>    and (SMSS <= 2190 bytes) is changed from RFC3390.  The new
>    definition will keep early values of cwnd at a multiple of SMSS and
>    avoid transmitting partial segments.
> 
> 
> Notes
> -----
> Hopefully, I surmised the reason for the change correctly.

You did not surmise correctly.  There is a very slight discrepancy
between the two documents when the SMSS == 2190 bytes.  RFC3390 says to
use an initial window of 2*SMSS, whereas RFC5681 says to use an initial
window of 3*SMSS.  This is nothing but a bug---a <= where there should
have been a < and a > where there should have been a >=.

So, the corrected text is not right.  We could say something like:

    A detailed rationale and discussion of the IW setting is provided in
    [RFC3390].  (Note: When SMSS is 2190 bytes the table in RFC 5681
    says to use an IW of 3*SMSS, while RFC 3390 says to use an IW of
    2*SMSS.  This is an off-by-one error in RFC 5681 and the intended IW
    is 2*SMSS, per RFC 3390.)

Or, we could just forget it as a harmless bug.

allman

---

From: RFC Errata System <[email-masked]>
Date: Mon, 15 Mar 2010 20:09:48 -0700 (PDT)

Section: 3.1

Original Text
-------------

Corrected Text
--------------
   A detailed rationale and discussion of the IW setting is provided in
   [RFC3390].  The IW value for the case when (SMSS > 1095 bytes) and (SMSS <= 
   2190 bytes) is changed from RFC3390.  The new definition will keep early 
   values of cwnd at a multiple of SMSS and avoid transmitting partial segments.

Notes
-----

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5681 (draft-ietf-tcpm-rfc2581bis-07)
--------------------------------------
Title               : TCP Congestion Control
Publication Date    : September 2009
Author(s)           : M. Allman, V. Paxson, E. Blanton
Category            : DRAFT STANDARD
Source              : TCP Maintenance and Minor Extensions
Area                : Transport
Stream              : IETF
Verifying Party     : IESG