Subject: [tcpm] I-D Action:draft-ietf-tcpm-urgent-data-04.txt

From: [email-masked]
Date: Wed, 3 Mar 2010 19:00:03 -0800 (PST)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the TCP Maintenance and Minor Extensions Working Group of the IETF.

	Title           : On the implementation of the TCP urgent mechanism
	Author(s)       : F. Gont, A. Yourtchenko
	Filename        : draft-ietf-tcpm-urgent-data-04.txt
	Pages           : 13
	Date            : 2010-03-03

This document analyzes how current TCP implementations process TCP
urgent indications, and how the behavior of some widely-deployed
middle-boxes affect how urgent indications are processed by end
systems.  This document updates the relevant specifications such that
they accommodate current practice in processing TCP urgent
indications, provides advice to applications that make use of the
urgent mechanism, and raises awareness about the reliability of TCP
urgent indications in the current Internet.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-tcpm-urgent-data-04.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Fernando Gont <[email-masked]>
Date: Thu, 04 Mar 2010 00:17:38 -0300

Hi, all,

I've posted a rev of the urgent-data I-D, with all the suggesdted
changes (modulo the data/datum one, that just wanted to double-check
with David (and that there's still plenty of time to fix, if needed)).

Thanks!

Kind regards,
Fernando

[email-masked] wrote:
> ------------------------------------------------------------------------
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

-- 
Fernando Gont
e-mail: [email-masked] || [email-masked]
PGP Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1

---

From: [email-masked]
Date: Thu, 04 Mar 2010 00:32:37 -0500

Question re: section 6 of this document -- would it be better to remove some of
the emphasis from SO_OOBINLINE and put it on the "urgent data" part?  For example:

Even though applications SHOULD NOT employ the urgent mechanism, applications
which still decide to do so MUST ensure that all "urgent data" is delivered
inline (e.g. set the SO_OOBINLINE socket option on platforms that support it),
as intended by the IETF specifications.

The above text also probably also makes the suggestion there a bit stronger, for
better or worse.

Best,
Gilbert Clark
Grad Student