Subject: [tcpm] tcp-ao-crypto-03, IANA registry location question

From: Gregory Lebovitz <[email-masked]>
Date: Wed, 24 Mar 2010 10:49:51 -0700

Draft-03 has now published addressing all issues.

Michelle (IANA team) had a good question:

Should the registry for this, "Cryptographic Algorithms for TCP-AO", be
stand alone or should it sit under the current "tcp-parameters"
registration? FYI, the other things in that "tcp-parameters" registry today
are only two:
  TCP Option Kind Numbers, and
  TCP Alternate Checksum Numbers

The specific question IANA will need answered:
Do we want to
(1) add "Cryptographic Algorithms for TCP-AO"  as a "tcp-parameter" registry
or
(2) Create "Cryptographic Algorithims for TCP-AO" as a stand-alone registry

Magnus happened to walk by while I was at IANA table with Michelle, and we
both thought (1) above was best. Chairs? Lars?

Michelle advises that IESG can clear the document, and we can address this
in Auth48.

Gregory

On Wed, Mar 24, 2010 at 10:37 AM, IETF I-D Submission Tool <
[email-masked]> wrote:

>
> A new version of I-D, draft-ietf-tcpm-tcp-ao-crypto-03.txt has been
> successfully submitted by Gregory Lebovitz and posted to the IETF
> repository.
>
> Filename:        draft-ietf-tcpm-tcp-ao-crypto
> Revision:        03
> Title:           Cryptographic Algorithms for TCP's Authentication Option,
> TCP-AO
> Creation_date:   2010-03-24
> WG ID:           tcpm
> Number_of_pages: 16
>
> Abstract:
> The TCP Authentication Option, TCP-AO, relies on security algorithms
> to provide authentication between two end-points.  There are many
> such algorithms available, and two TCP-AO systems cannot interoperate
> unless they are using the same algorithms.  This document specifies
> the algorithms and attributes that can be used in TCP-AO's current
> manual keying mechanism, and provides the interface for future MACs.
>
>
>
> The IETF Secretariat.
>
>
>

-- 
----
IETF related email from
Gregory M. Lebovitz
Juniper Networks

---

From: Lars Eggert <[email-masked]>
Date: Wed, 24 Mar 2010 11:16:52 -0700

On 2010-3-24, at 10:49, Gregory Lebovitz wrote:
> Magnus happened to walk by while I was at IANA table with Michelle, and we both thought (1) above was best. Chairs? Lars?

(1) seems fine.

Lars

---

From: Gregory Lebovitz <[email-masked]>
Date: Wed, 24 Mar 2010 11:35:48 -0700

Michelle,
After discussion with Lars, and with Magnus input, we believe (1) add
"Cryptographic Algorithms for TCP-AO"  as a "tcp-parameter" registry is
best.

IESG review has already completed.

Do we want to edit IANA section to reflect this in Auth48, or how did you
want to handle getting the text chagned?

pls advise,
Gregory

-- 
----
IETF related email from
Gregory M. Lebovitz
Juniper Networks

---

From: "Michelle Cotton via RT" <[email-masked]>
Date: Wed, 24 Mar 2010 20:01:49 +0000

Gregory,

I don't think any text changes are needed.  We'll make a note that the registry should be placed in tcp-
parameters.

Thanks,

Michelle