Subject: Re: [tcpm] poll for adoption of draft-ananth-persist-02

From: "Eddy, Wesley M. (GRC-MS00)[ASRC AEROSPACE CORP]" <[email-masked]>
Date: Wed, 14 Apr 2010 08:21:41 -0500

After reviewing this mailing list thread and the IETF 77
discussion, David and I think there's support to make
this a working group document.

As we see it, the path to take toward publication is:

1) authors submit a draft-ietf-tcpm version of the document
2) authors need to come to closure with several people who
   disagree with specification of a new socket option; this
   seems to be the main point of contention
3) issue a WGLC once consensus is determined for the socket
   option issue

--
Wes Eddy
MTI Systems

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf Of
>Eddy, Wesley M. (GRC-MS00)[ASRC AEROSPACE CORP]
>Sent: Monday, March 08, 2010 2:50 PM
>To: [email-masked]
>Subject: [tcpm] poll for adoption of draft-ananth-persist-02
>
>The authors have updated draft-ananth-persist, and asked
>us to poll the TCPM WG to have this particular document
>adopted with an Informational target.
>
>http://www.ietf.org/id/draft-ananth-tcpm-persist-02.txt
>
>This has been discussed to some extent on the mailing
>list and at the Dublin meeting.  The authors have
>responded to comments received thus far and updated the
>document as it grew from the outcome of prior feedback
>on the draft-mahesh-persist-timeout document.
>
>Please respond if you either:
>
>(1) Support making this document a WG document with the
>    target for Informational.
>
>(2) Oppose making this document a WG document.
>
>Of course, other comments are also welcome :).
>
>It's relatively short, so if people could respond in the
>next 2 weeks, this would allow us to determine consensus
>during the week of the IETF meeting.
>
>--
>Wes Eddy
>MTI Systems
>
>
>_______________________________________________
>tcpm mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/tcpm

---

From: [email-masked] (Christos Zoulas)
Date: Wed, 14 Apr 2010 10:37:12 -0400

On Apr 14,  8:21am, [email-masked] ("Eddy, Wesley M. (GRC-MS00)[ASRC AEROSPACE CORP]") wrote:
-- Subject: Re: [tcpm] poll for adoption of draft-ananth-persist-02

| After reviewing this mailing list thread and the IETF 77
| discussion, David and I think there's support to make
| this a working group document.
| 
| As we see it, the path to take toward publication is:
| 
| 1) authors submit a draft-ietf-tcpm version of the document
| 2) authors need to come to closure with several people who
|    disagree with specification of a new socket option; this
|    seems to be the main point of contention
| 3) issue a WGLC once consensus is determined for the socket
|    option issue

- Shouldn't the variable be called something like SO_PERSISTTIMEO to follow
  suit with existing options and be in the proper namespace?
- Shouldn't the type of the persist_timeout_value be mentioned (again
  presumably either int or struct timeval, again to follow convention)
  as well if "int" is chosen the units (seconds)?
- There should also be a getsockopt(2) for this (for symmetry).
- Are there any existing implementations for this, and if so do they use
  one of the existing timers, or does this need a new one?

Best,

christos

---

From: "Anantha Ramaiah (ananth)" <[email-masked]>
Date: Wed, 14 Apr 2010 08:32:17 -0700

Wes, 

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Eddy, Wesley M. (GRC-MS00)[ASRC AEROSPACE CORP]
> Sent: Wednesday, April 14, 2010 6:22 AM
> To: [email-masked]
> Subject: Re: [tcpm] poll for adoption of draft-ananth-persist-02
> 
> discussion, David and I think there's support to make this a 
> working group document.
> 

Should we re-submit the draft-ietf version taking into incorporating all
the comments we have received so far + new boiler plate etc.,? 

>    seems to be the main point of contention

Ok, there seems to be some confusion caused with the purpose of socket
option and the references to SO_LINGER etc., I think we need to get
closure on this issue. We (authors) discussed these responses and we
agree that if there is enough guidance that already exists to support
the implementers, then there is no need to invent any new socket option
and just mention the existing tools. OTOH, if currently there are no
ways to make things work reliably, we think that it is not a bad idea to
give some examples in the appendix (after all it is an informational
document and we are not changing ANY standard here, so I personally see
no conflict of interest here). The key is to give a guidance (or at the
least an example) to implementers and we think it is within the scope of
the informational document. That is the reason to mention the socket
option etc., in the first place.

That said, we will work with the folks who have had concerns and see if
we are on the same page w.r.t their thoughts. This is a pending action
from our side.

> 3) issue a WGLC once consensus is determined for the socket

Sounds good to me.

Thanks,
-Anantha

---

From: "Eddy, Wesley M. (GRC-MS00)[ASRC AEROSPACE CORP]" <[email-masked]>
Date: Wed, 14 Apr 2010 10:36:30 -0500

>From: Anantha Ramaiah (ananth) [mailto:[email-masked]]
>Sent: Wednesday, April 14, 2010 11:32 AM
>To: Eddy, Wesley M. (GRC-MS00)[ASRC AEROSPACE CORP]; [email-masked]
>Subject: RE: [tcpm] poll for adoption of draft-ananth-persist-02
>
>Wes,
>

Yes, and in the meantime, keep the discussion open on the
socket option.  If it converges in time for the resolution
to be included in the updated WG document, that would be
good, but not strictly necessary.  We would like to come
to consensus on that before making a WGLC though.

--
Wes Eddy
MTI Systems