Subject: [tcpm] WG status for 4/15/2010

From: "Eddy, Wesley M. (GRC-MS00)[ASRC AEROSPACE CORP]" <[email-masked]>
Date: Thu, 15 Apr 2010 15:30:06 -0500

Hello TCPMers, below is a snapshot of the WG status as of
this week.  There are a few updates following the IETF 77
meeting.  We're up to 4 documents in the RFC Editor queue,
1 ready to go to the IESG, 2 more in WGLC, and there are a
couple getting close to ready for WGLC.  Then there are a
number of them that we need to look at and check consensus
on whether they should become WG documents or not,
particularly the NewReno proposed modification has been
floating around for awhile, and hasn't had much feedback
lately.  If people can focus on the two in WGLC and on the
NewReno proposal, I think that would be healthy for progress.

Also, there are draft notes from IETF 77 (thanks to Jamshid
and Matt for taking notes, any errors are probably mine in
merging them!).  Vetting these would also be helpful:
http://www.ietf.org/proceedings/10mar/minutes/tcpm.txt

WG Items Nearing RFC Publication
================================

Early-Retransmit
http://www.ietf.org/id/draft-ietf-tcpm-early-rexmt-04.txt
Milestone Target: Experimental in July 2009
Status: In RFC Editor's queue
Action: None in TCPM

ICMP Attacks
http://www.ietf.org/id/draft-ietf-tcpm-icmp-attacks-11.txt
Milestone Target: Informational in July 2009
Status: finished IETF LC, with IESG
Action: None in TCPM

TCP Authentication Option
http://www.ietf.org/id/draft-ietf-tcpm-tcp-auth-opt-10.txt
Milestone Target: Proposed Standard in April 2009
Status: In RFC Editor's queue
Action: None in TCPM

TCP Authentication Option Crypto
http://www.ietf.org/id/draft-ietf-tcpm-tcp-ao-crypto-01.txt
Milestone Target: Proposed Standard with AO spec
Status: In RFC Editor's queue
Action: None in TCPM

WG Items in WGLC or being revised after WGLC
============================================

Urgent Pointer
http://www.ietf.org/id/draft-ietf-tcpm-urgent-data-05.txt
Milestone Target: Proposed Standard in January 2010
Status: updated after WGLC
Action: chairs (David) writing PROTO for sending to IESG

MSS Option
http://www.ietf.org/id/draft-ietf-tcpm-tcpmss-02.txt
Milestone Target: Proposed Standard in July 2009
Status: WGLC started 8/19, ended 9/8 (extended)
        2nd WGLC started at IETF 77, and is ended with few comments
Action: David will check with commenters from first WGLC to see
        if issues are closed

        Wes will write PROTO and send to the IESG, after WGLC
        completes

Long Connectivity Disruptions
http://www.ietf.org/id/draft-ietf-tcpm-tcp-lcd-00.txt
(need to submit WG version)
Milestone Target: Experimental in October 2010
Status: In WGLC
Action: WGLC to last 2 weeks, started on 4/13

Active WG Items
===============

1323bis
http://www.ietf.org/id/draft-ietf-tcpm-1323bis-01.txt
Milestone Target: Proposed Standard in July 2009
Status: Needs revision
Action: Revise & WGLC (action with D. Borman)

TCP Security
http://www.ietf.org/id/draft-ietf-tcpm-tcp-security-01.txt
Milestone Target: BCP in August 2010
Status: outline discussion dying off?  content needs work
Action: 00-draft / outline has been under active discussion; but not attained
          very clear consensus
        WG has begun working on recommendations while still looking for a
          possible compromise on outline (action with Fernando Gont)
        progress on recommendations made at IETF 77 needs to be worked into
          the next version of draft (D. Borman to work w/ Fernando)

SACK Entry
http://www.ietf.org/id/draft-ietf-tcpm-sack-recovery-entry-01.txt
Milestone Target: Proposed Standard in October 2010
Action: need WG to read/discuss
        TBD how this relates to 3517, and if it will update it; authors are
          to determine how much additional time this might take as a bis
          document versus standalone

Clarification of sender behavior in persist condition
http://tools.ietf.org/id/draft-ananth-tcpm-persist-01.txt
Status: discussed on mailing list and in face-to-face meetings
Action: authors to submit WG version
        WG determine what to do with socket option section
        then WGLC

Documents Under a Poll to Become WG Items
=========================================

Timestamps
http://tools.ietf.org/id/draft-gont-tcpm-tcp-timestamps-01.txt
Status: consensus to work on some portions of this, possibly as a part of the
          1323bis document
Action: need to determine if the accepted portions can be worked into 1323bis

Other Proposals Not Yet Decided On
==================================

NewReno Modification
http://www.ietf.org/internet-drafts/draft-nishida-newreno-modification-01.txt
Action: need WG to read/discuss
        presentation given, document updated, but WG list not yet polled for adoption

AO NAT
http://www.ietf.org/internet-drafts/draft-touch-tcp-ao-nat-00.txt
Status: IETF 77 discussion determined this should be Experimental, whether or
          not it is a WG document; need to ask TCPM list
Action: need to poll mailing list about path forward

Increasing TCP's Initial Window
http://tools.ietf.org/html/draft-hkchu-tcpm-initcwnd-00
Status: presented in Anaheim; lots of interest
        need to keep discussing; the work is in verifying that this is a good
          idea, moreso than documenting the change
Action: WG to continue to discuss

Computing TCP's Retransmission Timer
http://tools.ietf.org/id/draft-paxson-tcpm-rfc2988bis-00.txt
Status: presented briefly at IETF 77, also well-discussed on mailing list
          earlier and at IETF 75
Action: need to poll for becoming a WG document

Older & Expired Documents Discussed
===================================

discussions on Rate-Halving
http://tools.ietf.org/id/draft-mathis-tcp-ratehalving-00.txt
Action: mailing list discussion about the history of this, and whether
        it needs to be revived

Faster Application Handshakes with SYN/ACK Payloads
expired draft-agl-tcpm-sadata-01
Status: expired; not specifically polled for adoption in WG

Documents Not Adopted by WG
===========================

TCP Option for Transparent Middlebox Discovery
http://www.ietf.org/id/draft-knutsen-tcpm-middlebox-discovery-03.txt
Status: discussed on mailing list and updated in response
        poll for working group adoption opened on 12/9, responses
          desired by 12/23
        decision not to adopt by WG; IESG may allow publication and
          option number assignment at their discretion, but TCPM does
          not have consensus to do this work
        background presented at IETF 77

Other WG Activities
===================

Errata Review for legacy TCP RFCs:

RFC0793 (1496)  3.9  	Technical  	Legacy  Yin Shuming  		2008-08-27
RFC0793 (1561) 	3.2 	Technical 	Legacy 	Constantin Hagemeier 	2008-10-11
RFC0793 (1562) 	3.3 	Technical 	Legacy 	Constantin Hagemeier 	2008-10-11
RFC0793 (1563) 	3.4 	Technical 	Legacy 	Constantin Hagemeier 	2008-10-11
RFC0793 (1564) 	3.7 	Technical 	Legacy 	Constantin Hagemeier 	2008-10-11
RFC0793 (1565) 	3.8 	Technical 	Legacy 	Constantin Hagemeier 	2008-10-11
RFC0793 (1566) 	3.9 	Technical 	Legacy 	Constantin Hagemeier 	2008-10-11
RFC0793 (1567) 	3.9 	Technical 	Legacy 	Constantin Hagemeier 	2008-10-11
RFC0793 (1568) 	3.9 	Technical 	Legacy 	Constantin Hagemeier 	2008-10-11
RFC0793 (1569) 	2.4 	Technical 	Legacy 	Constantin Hagemeier 	2008-10-11
RFC0793 (1570) 	2.7 	Technical 	Legacy 	Constantin Hagemeier 	2008-10-11
RFC0793 (1571) 	3.1 	Technical 	Legacy 	Constantin Hagemeier 	2008-10-11
RFC0793 (1572) 	3.4 	Technical 	Legacy 	Constantin Hagemeier 	2008-10-11

--
Wes Eddy
MTI Systems

---

From: Fernando Gont <[email-masked]>
Date: Thu, 15 Apr 2010 18:36:24 -0300

Hi, Wes,

Two small comments....

> Status: finished IETF LC, with IESG

ICMP attacks has already been approved by the IESG. It's in the RFC
Editor's queue.

> Documents Under a Poll to Become WG Items

I think the idea is to publish a stand alone document that could be
published "soon". rfc1323bis could certainly pick that stuff at anytime....

Thanks,
-- 
Fernando Gont
e-mail: [email-masked] || [email-masked]
PGP Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1

---

From: Yoshifumi Nishida <[email-masked]>
Date: Fri, 16 Apr 2010 09:48:43 +0900 (JST)

Hello Eddy,

Thank you so much. Just a small correction..

 >         presentation given, document updated, but WG list not yet polled for adoption

Please use the following link

http://www.ietf.org/internet-drafts/draft-nishida-newreno-modification-02.txt

Thanks,
--
Yoshifumi Nishida
[email-masked]

From: "Eddy, Wesley M. (GRC-MS00)[ASRC AEROSPACE CORP]" <[email-masked]>
Subject: [tcpm] WG status for 4/15/2010
Date: Thu, 15 Apr 2010 15:30:06 -0500
Message-ID: <[email-masked]>

 > _______________________________________________
 > tcpm mailing list
 > [email-masked]
 > https://www.ietf.org/mailman/listinfo/tcpm

---

From: Alexander Zimmermann <[email-masked]>
Date: Fri, 16 Apr 2010 12:28:30 +0200

A small correction from me too.

The newest version is:

http://www.ietf.org/id/draft-ietf-tcpm-tcp-lcd-01.txt

Alex