Subject: [tcpm] I-D Action:draft-ietf-tcpm-anumita-tcp-stronger-checksum-00.txt

From: [email-masked]
Date: Tue, 25 May 2010 16:15:02 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the TCP Maintenance and Minor Extensions Working Group of the IETF.

	Title           : Support for Stronger Error Detection Codes in TCP for Jumbo Frames
	Author(s)       : A. Biswas
	Filename        : draft-ietf-tcpm-anumita-tcp-stronger-checksum-00.txt
	Pages           : 10
	Date            : 2010-05-25

There is a class of data serving protocols and applications that
cannot tolerate undetected data corruption on the wire.  Data
corruption could occur at the source in software, in the network
interface card, out on the link, on intermediate routers or at the
destination network interface card or node.  The Ethernet CRC and the
16-bit checksum in the TCP/UDP headers are used to detect data
errors.  Most applications rely on these checksums to detect data
corruptions and do not use any checksums or CRC checks at their
level.  Research has shown that the TCP/UDP checksums are catching a
significant number of errors, however, the research suggests that one
packet in 10 billion will have an error that goes undetected for
Ethernet MTU frames (MTU of 1500).  Under certain situations, "bad"
hosts can introduce undetected errors at a much higher frequency and
order.  With the use of Jumbo frames on the rise, and therefore more
data bits on the wire that could be corrupted, the current 16-bit
TCP/UDP checksum, or the Ethernet 32-bit CRC are simply not
sufficient for detecting errors.  This document specifies a proposal
to use stronger checksum algorithms for TCP Jumbo Frames for IPv4 and
IPv6 networks.  The Castagnoli CRC 32C algorithm used in iSCSI and
SCTP is proposed as the error detection code of choice.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-tcpm-anumita-tcp-stronger-checksum-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Eddy, Wesley M. (GRC-MS00)[ASRC AEROSPACE CORP]" <[email-masked]>
Date: Tue, 25 May 2010 21:17:29 -0500

FYI - This I-D was accidentally posted as a WG document rather than an individual submission.  We are working to have the posting corrected.  Thanks for bearing with this :).

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of [email-masked] [[email-masked]]
Sent: Tuesday, May 25, 2010 7:15 PM
To: [email-masked]
Cc: [email-masked]
Subject: [tcpm] I-D     Action:draft-ietf-tcpm-anumita-tcp-stronger-checksum-00.txt