Subject: [tcpm] response to questions raised at Beijing's meeting

From: Jerry Chu <[email-masked]>
Date: Thu, 25 Nov 2010 13:27:00 -0800

I have not seen the meeting minutes but two questions were raised
during the just passed IETF meeting, one from Lars on whether the
User Completion Time (UCT) as reported from our testbed includes
time spent on 3WHS, the other on whether raw test data from our
testbed can be made available.

The answer to the 1st question is No, our UCT does not include 3WHS.
If this is believed to be important we can certainly rerun tests to
include 3WHS.

The answer to the 2nd question is Yes, and we have made the raw
data available for download from
http://research.csc.ncsu.edu/netsrv/?q=content/iw10

Unfortunately the set of raw data does NOT include tcpdump traces
due to the sheer sizes. If you really want the packet traces we can
certainly rerun tests to collect them. But we'll probably need to find a
way to host the possibly voluminous data more efficiently.

BTW, the above mentioned web page contains all the info about the
testbed hosted by NCSU and parameters used in our tests. If you'd
like to see a different set of parameters being used just let us know.
But please apply good judgement as we can only accommodate a
limited number of test requests due to time constraint. (Dr. Idris Rai
has questioned the use of 40 pkt buffer being too large. But as others
pointed out that size is not unreasonable. Also we've found out a
buffer pool smaller than 40 can cause severe performance (response
time) degradation even for IW3.

Thanks,

Jerry

---

From: Lars Eggert <[email-masked]>
Date: Fri, 26 Nov 2010 09:41:48 +0200

Hi,

> If this is believed to be important we can certainly rerun tests to

thanks for checking this.

I believe that it would be good to see results where UTC is the time from when the SYN is sent until the connection closes. There are two reasons:

(1) If SYNs or SYN-ACKs are lost, your current metric doesn't capture the impact of the resulting 3-second retransmit timer. Since packet loss rates are sometimes somewhat higher with IW10 compared to IW3, I'd expect at least some SYNs and SYN-ACKs to be lost.

(2) Not including the SYN exchange in UTC overestimates the actual delay improvement with IW10, because the current UTC times are at least 1.5RTT lower than what a user would actually see (click-wait-read).

Lars

---

From: <[email-masked]>
Date: Fri, 26 Nov 2010 09:21:09 +0000

On 26 Nov 2010, at 07:41, Lars Eggert wrote:
> (1) If SYNs or SYN-ACKs are lost, your current metric doesn't capture the impact of the resulting 3-second retransmit timer.

Worth noting that the SYN timer is usually 3 seconds with further exponential backoff, but varies somewhat between implementations in value and how often they repeat before giving up. ( I think Linux quits after 6 attempts, BSD after 9.)

Lloyd Wood
[email-masked]
http://sat-net.com/L.Wood