Subject: [tcpm] dctcp

From: "Scheffenegger, Richard" <[email-masked]>
Date: Thu, 11 Nov 2010 11:51:56 -0000

Hi,

I just listened to the recorded TCPM meeting, and wanted to follow up on
the rather rushed talk about DCTCP.

Who made the comment about NFSv4 being prone to the same (incast)
issues? (After Andrew made his comment about RED defaults)

Also, the recording gave the impression, that there was high interest in
doing a I-D.

Reading the TSVAREA material, it was also pointed out (storage teaser -
NFSv4, iSCSI) that TCPM may need to look closer at datacenter
environments rather soon.

Were there any other offline discussions outside the meeting room, which
would be worthwhile to document here on the list?

Best regards,

Richard Scheffenegger

---

From: Joe Touch <[email-masked]>
Date: Fri, 12 Nov 2010 12:05:52 -0800

On 11/11/2010 3:51 AM, Scheffenegger, Richard wrote:
...
> environments rather soon.

Tuning TCP for private networks (i.e., not using the Internet, or 
competing with Internet flows) seems out of scope for TCPM.

It might not even be relevant elsewhere in the IETF, except as an issue 
of common interest. Protocols running over private networks don't need 
to adhere to standards.

Joe

---

From: Joe Touch <[email-masked]>
Date: Sat, 13 Nov 2010 06:48:58 -0800

On 11/13/2010 1:59 AM, Andrew McGregor wrote:
> That's true, but if it can be made to happen automatically that would, I suspect, be in scope.

Automatic isn't the issue. Impact with the rest of the Internet is.

A general autotuning TCP would be one thing, but even that wouldn't be a 
'minor' mod to TCP; it's a generic issue common to all reactive 
transports (DCCP, SCTP, etc.)

The two issues are:
- is this a TCPM issue?
- is this an IETF issue at all?

I have questions on both counts. Keep in mind, e.g., that there's no "IP 
for SCSI" (there was a time when that was assumed as required).

Joe

> On 13/11/2010, at 4:05 AM, Joe Touch wrote:
>
>>
>>
>> Tuning TCP for private networks (i.e., not using the Internet, or competing with Internet flows) seems out of scope for TCPM.
>>
>> It might not even be relevant elsewhere in the IETF, except as an issue of common interest. Protocols running over private networks don't need to adhere to standards.
>>
>> Joe
>

---

From: "Anantha Ramaiah (ananth)" <[email-masked]>
Date: Sat, 13 Nov 2010 08:46:01 -0800

Well,

My thoughts here are :-

- If someone is using a protocol defined by IETF, then it is desirable
to abide by the standards, irrespective of the type of network. 

- interoperability across different devices (may be coming from
different vendors), using the same protocol, is one of the reason you
need standards! 

-  From an implementation perspective you don't want "private TCP" and
"public TCP" in the same stack since the same stack needs to cater to
TCP connections from *both* private and public networks!

- The problems and the solutions which are posed by the data center
environments may not be unique. The question to ask is : "what is the
problem and whether the problems and solutions would have a generic
applicability.  

- Also how do you draw a boundary as to a what is private network and
what isn't ? Why is data center environment considered a "private
network" ?

IMO, it is an issue that can be well addressed (if there is a need) by
the IETF,  if changes are being planned with TCP protocol, yes TCPM is
the right place for such efforts.

$0.02,
-Anantha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Joe Touch
Sent: Friday, November 12, 2010 12:06 PM
To: Scheffenegger, Richard
Cc: Murari Sridharan; tcpm; Andrew McGregor
Subject: Re: [tcpm] dctcp

Joe
_______________________________________________
tcpm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tcpm

---

From: Andrew McGregor <[email-masked]>
Date: Sat, 13 Nov 2010 17:59:28 +0800

Andrew

---

From: Murari Sridharan <[email-masked]>
Date: Tue, 16 Nov 2010 17:39:54 +0000

I agree. We believe that DCTCP has certain properties that are generally applicable and personally I see DCTCP as an enabler for ECN even if in private or enterprise networks as it makes the switch side configuration rather trivial. I also think the ideas in the paper have broad applicability which is the reason why I wanted to present this to TCPM. Our goal has been to design DCTCP such that without ECN marks it behaves exactly like New Reno or whatever congestion control it is built on. In our case we built it as a modification to New Reno, I therefore think it is very much in scope for discussion. Whether it is in TCPM or ICCRG (treating DCTCP as an alternative congestion control algorithm) is for the WG to decide. 

Remember if you are in a multi-tenant datacenter, algorithms like DCTCP are most effective especially at the switches only if all the senders are conformant to DCTCP, in that vein it is worth discussing at IETF. 

If the WG and the chairs agree I intend to submit an ID explaining the changes. I propose two alternatives. One way to think of this is as a modification to the ECN RFC, to say that instead of halving in response to the *presence* of congestion; react to the *extent* of congestion by averaging the ECN marks which is what DCTCP does. Personally I believe this is a better approach however the alternative option is to submit DCTCP as a new congestion control algorithm. Thoughts?

Thanks
Murari 

-----Original Message-----
From: Anantha Ramaiah (ananth) [mailto:[email-masked]] 
Sent: Saturday, November 13, 2010 8:46 AM
To: Joe Touch; Scheffenegger, Richard
Cc: Murari Sridharan; tcpm; Andrew McGregor
Subject: RE: [tcpm] dctcp

Well,

My thoughts here are :-

- If someone is using a protocol defined by IETF, then it is desirable to abide by the standards, irrespective of the type of network. 

- interoperability across different devices (may be coming from different vendors), using the same protocol, is one of the reason you need standards! 

-  From an implementation perspective you don't want "private TCP" and "public TCP" in the same stack since the same stack needs to cater to TCP connections from *both* private and public networks!

- The problems and the solutions which are posed by the data center environments may not be unique. The question to ask is : "what is the problem and whether the problems and solutions would have a generic applicability.  

- Also how do you draw a boundary as to a what is private network and what isn't ? Why is data center environment considered a "private network" ?

IMO, it is an issue that can be well addressed (if there is a need) by the IETF,  if changes are being planned with TCP protocol, yes TCPM is the right place for such efforts.

$0.02,
-Anantha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joe Touch
Sent: Friday, November 12, 2010 12:06 PM
To: Scheffenegger, Richard
Cc: Murari Sridharan; tcpm; Andrew McGregor
Subject: Re: [tcpm] dctcp

Joe