Subject: Re: [tcpm] Side meeting to discuss TCP Security document

From: Joe Touch <[email-masked]>
Date: Wed, 01 Dec 2010 19:07:17 -0800

Dave,

I've asked repeatedly off-list, so I'll ask on-list.

Will there be a summary of the results of this meeting posted to the list?

Joe

On 11/9/2010 4:43 PM, David Borman wrote:
> We have Diamond 2 reserved from 1:00-3:00 today, Wednesday.  Anyone who is interested is welcome.
>
> 			-David Borman, TCPM co-chair
>
> On Nov 7, 2010, at 10:20 PM, David Borman wrote:
>
>> In Anaheim we had a small session to look at the TCP Security document, attended by a hand full of people.  We are interested in doing this again here in Beijing.  The goal is to go through some more of the document and come up with some recommendations for how to move forward with revising/editing the document, which will then be brought back to the list.
>>
>> So, there are 2 questions:
>> 1) Who is interested in attending?
>> 2) When should we meet?  My recommendations for possibilities are, in order of preference:
>> 	1) Tuesday morning (NFSv4 meets at this time)
>> 	2) Wednesday after lunch (No TSV groups meet at this time)
>> 	3) Thursday morning (Congestion Exposure WG meets at this time)
>> Please reply to me or the list if you are interested in this, and if so, which of those 3 periods you are available. Once we see who is interested and when they would be available, I'll see about finding a place to meet, but it won't be a regular session room, i.e. there won't be any remote participation.
>>
>> 			-David Borman, TCPM co-chair
>> _______________________________________________
>> tcpm mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/tcpm
>

---

From: David Borman <[email-masked]>
Date: Thu, 2 Dec 2010 15:52:46 -0600

Joe,

> Will there be a summary of the results of this meeting posted to the list?

See the meeting minutes:
	http://www.ietf.org/proceedings/79/minutes/tcpm.txt
			-David

---

From: Joe Touch <[email-masked]>
Date: Thu, 02 Dec 2010 13:59:02 -0800

Hi, Dave,

Thanks. I wouldn't have looked for it there, but glad to see the notes.

What I have not seen yet is a discussion of a few key issues:

1) the numerous errors in the doc

2) the confusion between issues
	specification issues
	implementation issues
	operational issues

3) the large amount of this document that can be compressed to a single 
simple statement of general good programming practice, that is already 
implicit or explicit in most specifications:

	check values before you act on them

If the doc would separate the issues, fix the errors, and omit the 'good 
programming platitudes', it might be useful. That won't happen, IMO, one 
section at a time.

Joe