Subject: Re: [tcpm] [Technical Errata Reported] RFC5681 (5458)

From: Michael Tuexen <[email-masked]>
Date: Mon, 13 Aug 2018 11:01:39 +0200

> On 13. Aug 2018, at 01:33, RFC Errata System <[email-masked]> wrote:
> 
> The following errata report has been submitted for RFC5681,
> "TCP Congestion Control".
> 
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata/eid5458
> 
> --------------------------------------
> Type: Technical
> Reported by: James McCauley <[email-masked]>
> 
> Section: 2
> 
> Original Text
> -------------
>   DUPLICATE ACKNOWLEDGMENT: An acknowledgment is considered a
>      "duplicate" in the following algorithms when (a) the receiver of
>      the ACK has outstanding data, (b) the incoming acknowledgment
>      carries no data, (c) the SYN and FIN bits are both off, (d) the
>      acknowledgment number is equal to the greatest acknowledgment
>      received on the given connection (TCP.UNA from [RFC793]) and (e)
>      the advertised window in the incoming acknowledgment equals the
>      advertised window in the last incoming acknowledgment.
> 
> Corrected Text
> --------------
>   DUPLICATE ACKNOWLEDGMENT: An acknowledgment is considered a
>      "duplicate" in the following algorithms when (a) the receiver of
>      the ACK has outstanding data, (b) the incoming acknowledgment
>      carries no data, (c) the SYN and FIN bits are both off, (d) the
>      acknowledgment number is equal to the greatest acknowledgment
>      received on the given connection (SND.UNA from [RFC793]) and (e)
>      the advertised window in the incoming acknowledgment equals the
>      advertised window in the last incoming acknowledgment.
> 
> Notes
> -----
> There is no such thing as TCP.UNA in RFC793.  The boundary between acknowledged and unacknowledged sent data is SND.UNA.
I agree.

Best regards
Michael
> 
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party  
> can log in to change the status and edit the report, if necessary. 
> 
> --------------------------------------
> RFC5681 (draft-ietf-tcpm-rfc2581bis-07)
> --------------------------------------
> Title               : TCP Congestion Control
> Publication Date    : September 2009
> Author(s)           : M. Allman, V. Paxson, E. Blanton
> Category            : DRAFT STANDARD
> Source              : TCP Maintenance and Minor Extensions
> Area                : Transport
> Stream              : IETF
> Verifying Party     : IESG

---

From: RFC Errata System <[email-masked]>
Date: Sun, 12 Aug 2018 16:33:12 -0700 (PDT)

Section: 2

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Mon, 13 Aug 2018 11:34:35 +0200

Verified as editorial errata.

> Am 13.08.2018 um 11:01 schrieb Michael Tuexen <[email-masked]>:
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm