Subject: Re: [tcpm] New Version Notification for draft-ietf-tcpm-rack-05.txt

From: "Scharf, Michael" <[email-masked]>
Date: Mon, 6 May 2019 08:19:53 +0000

Hi Yuchung,

A purely editorial comment on the new text in -05:

The definition of terms has been updated by RFC 8174 and the new suggested wording is:

      The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL
      NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED", "NOT RECOMMENDED",
      "MAY", and "OPTIONAL" in this document are to be interpreted as
      described in BCP 14 [RFC2119] [RFC8174] when, and only when, they
      appear in all capitals, as shown here.

Unless there are good reasons to deviate, IMHO it would make sense to use the default text.

Also, note that there is some use of capital letter terms before Section 5. The definition should probably be introduced before the first use (in the body).

Finally, draft-ietf-tcpm-rack-05 references RFC2119 three times, which may be a tooling bug.

Those editorial nits can be fixed later in the publication process, but as these are low hanging fruits, IMHO it would make sense to correct them in the next version.

Thanks

Michael

From: Yuchung Cheng <[email-masked]>
Sent: Saturday, April 27, 2019 3:43 AM
To: [email-masked]; [email-masked] Extensions <[email-masked]>
Subject: Fwd: New Version Notification for draft-ietf-tcpm-rack-05.txt

Hi we are posting new draft per chairs' request for discussion on status.

04-05 diffs are minor edits for clarification raised by many reviewers (thanks!). No changes to algorithm / protocol.
---------- Forwarded message ---------
From: <[email-masked]<mailto:[email-masked]>>
Date: Fri, Apr 26, 2019 at 6:39 PM
Subject: New Version Notification for draft-ietf-tcpm-rack-05.txt
To: Neal Cardwell <[email-masked]<mailto:[email-masked]>>, Yuchung Cheng <[email-masked]<mailto:[email-masked]>>, Priyaranjan Jha <[email-masked]<mailto:[email-masked]>>, Nandita Dukkipati <[email-masked]<mailto:[email-masked]>>

A new version of I-D, draft-ietf-tcpm-rack-05.txt
has been successfully submitted by Yuchung Cheng and posted to the
IETF repository.

Name:           draft-ietf-tcpm-rack
Revision:       05
Title:          RACK: a time-based fast loss detection algorithm for TCP
Document date:  2019-04-26
Group:          tcpm
Pages:          29
URL:            https://www.ietf.org/internet-drafts/draft-ietf-tcpm-rack-05.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-tcpm-rack/
Htmlized:       https://tools.ietf.org/html/draft-ietf-tcpm-rack-05
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-tcpm-rack
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-tcpm-rack-05

Abstract:
   This document presents a new TCP loss detection algorithm called RACK
   ("Recent ACKnowledgment").  RACK uses the notion of time, instead of
   packet or sequence counts, to detect losses, for modern TCP
   implementations that can support per-packet timestamps and the
   selective acknowledgment (SACK) option.  It is intended to replace
   the conventional DUPACK threshold approach and its variants, as well
   as other nonstandard approaches.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

---

From: Yuchung Cheng <[email-masked]>
Date: Mon, 6 May 2019 09:37:47 -0700

Thanks Mchael. Noted and will correct in the next revision.

On Mon, May 6, 2019 at 1:19 AM Scharf, Michael <
[email-masked]> wrote:

> Also, note that there is some use of capital letter terms before Section
> 5. The definition should probably be introduced before the first use (in
> the body).
>
>
>
> Those editorial nits can be fixed later in the publication process, but as
> these are low hanging fruits, IMHO it would make sense to correct them in
> the next version.
>
>
>
> Thanks
>
>
>
> Michael
>
>
>
>
>
> *From:* Yuchung Cheng <[email-masked]>
> *Sent:* Saturday, April 27, 2019 3:43 AM
> *To:* [email-masked]; [email-masked] Extensions <[email-masked]>
> *Subject:* Fwd: New Version Notification for draft-ietf-tcpm-rack-05.txt
>
>
>
> 04-05 diffs are minor edits for clarification raised by many reviewers
> (thanks!). No changes to algorithm / protocol.
>
> From: <[email-masked]>
> To: Neal Cardwell <[email-masked]>, Yuchung Cheng <[email-masked]>,
> Priyaranjan Jha <[email-masked]>, Nandita Dukkipati <
> [email-masked]>
>
>
>
>
> URL:
> https://www.ietf.org/internet-drafts/draft-ietf-tcpm-rack-05.txt
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>