Subject: [tcpm] RFC793bis draft 14 Reserved Bits

From: Mike Kosek <[email-masked]>
Date: Wed, 27 Nov 2019 17:29:55 +0000

Hi tcpm,

Sorry for bumping this, maybe it got overlooked during 106.

Catching up on draft-ietf-tcpm-rfc793bis-14, I was wondering why the rsrvd bits are not explicitly stated as a formal MUST requirement: 

"Must be zero in generated segments and must be ignored in received segments, if corresponding future features are unimplemented by the sending or receiving host."

To my understanding, the current phrasing is up to interpretation, i.e., someone might opt to not implement it as stated due to the missing formal MUST - Please prove me wrong if I am missing something.

Best Regards,
Mike

---

From: "Rodney W. Grimes" <[email-masked]>
Date: Wed, 27 Nov 2019 18:44:33 -0800 (PST)

> To my understanding, the current phrasing is up to interpretation, i.e., someone might opt to not implement it as stated due to the missing formal MUST - Please prove me wrong if I am missing somet…

I would even like to see it go further and add "they MUST be ignored by the network, and traverse the network unchanged."

-- 
Rod Grimes                                                 [email-masked]

---

From: Joe Touch <[email-masked]>
Date: Wed, 27 Nov 2019 19:52:53 -0800

> On Nov 27, 2019, at 6:44 PM, Rodney W. Grimes <[email-masked]> wrote:
> 
>> Hi tcpm,
>> 
> I would even like to see it go further and add "they MUST be ignored by the network, and traverse the network unchanged.”

Perhaps further explicitly:

they MUST be ignored by the network and MUST traverse the network unchanged