Subject: [tcpm] Open questions in draft-scharf-tcpm-yang-tcp-03

From: "Scharf, Michael" <[email-masked]>
Date: Thu, 28 Nov 2019 18:37:00 +0000

[chair hat off]

At IETF 106 there was not enough time left for Mahesh to present the latest update of the document "YANG Model for Transmission Control Protocol (TCP) Configuration".

Mahesh, Vishal and me have significantly updated draft-scharf-tcpm-yang-tcp-03 since the last meeting. The changes are summarized in the slides that can be found at:

   https://datatracker.ietf.org/meeting/106/materials/slides-106-tcpm-yang-model-for-transmission-control-protocol-tcp-configuration-01

Our proposal to refine the scope of the document. This results in at least 4 questions:

1. Should the model support statistics?

2. Should it model all TCP connections?

3. Add support for TCP-AO?

4. Add support for TCP-MD5?

The slide deck details why these four questions are relevant. At least the last two requirements originate from another IETF document (draft-ietf-idr-bgp-model).

The authors plan to further update the document and address open issues as far as possible. Therefore we seek guidance from the TCPM community on these questions. Feedback on the list (or off-list) would be highly welcome.

Thanks

Michael (on behalf of the authors)

PS: I'd like to note that the TCPM chairs usually try hard to give at least some time to all presentations on the agenda. While I believe that this is an important tradition in TCPM, I decided not to intervene last meeting in order to avoid an impression that an own document would be prioritized over other topics.

---

From: Joe Touch <[email-masked]>
Date: Fri, 29 Nov 2019 09:08:37 -0800

Hi, Michael,

> On Nov 28, 2019, at 10:37 AM, Scharf, Michael <[email-masked]> wrote:
> 
> [chair hat off]
> 

IMO, no - that should be a different, optional model (TCP-stats or something).

> 2. Should it model all TCP connections?

I don’t know what that means, even given the slides. I would expect there to be some common practice for this in YANG models, i.e., to describe how state is grouped by address.

> 3. Add support for TCP-AO?

It should include all current standards-track options IMO.

> 4. Add support for TCP-MD5?

For the reason above, this should not be included - it is deprecated by TCP-AO. If supported, it should be clearly identified as deprecated.

Joe