Subject: Re: [tcpm] [Lwip] Review of draft-ietf-lwig-tcp-constrained-node-networks-04

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Sun, 17 Nov 2019 10:32:50 +0100

Hi Ilpo,

First of all, apologies for this very late reply.

Once again, thanks a lot for your thorough review!

We recently published -09. We believe that this last revision addresses
your remaining points below.

Should you have further comments, please do not hesitate to let us know.

Thanks,

Carles

> On Fri, 23 Aug 2019, Mohit Sethi M wrote:
>
>> Hi Ilpo and Markku,
>>
>> Could you confirm that -08 version of the draft addresses all your
>> concerns. We will then send it to the IESG for review.
>
> For me, no major concerns remaining. A few minor points from the text
> edited in -08.
>
> The "pure ACK" might be better to write open, e.g., "ACK without
> payload".
>
> The current text in FR/FR scenario with 1-6 segment might confuse as
> the sixth segment is only sent out on the first (duplicate) ACK. The
> current wording makes it to sound as if 1-6 would be outstanding right
> at the beginning (instead of first 1-5 and then 2-6 after the ACK).
>
> "plus two additional segments for each one of the first two duplicate
> ACKs."
> I think this might be misinterpreted to mean 2*2 segments.
>
>
>
> --
>  i.
>

---

From: "Ilpo Järvinen" <[email-masked]>
Date: Sun, 17 Nov 2019 13:08:04 +0200 (EET)

> Should you have further comments, please do not hesitate to let us know.

Thanks. It looks good now.

I was a bit surprised by the return of the "single-MSS" but then found out 
you had a good reason for that.

-- 
 i.

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Mon, 18 Nov 2019 01:35:00 +0100

> you had a good reason for that.

Indeed! :)

Thanks,

Carles