Subject: [tcpm] Review of hystartplusplus-01

From: "Ilpo Järvinen" <[email-masked]>
Date: Wed, 22 Jan 2020 14:24:18 +0200 (EET)

Hi all,

I've just read through the HyStart++ draft v01. Two comments:

I find using variable named "Eta" and related constants (MIN/MAX_ETA) 
somewhat strange as to me ETA reads "estimated time of arrival" which in 
the context didn't seem to make much of a sense.

Then there is a major contradiction within the draft:

if (currentRoundMinRTT >= (lastRoundMinRTT + Eta))
               ssthresh = cwnd
               exit slow start and enter LSS

  "HyStart++ ends when cwnd exceeds ssthresh or when congestion is
   observed."

...ssthresh is set to cwnd when exiting slow start and LSS is entered as 
per the algorithm but the quoted sentence tells that LSS will be 
terminated as soon as cwnd grows any?

-- 
 i.

---

From: Praveen Balasubramanian <[email-masked]>
Date: Thu, 23 Jan 2020 06:00:11 +0000

Thanks for the review!

The variable name Eta comes from equations in the HyStart paper " Hybrid Slow Start for High-Bandwidth and Long-Distance Networks" which use the Greek alphabet η. We will change to call it RTT threshold to avoid confusion with "estimated time of arrival".

Indeed that is a contradiction and is a mistake. HyStart++ ends after the first congestion signal is observed. 

Thanks

-----Original Message-----
From: Ilpo Järvinen <[email-masked]> 
Sent: Wednesday, January 22, 2020 4:24 AM
To: [email-masked]; Praveen Balasubramanian <[email-masked]>; Yi Huang <[email-masked]>; Matt Olson <[email-masked]>
Subject: [EXTERNAL] Review of hystartplusplus-01

Hi all,

I find using variable named "Eta" and related constants (MIN/MAX_ETA) somewhat strange as to me ETA reads "estimated time of arrival" which in the context didn't seem to make much of a sense.

...ssthresh is set to cwnd when exiting slow start and LSS is entered as per the algorithm but the quoted sentence tells that LSS will be terminated as soon as cwnd grows any?

--
 i.