Subject: [tcpm] FW: Request for feedback on WG adoption of draft-scharf-tcpm-yang-tcp-04

From: "Scharf, Michael" <[email-masked]>
Date: Wed, 18 Mar 2020 20:12:55 +0000

Hi all,

This is a heads-up regarding the ongoing adoption call for draft-scharf-tcpm-yang-tcp-04 in TCPM.

You may want to pay attention. For instance, this document defines groupings for TCP-AO and MD5, which are used by draft-ietf-idr-bgp-model.

If you support work of this document in TCPM, or if you have any comments, please free to provide feedback on the TCPM list ([email-masked]).

Thanks

Michael (TCPM chair hat off)

Von: Michael Tuexen<mailto:[email-masked]>
Gesendet: Montag, 16. März 2020 21:44
An: tcpm IETF list<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Betreff: Request for feedback on WG adoption of draft-scharf-tcpm-yang-tcp-04

Dear all,

this mail starts a WG adoption call for
https://tools.ietf.org/html/draft-scharf-tcpm-yang-tcp-04

So I would like to solicit feedback regarding support for or objections against the
adoption of the document as a WG document in TCPM.

Please provide feedback before March 31st.

For the context and current state of the document, see the presentation sent yesterday
to the mailing list by Mahesh.

Best regards
Michael

---

From: tom petch <[email-masked]>
Date: Wed, 25 Mar 2020 12:52:42 +0000

From: Idr <[email-masked]> on behalf of Scharf, Michael <[email-masked]>
Sent: 18 March 2020 20:12

Hi all,

<tp>
Michael

I note that you have also sent this to Netconf and that you import groupings from the netconf-tcp draft which makes the netconf draft a Normative Reference except that this I-D does not mention that fact. 

I think this is problematic.  Progress on the netconf I-D has been slow for some years and so your I-D could have to wait a while.  The solution would be to progress the netconf draft but I do not know how this can be expedited.

There are a lot of details in this I-D that I think of as admin which need fixing to conform to YANG Guidelines but would not see that as a bar to adoption whereas dependency on netconf is more debatable IMHO.

Tom Petch

Thanks

Dear all,

Best regards
Michael

---

From: "Scharf, Michael" <[email-masked]>
Date: Wed, 25 Mar 2020 16:39:47 +0000

Hi Tom,

> -----Original Message-----
> From: tom petch <[email-masked]>
> Sent: Wednesday, March 25, 2020 1:53 PM
> To: Scharf, Michael <[email-masked]>; [email-masked]
> Cc: tcpm IETF list <[email-masked]>
> Subject: Re: Request for feedback on WG adoption of draft-scharf-tcpm-yang-
> tcp-04
> 
> I note that you have also sent this to Netconf and that you import groupings
> from the netconf-tcp draft which makes the netconf draft a Normative
> Reference except that this I-D does not mention that fact.

[I-D.ietf-netconf-tcp-client-server] is listed as first normative reference in draft-scharf-tcpm-yang-tcp and that dependency is also mentioned in the abstract. With the current structure of the models, it is not clear to me why a reference in the reverse direction would be needed.

So far, the feedback from the NETCONF chairs was that draft-ietf-netconf-tcp-client-server would most likely finish before a TCPM document. The work in the NETCONF WG started much earlier.

> I think this is problematic.  Progress on the netconf I-D has been slow for some
> years and so your I-D could have to wait a while.  The solution would be to
> progress the netconf draft but I do not know how this can be expedited.

That is an interesting line of thought. Actually, when I wear the hat of a co-chair of TCPM, I get told again and again that TCPM is too slow... We currently try our best to speed up a bit. However, due to the complexity of TCP, the heterogeneity of implementations, and the scale of deployment of the protocol, TCPM needs some time to process documents. This would almost certainly also apply to a YANG model. In addition, TCPM has not dealt with YANG so far, i.e., it is a new topic for the working group.

Realistically, even if we as authors try our best, the normative reference to the netconf I-D would only become a problem if that document does not progress at all for a longer time.

Would you prefer a TCPM document without that normative reference? In any case, I doubt that timing should be the main motivation for that. Would there be other reasons?

> There are a lot of details in this I-D that I think of as admin which need fixing to
> conform to YANG Guidelines but would not see that as a bar to adoption
> whereas dependency on netconf is more debatable IMHO.

Indeed, many details require further work. That is well understood.

Thanks

Michael

> Tom Petch
> 
> 
> You may want to pay attention. For instance, this document defines groupings
> for TCP-AO and MD5, which are used by draft-ietf-idr-bgp-model.
> 
> If you support work of this document in TCPM, or if you have any comments,
> please free to provide feedback on the TCPM list ([email-masked]).
> 
> Thanks
>