Subject: Re: [tcpm] Request for feedback on WG adoption of draft-scharf-tcpm-yang-tcp-04

From: "Scharf, Michael" <[email-masked]>
Date: Fri, 27 Mar 2020 13:52:00 +0000

Lars,

I have not followed the IETF when RFC 4022 (TCP-MIB) was published, but I found a number of implementations of TCP-MIB, as mentioned during IETF 104. It seems that the TCP-MIB is more commonly implemented on routers than on host operating systems, and the latter TCP stacks are probably more well-known. And it is well understood that YANG models will also in future most likely more matter for the former type of TCP stacks.

But, wait a second: I recommend to have a look at the output of „cat /proc/net/snmp“ under Linux (just tested on Debian Buster)…

As far as I can see, these are the object definitions from the TCP-MIB. If implemented on Linux, why does the TCP-MIB not matter?

(I don’t assume that a vanilla Linux kernel will implement a YANG model in short term. As mentioned in another thread, a YANG model would typically be implemented outside the kernel in NETCONF server and client applications, if it is used for network management.)

In contrast to the TCP-MIB, I have not found any implementation of RFC 4898, and, according to datatracker, that RFC apparently took five years. So maybe the „TCP Statistics Extended MIB“ RFC 4898 is not a great success story... However, we have learnt from that: We have explicitly decided not to include extended statistics in draft-scharf-tcpm-yang-tcp. The draft currently only includes basic stats.

It is well understood that there *are* challenges with coming up for a YANG model for TCP. But if RFC 4898 got it wrong, we could learn from that, IMHO.

Michael

Von: Lars Eggert<mailto:[email-masked]>
Gesendet: Freitag, 27. März 2020 13:40
An: Michael Tuexen<mailto:[email-masked]>
Cc: tcpm IETF list<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Betreff: Re: [tcpm] Request for feedback on WG adoption of draft-scharf-tcpm-yang-tcp-04

Hi,

On 2020-3-16, at 22:44, Michael Tuexen <[email-masked]> wrote:
> this mail starts a WG adoption call for
> https://tools.ietf.org/html/draft-scharf-tcpm-yang-tcp-04
...
> Please provide feedback before March 31st.

I (still) don't believe this is worthwhile for the WG to take on.

My view here is very much biased by the disaster that were (are?) the TCP SNMP MIBs. Besides needing two attempts to get it right (RFC4022 followed by RFC4898), it took five years of WG time and produced work that AFAICT never really mattered, and quickly became stale.

I don't see any indications that a YANG model for TCP wouldn't follow the same course. Are there any stacks that indicated they were going to implement this? Who wants this?

Thanks,
Lars

---

From: Lars Eggert <[email-masked]>
Date: Fri, 27 Mar 2020 16:15:13 +0200

Hi,

> As far as I can see, these are the object definitions from the TCP-MIB. If implemented on Linux, why does the TCP-MIB not matter?

/proc/net/snmp provides the scalars (a small subset of 4022), and obviously just in text form. Are you aware of any uses?

> However, we have learnt from that: We have explicitly decided not to include extended statistics in draft-scharf-tcpm-yang-tcp. The draft currently only includes basic stats.

Well, basic stats and AO detail. (And why still MD5? We obsoleted 2385 ten years ago.)

> It is well understood that there *are* challenges with coming up for a YANG model for TCP. But if RFC 4898 got it wrong, we could learn from that, IMHO.

You are much more optimistic than I am.

Lars