Subject: [tcpm] Fwd: New Version Notification for draft-scharf-tcpm-yang-tcp-04.txt

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 9 Mar 2020 13:37:58 -0700

This update of the draft added text to address the issues we discussed in IETF 106. In particular it adds:
a container to keep track of all TCP connections
statistics and ability to clear them (if support for it is indicated using the feature statement)
support for securing the connection using TCP-AO or MD5
congestion control algorithms
ECN

Please review and provide comments.

We, the authors believe that the draft is ready for WG adoption at this time.

Thanks.

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-scharf-tcpm-yang-tcp-04.txt
> Date: February 24, 2020 at 11:56:39 AM PST
> To: "Michael Scharf" <[email-masked]>, "Mahesh Jethanandani" <[email-masked]>, "Vishal Murgai" <[email-masked]>
> 
> 
> A new version of I-D, draft-scharf-tcpm-yang-tcp-04.txt
> has been successfully submitted by Mahesh Jethanandani and posted to the
> IETF repository.
> 
> Name:		draft-scharf-tcpm-yang-tcp
> Revision:	04
> Title:		YANG Model for Transmission Control Protocol (TCP) Configuration
> Document date:	2020-02-24
> Group:		Individual Submission
> Pages:		21
> URL:            https://www.ietf.org/internet-drafts/draft-scharf-tcpm-yang-tcp-04.txt
> Status:         https://datatracker.ietf.org/doc/draft-scharf-tcpm-yang-tcp/
> Htmlized:       https://tools.ietf.org/html/draft-scharf-tcpm-yang-tcp-04
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-scharf-tcpm-yang-tcp
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-scharf-tcpm-yang-tcp-04
> 
> Abstract:
>   This document specifies a YANG model for TCP on devices that are
>   configured by network management protocols.  The YANG model defines a
>   container for all TCP connections and groupings of fundamental
>   parameters that can be imported and used in many TCP implementations.
>   The model includes definitions from YANG Groupings for TCP Client and
>   TCP Servers (I-D.ietf-netconf-tcp-client-server).  The model is NMDA
>   (RFC 8342) compliant.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> 

Mahesh Jethanandani
[email-masked]

---

From: Mahesh Jethanandani <[email-masked]>
Date: Sat, 14 Mar 2020 16:19:54 -0700

We, the authors had planned to present the attached set of slides at the 107 meeting. The deck consist of both the slides we had planned for 106, but did not have an opportunity to present, and 107 which has been cancelled. 

The work on the draft however has continued in that time frame. In the 106 time frame we came up with a proposal on what we wanted to do with the draft, and since then went ahead and implemented some of those proposals. The submission of -04 reflects that work. It should also be noted that other drafts have been wanting to use this model. In particular, draft-ietf-idr-bgp-yang <https://tools.ietf.org/html/draft-ietf-idr-bgp-model-08> uses the YANG model defined in this draft to secure the BGP session.

We believe the draft is ready for WG adoption at this time. Let us know if there are any questions.

Thanks.

> On Mar 9, 2020, at 1:37 PM, Mahesh Jethanandani <[email-masked]> wrote:
> 
>> From: [email-masked] <mailto:[email-masked]>
>> To: "Michael Scharf" <[email-masked] <mailto:[email-masked]>>, "Mahesh Jethanandani" <[email-masked] <mailto:[email-masked]>>, "Vishal Murgai" <[email-masked] <mailto:[email-masked]>>
>> 
>> 
>> URL:            https://www.ietf.org/internet-drafts/draft-scharf-tcpm-yang-tcp-04.txt <https://www.ietf.org/internet-drafts/draft-scharf-tcpm-yang-tcp-04.txt>
>> Status:         https://datatracker.ietf.org/doc/draft-scharf-tcpm-yang-tcp/ <https://datatracker.ietf.org/doc/draft-scharf-tcpm-yang-tcp/>
>> Htmlized:       https://tools.ietf.org/html/draft-scharf-tcpm-yang-tcp-04 <https://tools.ietf.org/html/draft-scharf-tcpm-yang-tcp-04>
>> Htmlized:       https://datatracker.ietf.org/doc/html/draft-scharf-tcpm-yang-tcp <https://datatracker.ietf.org/doc/html/draft-scharf-tcpm-yang-tcp>
>> Diff:           https://www.ietf.org/rfcdiff?url2=draft-scharf-tcpm-yang-tcp-04 <https://www.ietf.org/rfcdiff?url2=draft-scharf-tcpm-yang-tcp-04>
>> 
>> Abstract:
>> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
>> 
>> The IETF Secretariat
>> 
>> 

Mahesh Jethanandani (on behalf of all the authors).
[email-masked]