Subject: Re: [tcpm] I-D Action: draft-ietf-tcpm-rto-consider-11.txt

From: Mark Allman <[email-masked]>
Date: Thu, 30 Apr 2020 15:36:09 -0400

>         Title           : Requirements for Time-Based Loss Detection
>         Author          : Mark Allman
> 	Filename        : draft-ietf-tcpm-rto-consider-11.txt
> 	Pages           : 10
> 	Date            : 2020-04-30

I believe this version addresses the wording issue in requirement
(3) brought up during WGLC.  Per yesterday's meeting I think that
means we can forward the document on to the IESG.

allman

---

From: Martin Duke <[email-masked]>
Date: Fri, 1 May 2020 14:52:18 -0700

Great! I'll start my AD review while Yoshi starts his shepherd writeup.

Thanks Mark!

On Fri, May 1, 2020 at 10:56 AM Mark Allman <[email-masked]>
wrote:

> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm
>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 5 May 2020 15:52:08 +0000

Hi Mark, hi all,

sorry of being super later here but I finally found some time to fully read the document again. Thanks for rewriting it with a focus on loss detection. I think this works really well and I'm happy to see this document moving forward now.

Given I've read it now, I also do have two smallish comments:

The first one is rather editorial. You say first sentence in sec 2:
" This document is different from other standards documents in that it
    is backwards from the way we generally like to engineer systems."
I would think that this is rather normal for BCPs... I guess you could just cut this sentence in a future version but no worries...

The second comment/question is potentially more technical, regarding this in sec 4:
" In steady state the RTO SHOULD be set based on observations
            of both the FT and the variance of the FT."
I guess you could be more explicitly that the RTO should be not smaller than the FT+variation. Or is that not the intended guidance? Further, what does steady state actually really mean and what's the guidance for non-steady state?

Mirja

    
    
    allman