Subject: Re: [tcpm] WGLC for draft-ietf-tcpm-2140bis

From: Mirja Kuehlewind <[email-masked]>
Date: Fri, 19 Jun 2020 18:31:57 +0000

Hi Michael, hi all,

sorry for being late here but times are busy... so thanks for the extension.

Thanks to the authors for all the work on this bis doc. I only managed to have a brief review of the draft but I think it an interesting read with a lot of good updates. I think the document is basically ready for publication, however, I have two comments/questions. tThe first one is more a suggestion but the second point is something I think we should be should we have support for in the group before we move ahead.

1) The security section could maybe also discuss if there are any implications for likability when caching any of these information and how to handle that. Looking at the diff, there was a section in the security consideration about information sharing of application-specific settings. So why was that removed? However, I think the document could even say more!

2) I was quite surprised to see appendix C and that it is a FULL copy of draft-touch-tcpm-automatic-iw-03. I'm okay to discuss more considerations on the IW e.g. on the design principle level and most importantly maybe that a loss within the IW can/should impacting the cached value, and to do so even in the body of the doc, however, if I remember correctly there was a lot of discussion about the automated setting of IW in tcpm when the IW10 RFC was under discussion and no agreement reached in the group, so would rather just like to see a reference to the expired draft than copy and pasting the whole algorithm in the appendix of this draft.

Mirja
 
P.S.: I will be on holidays the next two weeks and therefore probably not reply before I'm back.

On 12.06.20, 11:57, "tcpm on behalf of Scharf, Michael" <[email-masked] on behalf of [email-masked]> wrote:

    Hi all,

    I haven't seen any reply so far. Lack of _any_ feedback is not a particularly good sign.

    Anyway, no feedback implies that the document is ready to move forward. However, even in that case explicit support for publication  would be _really_ useful. A simple "+1" could be enough...

    I'll extend the WGLC by one week until June 21 to give the community some additional time to comment.

    Thanks

    Michael

    > -----Original Message-----
    > From: Scharf, Michael <[email-masked]>
    > Sent: Saturday, May 30, 2020 8:06 PM
    > To: [email-masked]
    > Cc: tcpm-chairs <[email-masked]>
    > Subject: WGLC for draft-ietf-tcpm-2140bis
    > 
    > Hi all,
    > 
    > The document "TCP Control Block Interdependence" (draft-ietf-tcpm-
    > 2140bis) is out there for a quite some time already. Given that there has
    > been a bit less activity on the list after the interim, let's use this opportunity
    > to finish one of our milestones...
    > 
    > This e-mail starts a WGLG for the document draft-ietf-tcpm-2140bis. The
    > WGLC will run until ***June 14***.
    > 
    > The intended status is an informational RFC. The current version of the
    > document can be found at:
    > 
    > https://tools.ietf.org/html/draft-ietf-tcpm-2140bis-05
    > 
    > Please review the latest version and please let us know any comments or
    > suggestions. TCPM needs reviews to ensure that the content is ready to
    > move forward. Feedback supporting publication ("+1") is also very welcome.
    > 
    > Thanks
    > 
    > Michael, on behalf of the TCPM chairs

    _______________________________________________
    tcpm mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/tcpm

---

From: Joseph Touch <[email-masked]>
Date: Fri, 19 Jun 2020 11:40:15 -0700

Hi, Mirja,

> On Jun 19, 2020, at 11:31 AM, Mirja Kuehlewind <mirja.kuehlewind=[email-masked]> wrote:
> 
> Hi Michael, hi all,
> 

The discussion was only whether there were specific settings that had been implemented. If we cite an expired draft, we need to basically add some info to explain what’s in the other doc (which we are supposed to treat as non-existent). I.e., if we’re citing an old draft for credit, it’s just a citation, but in this case we’re saying that the techniques in that draft *are* just a variant of what 2140 already suggests, only on a different timescale.

I.e., “discussing more considerations” is basically what that text already does. All the issues that are in the original doc were relevant for this one’s discussion on that issue.

Joe