Subject: Re: [tcpm] Test vectors for RFC5925 algorithms?

From: Joseph Touch <[email-masked]>
Date: Sun, 7 Jun 2020 13:52:15 -0700

Hi, Michael,

The link below doesn’t appear to reference TCP-AO. Do you know of a link with a more direct reference?

Joe

> On Apr 16, 2020, at 9:31 AM, Scharf, Michael <[email-masked]> wrote:
> 
>>> Have you checked other router vendors? For instance, the public Cisco IOS XE
>> documentation lists TCP-AO support. And I have also heard that another main
>> router vendor may implement TCP-AO (well, I am not familiar with Juniper).
>> 
>> I am aware that Cisco has an implementation. It is quite new, and
>> unfortunately I do have experience of it. If someone has, then that
>> may well be a very good candidate for test vectors.
> 
> Coming back to this, as I have just found another document: According to reference [1], Nokia SROS implements TCP-AO as well.
> 
> Michael
> 
> 
> [1] Nokia SROS documentation at https://documentation.nokia.com/cgi-bin/dbaccessfilename.cgi/3HE15811AAAATQZZA01_V1_7450%20ESS%207750%20SR%207950%20XRS%20and%20VSR%20Basic%20System%20Configuration%20Guide%2020.2.R1.pdf <https://documentation.nokia.com/cgi-bin/dbaccessfilename.cgi/3HE15811AAAATQZZA01_V1_7450%20ESS%207750%20SR%207950%20XRS%20and%20VSR%20Basic%20System%20Configuration%20Guide%2020.2.R1.pdf>

---

From: "Scharf, Michael" <[email-masked]>
Date: Mon, 8 Jun 2020 07:21:34 +0000

Hi Joe,

Page 700 of link [1] references RFC 5925 and RFC 5926.

I don’t have access to a Nokia router to actually test the implementation. Yet, as far as I know, listing an RFC in the standard compliance lists of a Nokia product implies that the standard is indeed implemented.

Michael

From: Joseph Touch <[email-masked]>
Sent: Sunday, June 7, 2020 10:52 PM
To: Scharf, Michael <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [tcpm] Test vectors for RFC5925 algorithms?

Hi, Michael,

Joe

On Apr 16, 2020, at 9:31 AM, Scharf, Michael <[email-masked]<mailto:[email-masked]>> wrote:

Michael

[1] Nokia SROS documentation at https://documentation.nokia.com/cgi-bin/dbaccessfilename.cgi/3HE15811AAAATQZZA01_V1_7450%20ESS%207750%20SR%207950%20XRS%20and%20VSR%20Basic%20System%20Configuration%20Guide%2020.2.R1.pdf

---

From: Joseph Touch <[email-masked]>
Date: Thu, 11 Jun 2020 09:42:58 -0700

Thanks. At this time, I haven’t included this sort of product reference to the draft, but it is useful to know.

Joe

> On Jun 8, 2020, at 12:21 AM, Scharf, Michael <[email-masked]> wrote:
> 
> Hi Joe,
>  
> From: Joseph Touch <[email-masked] <mailto:[email-masked]>> 
> To: Scharf, Michael <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> On Apr 16, 2020, at 9:31 AM, Scharf, Michael <[email-masked] <mailto:[email-masked]>> wrote:
>