Subject: Re: [tcpm] [EXTERNAL] Re: On Sender Control of Delayed Acks in TCP

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Thu, 18 Jun 2020 10:29:00 +0200

Hi Joe,

First of all, sorry for the late reply.

Please find below my inline response.

>> On May 13, 2020, at 5:00 AM, Carles Gomez Montenegro
>> <[email-masked]> wrote:
>>
>> In this thread, several WG participants expressed a positive opinion
>> about
>> defining a new TCP option. (Although, as you mentioned, this approach
>> also
>> has drawbacks.)
>
> Why not start as defining an Experimental Option (with a corresponding
> code point)?
>
> Joe

Thanks for your suggestion.

(I understand that you mean an Experimental-category specification
defining a TCP Option using a dedicated kind number different from 253 or
254.)

Yes, this sounds as a very good approach!

Cheers,

Carles

---

From: Joseph Touch <[email-masked]>
Date: Thu, 18 Jun 2020 07:26:53 -0700

Carles,

> On Jun 18, 2020, at 1:29 AM, Carles Gomez Montenegro <[email-masked]> wrote:
> 

That’s definitely NOT what I meant.

Please review RFC 6994. There should NEVER be a need to assign new TCP Option kind codepoints to experiments.

To be explicit, I mean to follow 6994 and request an Experimental code point that can be used together with TCP Option kinds of 253 and/or 254.

Joe

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Thu, 18 Jun 2020 18:07:51 +0200

Hi Joe,

> That's definitely NOT what I meant.
>
> To be explicit, I mean to follow 6994 and request an Experimental code
> point that can be used together with TCP Option kinds of 253 and/or 254.

Oops, I see!

(I see that it was right to include what I understood above...)

Thank you very much for the clarification.

Cheers,

Carles