Subject: [tcpm] Presentation slot requests for IETF 108 (online)

From: "Scharf, Michael" <[email-masked]>
Date: Thu, 2 Jul 2020 07:15:17 +0000

Hi all,

Given that we had a pretty packed agenda during the virtual interim meeting, the chairs have asked for two slots during IETF 108. This basically implies that we have again the 2:30 hour slot that TCPM used to have for many years.

According to the draft agenda for IETF 108, TCPM has been scheduled for Monday Session I (1:40) and Monday Session II (0:50).

If you are interested in presenting, please let the chairs know until **Monday 2020-07-13**:

* Draft name / presentation title
* Presenter
* Total duration (including Q&A)

Thanks

Michael (2x) and Yoshi

---

From: <[email-masked]>
Date: Thu, 2 Jul 2020 07:54:31 +0000

Dear Michaels, Yoshi

Since MPTCP WG is closed and TCPM takes care, Jiao and I would like to present implementation updates (probably also a new draft version -02) for

* draft-amend-mptcp-robe / "Multipath TCP Robust Session Establishment"
* Jiao Kang / Markus Amend
* 20min

Just in case we are not able to update the recent -01 to a -02, is it still required to move the -01 to TCPM before #108?

Br

Markus

-----Original Message-----
From: tcpm <[email-masked]> On Behalf Of Scharf, Michael
Sent: Donnerstag, 2. Juli 2020 09:15
To: [email-masked]
Cc: tcpm-chairs <[email-masked]>
Subject: [tcpm] Presentation slot requests for IETF 108 (online)

Hi all,

Thanks

Michael (2x) and Yoshi

_______________________________________________
tcpm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tcpm

---

From: "Scharf, Michael" <[email-masked]>
Date: Thu, 2 Jul 2020 14:33:44 +0000

Markus,

Thanks for the request.

It may make sense to resubmit the I-D as -tcpm- if it shall be presented in TCPM. Then it shows up in datatracker in the right context.

Michael

> From: [email-masked] <[email-masked]>
> Sent: Thursday, July 2, 2020 9:55 AM
> To: Scharf, Michael <[email-masked]>; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: Presentation slot requests for IETF 108 (online)
> 
> Dear Michaels, Yoshi
> 
> Since MPTCP WG is closed and TCPM takes care, Jiao and I would like to
> present implementation updates (probably also a new draft version -02) for
> 
> Just in case we are not able to update the recent -01 to a -02, is it still
> required to move the -01 to TCPM before #108?
> 
> Br
> 
> Markus
> 
> Given that we had a pretty packed agenda during the virtual interim meeting,
> the chairs have asked for two slots during IETF 108. This basically implies that
> we have again the 2:30 hour slot that TCPM used to have for many years.
> 
> According to the draft agenda for IETF 108, TCPM has been scheduled for
> Monday Session I (1:40) and Monday Session II (0:50).
>

---

From: "Rodney W. Grimes" <[email-masked]>
Date: Thu, 2 Jul 2020 11:20:32 -0700 (PDT)

Michael,
	Shouldnt the datatracker entry in its entierity be moved
to tcpm since tcpm is now taking on the work of the closed mptcp wg?
That way history of the document is preserved and can be easier
to research.

	I am not sure this is even possible, but loosing the
provadence of a document because it moved WG's seems problematic.

Regards,
Rod

-- 
Rod Grimes                                                 [email-masked]

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 2 Jul 2020 15:25:22 -0400

Rodney

When the newer document is uploaded with the -tcpm- name, one can use the
"Replaces" button in the Datatracker to create the breadcrumbs.

For a current example in DNSOP, see:

https://datatracker.ietf.org/doc/draft-ietf-dnsop-svcb-https/

tim

On Thu, Jul 2, 2020 at 2:21 PM Rodney W. Grimes <[email-masked]>
wrote:

> > It may make sense to resubmit the I-D as -tcpm- if it shall be presented
> in TCPM. Then it shows up in datatracker in the right context.
> >
> > Michael
> >

---

From: "Scharf, Michael" <[email-masked]>
Date: Fri, 3 Jul 2020 07:36:15 +0000

Rod,

Tim Wicinski has already mentioned that "update" metadata can be used to keep record of the history.

Also, I believe it is quite common in the IETF to rename I-Ds if they move between WGs. For individual submissions, this is probably not formally required, though.

The advantage of -tcpm- is that it is then more apparent on which list the discussion shall take place. Not all readers of I-Ds are familiar with all IETF internals.

Michael

> From: Rodney W. Grimes <[email-masked]>
> Sent: Thursday, July 2, 2020 8:21 PM
> To: Scharf, Michael <[email-masked]>
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [tcpm] Presentation slot requests for IETF 108 (online)
> 
> Michael,
> > It may make sense to resubmit the I-D as -tcpm- if it shall be presented in
> TCPM. Then it shows up in datatracker in the right context.
> >
> > Michael
> >

---

From: tom petch <[email-masked]>
Date: Fri, 3 Jul 2020 09:19:17 +0000

From: tcpm <[email-masked]> on behalf of Scharf, Michael <[email-masked]>
Sent: 03 July 2020 08:36

Rod,

<tp>
which is why it is a bad idea to rename I-D IMHO when the WG changes since it then requires a datatracker wonk to know where to go in the maze of IETF related pages to find what it was in a previous life, something WG Chairs do all the time but mere mortals may not.  When OSPF became LSR, the I-D were NOT renamed and very sensible it was too:-)
The only time a change of identifier is sensible is when an individual draft is adopted which happens to be another aspect of IETF internals that most outside the IETF will not be familiar with!.
Tom Petch
Michael

---

From: "Scharf, Michael" <[email-masked]>
Date: Fri, 3 Jul 2020 09:54:07 +0000

> Also, I believe it is quite common in the IETF to rename I-Ds if they move
> between WGs. For individual submissions, this is probably not formally
> required, though.
> 
> The advantage of -tcpm- is that it is then more apparent on which list the
> discussion shall take place. Not all readers of I-Ds are familiar with all IETF
> internals.
> 
> <tp>
> which is why it is a bad idea to rename I-D IMHO when the WG changes since
> it then requires a datatracker wonk to know where to go in the maze of IETF
> related pages to find what it was in a previous life, something WG Chairs do
> all the time but mere mortals may not.  When OSPF became LSR, the I-D
> were NOT renamed and very sensible it was too:-)

Well, mere mortals may also not care much about the history of the document, diffs between versions, and the like. As soon as they do, they sooner or later run into datatracker, IMHO.

Thus, with chair hat off, I disagree that using the name of a changed WG is _always_ a "bad idea". But, well, my original statement was "it may make sense". And this includes the word MAY...

> The only time a change of identifier is sensible is when an individual draft is
> adopted which happens to be another aspect of IETF internals that most
> outside the IETF will not be familiar with!.

To me, there are tradeoffs and there is no such one-fits-all rule. But the last observation is probably correct. So, I really wonder if we discuss a relevant question here.

And, well, the specific I-D discussed here is an (expired) -01 version of a document that already has an "replaces" entry to an entirely different draft name... I may miss something, but for this specific example I don't understand why renaming would be a real-world issue.

Michael

---

From: Mahesh Jethanandani <[email-masked]>
Date: Sat, 4 Jul 2020 15:42:31 -0700

Hi Michael,

See the request embedded within the e-mail.

> On Jul 2, 2020, at 12:15 AM, Scharf, Michael <[email-masked]> wrote:
> 
> Hi all,
> 
> * Draft name / presentation title - draft-scharf-tcpm-yang-tcp/YANG Model for Transmission Control Protocol (TCP) Configuration.
> * Presenter: TBD
> * Total duration (including Q&A): 10 min.
> 
> Thanks
> 
> Michael (2x) and Yoshi
> 

Thanks.

Mahesh Jethanandani
[email-masked]

---

From: "Scharf, Michael" <[email-masked]>
Date: Tue, 7 Jul 2020 07:45:56 +0000

Hi Mahesh,

Thanks. My co-chairs will decide on that slot request, as I am an author of the I-D.

But as we have a pretty long slot this time, I expect that we have enough time for all presentation requests.

I would probably plan rather with a 15min slot - under the assumption what a discussion on the next steps (such as WG adoption in TCPM) is needed.

Michael

From: Mahesh Jethanandani <[email-masked]>
Sent: Sunday, July 5, 2020 12:43 AM
To: Scharf, Michael <[email-masked]>
Cc: [email-masked]; tcpm-chairs <[email-masked]>
Subject: Re: [tcpm] Presentation slot requests for IETF 108 (online)

Hi Michael,

On Jul 2, 2020, at 12:15 AM, Scharf, Michael <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Thanks

Michael (2x) and Yoshi

_______________________________________________
tcpm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tcpm

Thanks.

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Mon, 13 Jul 2020 09:22:33 +0200

Dear chairs,

We would like to request a presentation slot for IETF 108.

Please find next the details of the request:

* Draft name / presentation title:  draft-gomez-tcpm-ack-rate-request-00
* Presenter:                        Carles Gomez
* Total duration (including Q&A):   10 minutes

Thanks,

Carles

> Hi all,
>
> Given that we had a pretty packed agenda during the virtual interim
> meeting, the chairs have asked for two slots during IETF 108. This
> basically implies that we have again the 2:30 hour slot that TCPM used to
> have for many years.
>

---

From: Juhamatti Kuusisaari <[email-masked]>
Date: Wed, 22 Jul 2020 12:03:38 +0300

Dear chairs,

* Draft name / presentation title: draft-touch-tcpm-ao-test-vectors-00
* Presenter:                        Juhamatti Kuusisaari
* Total duration (including Q&A):   15 minutes

Thanks,

Juhamatti

---

From: "Scharf, Michael" <[email-masked]>
Date: Wed, 22 Jul 2020 22:21:19 +0000

Hi Juhamatti,

This is a late request.

But as we may have some time left, I’ll put you talk at the end of the agenda (“if time permits”).

Michael

From: Juhamatti Kuusisaari <[email-masked]>
Sent: Wednesday, July 22, 2020 11:04 AM
To: [email-masked]
Cc: Joseph Touch <[email-masked]>; tcpm IETF list <[email-masked]>
Subject: [tcpm] Presentation slot requests for IETF 108 (online)

Dear chairs,

Thanks,

Juhamatti

---

From: Joseph Touch <[email-masked]>
Date: Wed, 22 Jul 2020 21:44:15 -0700

FWIW - this is largely my fault; I didn’t realize the timelines and I’ve been helping lead this effort through the IETF process. 

Even a brief slot would be appreciated and useful. It’s quite simple as docs go.

Joe

> On Jul 22, 2020, at 3:21 PM, Scharf, Michael <[email-masked]> wrote:
> 
> Hi Juhamatti,
>  
> This is a late request.
>  
> From: Juhamatti Kuusisaari <[email-masked] <mailto:[email-masked]>> 
> To: [email-masked] <mailto:[email-masked]>
> Cc: Joseph Touch <[email-masked] <mailto:[email-masked]>>; tcpm IETF list <[email-masked] <mailto:[email-masked]>>
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/tcpm <https://www.ietf.org/mailman/listinfo/tcpm>