Subject: [tcpm] [Technical Errata Reported] RFC7413 (6239)

From: RFC Errata System <[email-masked]>
Date: Sun, 26 Jul 2020 19:27:31 -0700 (PDT)

The following errata report has been submitted for RFC7413,
"TCP Fast Open".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6239

--------------------------------------
Type: Technical
Reported by: Simon khng ren hao <[email-masked]>

Section: 5.2

Original Text
-------------
produces responses earlier before the handshake completes

Corrected Text
--------------
produces responses after the handshake completes

Notes
-----
Located on last paragraph last line of section on page 16. First line states 'not to respond with data until the handshake finishes' which contradicts the last line.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7413 (draft-ietf-tcpm-fastopen-10)
--------------------------------------
Title               : TCP Fast Open
Publication Date    : December 2014
Author(s)           : Y. Cheng, J. Chu, S. Radhakrishnan, A. Jain
Category            : EXPERIMENTAL
Source              : TCP Maintenance and Minor Extensions
Area                : Transport
Stream              : IETF
Verifying Party     : IESG

---

From: Yuchung Cheng <[email-masked]>
Date: Mon, 27 Jul 2020 13:00:00 -0700

> The following errata report has been submitted for RFC7413,

I don't think the errata is valid. what the text meant to say is "if
the server produces data (ready to sent) before the handshake
completes, then  the server not to send the data until the handshake
finishes is at a disadvantage.". the text is to discuss pros & cons of
a design decision, not describing the protocol itself.