Subject: [tcpm] WG item adoption for draft-scharf-tcpm-yang-tcp-06

From: Yoshifumi Nishida <[email-masked]>
Date: Mon, 3 Aug 2020 01:04:32 -0700

Hi,

The chairs has been discussing how to proceed draft-scharf-tcpm-yang-tcp-06
after the WG meeting.
The results of the hum were a bit weak to see clear consensus although
there was slightly strong hum for adoption.
Also, there seems to be some confusions during the adoption call. (I'm
sorry for the clumsiness of using the tool)
In order for this, we would like to seek the additional feedback from the
community on the following points.

1: If you want to add your hum to the call because you didn't at the
meeting for some reasons or if you want to change your hum, please let the
chairs know.
2: if you hummed for not adopting the draft, please share your opinion.
This will be a very helpful input for us.

We'll appreciate your cooperation.
Thanks,
--
Yoshi

---

From: Yoshifumi Nishida <[email-masked]>
Date: Mon, 17 Aug 2020 10:03:46 -0700

Hi folks,
We appreciate your feedback on this.
--
tcpm co-chairs

On Mon, Aug 3, 2020 at 1:04 AM Yoshifumi Nishida <[email-masked]> wrote:

> Hi,
>
> The chairs has been discussing how to proceed
> draft-scharf-tcpm-yang-tcp-06 after the WG meeting.

---

From: Lars Eggert <[email-masked]>
Date: Tue, 18 Aug 2020 11:32:05 +0300

Hi,

On 2020-8-3, at 11:04, Yoshifumi Nishida <[email-masked]> wrote:
> 2: if you hummed for not adopting the draft, please share your opinion. This will be a very helpful input for us.

I shared my opinion on this in the past, and it hasn't changed.

Lars

---

From: "Scharf, Michael" <[email-masked]>
Date: Wed, 19 Aug 2020 22:20:59 +0000

Hi Lars,

> -----Original Message-----
> From: tcpm <[email-masked]> On Behalf Of Lars Eggert
> Sent: Tuesday, August 18, 2020 10:32 AM
> To: Yoshifumi Nishida <[email-masked]>
> Cc: [email-masked] Extensions <[email-masked]>
> Subject: Re: [tcpm] WG item adoption for draft-scharf-tcpm-yang-tcp-06
> 
> Hi,
> 

... but the document has changed significantly since the past discussions, amongst others to address your pushback.

Can you be a bit more specific regarding your concerns, specifically considering draft-scharf-tcpm-yang-tcp-06?

The latest version -06 is quite short and has a narrow scope to address the most obvious use cases for a TCP YANG model, most notably TCP-AO in IDR. Other than that, -06 basically just documents how the information in the TCP MIB can be modeled in YANG. The TCP MIB is used by several TCP implementations as basis for basic stats (as discussed previously). And I guess it is IETF consensus that YANG is a better alternative for data models. As usual, a document proposed for WG adoption is not final, but the authors believe that the model in draft-scharf-tcpm-yang-tcp-06 is already in a decent shape.

As a result, it is a bit difficult to understand why such a narrow-scoped document should not be doable with reasonable effort in TCPM.

Michael (as author)

---

From: <[email-masked]>
Date: Thu, 27 Aug 2020 08:16:51 +0000

Hi all,

This is a useful document. I support it.

Michael, please update the tree diagram to list all the data nodes. Thanks.

Cheers,
Med

De : tcpm [mailto:[email-masked]] De la part de Yoshifumi Nishida
Envoyé : lundi 17 août 2020 19:04
À : [email-masked] Extensions <[email-masked]>
Objet : Re: [tcpm] WG item adoption for draft-scharf-tcpm-yang-tcp-06

Hi folks,

On Mon, Aug 3, 2020 at 1:04 AM Yoshifumi Nishida <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

The chairs has been discussing how to proceed draft-scharf-tcpm-yang-tcp-06 after the WG meeting.
The results of the hum were a bit weak to see clear consensus although there was slightly strong hum for adoption.
Also, there seems to be some confusions during the adoption call. (I'm sorry for the clumsiness of using the tool)
In order for this, we would like to seek the additional feedback from the community on the following points.

1: If you want to add your hum to the call because you didn't at the meeting for some reasons or if you want to change your hum, please let the chairs know.
2: if you hummed for not adopting the draft, please share your opinion. This will be a very helpful input for us.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Yoshifumi Nishida <[email-masked]>
Date: Thu, 27 Aug 2020 23:41:38 -0700

Hi Med,

Thank you for the input.
We'll wait a bit more and will make a decision.
--
Yoshi

On Thu, Aug 27, 2020 at 1:16 AM <[email-masked]> wrote:

> *De :* tcpm [mailto:[email-masked]] *De la part de* Yoshifumi
> Nishida
> *Envoyé :* lundi 17 août 2020 19:04
> *À :* [email-masked] Extensions <[email-masked]>
> *Objet :* Re: [tcpm] WG item adoption for draft-scharf-tcpm-yang-tcp-06
>
>
>
> Hi folks,
>