Subject: [tcpm] WGLC for 793bis - REVIEW NEEDED

From: "Scharf, Michael" <[email-masked]>
Date: Fri, 18 Sep 2020 12:11:30 +0000

Dear TCPM contributors,

This e-mail starts a working group last call for draft-ietf-tcpm-rfc793bis-18. Information about the document can be found at this link:

https://datatracker.ietf.org/doc/draft-ietf-tcpm-rfc793bis/

For instance, the current version can be found at https://datatracker.ietf.org/doc/html/draft-ietf-tcpm-rfc793bis-18.

When adopting draft-ietf-tcpm-rfc793bis, the TCPM working group consensus was to limit the scope of 793bis to TCP changes that are specified either in standards-track RFCs or in verified errata. Also, the consensus was to focus on the base protocol and exclude mechanisms that can be specified separately (e.g., congestion control). As a result, 793bis should in principle not contain anything new. Nonetheless, we all know that TCP is a complex protocol and even small details of the specification matter a lot.

Given that 793bis will obsolete RFC 793, which is one of the most important Internet Standards, this WGLC will run for *four weeks*, i.e., until October 16.

Therefore, *your* help is needed: PLEASE review 793bis in the next weeks! The earlier, the better...

- Any comments or suggestions are important and highly appreciated. Even if you don't speak up often on the TCPM mailing list, please let us know if you have any feedback.

- Even if you read the document without finding any errors or issue, please let us know ("+1").

- It is also perfectly fine to look only at a subset of the document, e.g., if you are familiar with specific details of TCP. Partial reviews are welcome, too.

- If you own TCP running code, you definitively should have a very close look; this document is supposed to be the new base specification of TCP.

RFC 793 lays the ground for all work in TCPM, and 793bis is probably one of the most important deliverables of TCPM. Please help us with completing this milestone.

Thanks!

Michael Scharf
Yoshifumi Nishida
Michael Tuexen 
(TCPM chairs)

---

From: <[email-masked]>
Date: Fri, 25 Sep 2020 13:52:15 +0000

Hi all, 

Wes already addressed my comments in previous versions of the spec.

Please find some edits/nits/comments:

* pdf: https://github.com/boucadair/IETF-Drafts-Reviews/blob/master/draft-ietf-tcpm-rfc793bis-18-rev%20Med.pdf 
* doc: https://github.com/boucadair/IETF-Drafts-Reviews/raw/master/draft-ietf-tcpm-rfc793bis-18-rev%20Med.docx 

The document is almost ready to move forward.

Many thanks to Wes for carrying this important work. 

Cheers,
Med

> -----Message d'origine-----
> De : tcpm [mailto:[email-masked]] De la part de Scharf,
> Michael
> Envoyé : vendredi 18 septembre 2020 14:12
> À : [email-masked] Extensions <[email-masked]>
> Objet : [tcpm] WGLC for 793bis - REVIEW NEEDED
> 
> Dear TCPM contributors,
> 
> This e-mail starts a working group last call for draft-ietf-tcpm-
> rfc793bis-18. Information about the document can be found at this
> link:
> 
> For instance, the current version can be found at
> https://datatracker.ietf.org/doc/html/draft-ietf-tcpm-rfc793bis-18.
> 
> When adopting draft-ietf-tcpm-rfc793bis, the TCPM working group
> consensus was to limit the scope of 793bis to TCP changes that are
> specified either in standards-track RFCs or in verified errata.
> Also, the consensus was to focus on the base protocol and exclude
> mechanisms that can be specified separately (e.g., congestion
> control). As a result, 793bis should in principle not contain
> anything new. Nonetheless, we all know that TCP is a complex
> protocol and even small details of the specification matter a lot.
> 
> Given that 793bis will obsolete RFC 793, which is one of the most
> important Internet Standards, this WGLC will run for *four weeks*,
> i.e., until October 16.
> 
> - Any comments or suggestions are important and highly appreciated.
> Even if you don't speak up often on the TCPM mailing list, please
> let us know if you have any feedback.
> 
> - It is also perfectly fine to look only at a subset of the
> document, e.g., if you are familiar with specific details of TCP.
> Partial reviews are welcome, too.
> 
> - If you own TCP running code, you definitively should have a very
> close look; this document is supposed to be the new base
> specification of TCP.
> 
> RFC 793 lays the ground for all work in TCPM, and 793bis is probably
> one of the most important deliverables of TCPM. Please help us with
> completing this milestone.
> 
> Thanks!
> 
> Michael Scharf
> Yoshifumi Nishida
> Michael Tuexen
> (TCPM chairs)
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.