Subject: Re: [tcpm] I-D Action: draft-ietf-tcpm-2140bis-06.txt

From: Yoshifumi Nishida <[email-masked]>
Date: Sun, 13 Dec 2020 03:38:04 -0800

(chair hat off)
Hi,

I've read the updated version of the draft. But, I personally think the
appendix.C still looks a bit too long.
This appendix describes a proposal that can adjust initial cwnd over long
timescales, but I'm not very sure if it's worth using 7 pages because It
seems to me it doesn't look a very crucial part of the draft.
Also, I am not sure how many readers want to implement this or there are
some implementations that have already adopted it.

Thanks,
--
Yoshi

On Thu, Nov 26, 2020 at 6:13 AM Scharf, Michael <
[email-masked]> wrote:

> The appendix was the only remaining open issue I am aware of. If I there
> are no objections to -06, I will close the WGLC and prepare my shepherd
> write-up.
>
> Thanks!
>
> Michael
>
>
> > -----Original Message-----
> > From: tcpm <[email-masked]> On Behalf Of Michael Welzl
> > Sent: Thursday, November 26, 2020 1:48 PM
> > To: tcpm IETF list <[email-masked]>
> > Subject: Re: [tcpm] I-D Action: draft-ietf-tcpm-2140bis-06.txt
> >
> > Dear all,
> >
> > This is our update to address the WGLC comments, where concrete
> > suggestions were made regarding the appendix.
> >
> > Cheers,
> > Michael
> >
> >
> > > On 26 Nov 2020, at 00:04, [email-masked] wrote:
> > >
> > >
> > > A New Internet-Draft is available from the on-line Internet-Drafts
> > directories.
> > > This draft is a work item of the TCP Maintenance and Minor Extensions
> WG
> > of the IETF.
> > >
> > >        Title           : TCP Control Block Interdependence
> > >        Authors         : Joe Touch
> > >                          Michael Welzl
> > >                          Safiqul Islam
> > >     Filename        : draft-ietf-tcpm-2140bis-06.txt
> > >     Pages           : 34
> > >     Date            : 2020-11-25
> > >
> > > Abstract:
> > >   This memo provides guidance to TCP implementers that are intended to
> > >   help improve convergence to steady-state operation without affecting
> > >   interoperability. It updates and replaces RFC 2140's description of
> > >   interdependent TCP control blocks and the ways that part of TCP
> > >   state can be shared among similar concurrent or consecutive
> > >   connections. TCP state includes a combination of parameters, such as
> > >   connection state, current round-trip time estimates, congestion
> > >   control information, and process information. Most of this state is
> > >   maintained on a per-connection basis in the TCP Control Block (TCB),
> > >   but implementations can (and do) share certain TCB information
> > >   across connections to the same host. Such sharing is intended to
> > >   improve overall transient transport performance, while maintaining
> > >   backward-compatibility with existing implementations. The sharing
> > >   described herein is limited to only the TCB initialization and so
> > >   has no effect on the long-term behavior of TCP after a connection
> > >   has been established.
> > >
> > >
> > > The IETF datatracker status page for this draft is:
> > > https://datatracker.ietf.org/doc/draft-ietf-tcpm-2140bis/
> > >
> > > There are also htmlized versions available at:
> > > https://tools.ietf.org/html/draft-ietf-tcpm-2140bis-06
> > > https://datatracker.ietf.org/doc/html/draft-ietf-tcpm-2140bis-06
> > >
> > > A diff from the previous version is available at:
> > > https://www.ietf.org/rfcdiff?url2=draft-ietf-tcpm-2140bis-06
> > >
> > >
> > > Please note that it may take a couple of minutes from the time of
> > submission
> > > until the htmlized version and diff are available at tools.ietf.org.
> > >
> > > Internet-Drafts are also available by anonymous FTP at:
> > > ftp://ftp.ietf.org/internet-drafts/
> > >
> > >
> > > _______________________________________________
> > > tcpm mailing list
> > > [email-masked]
> > > https://www.ietf.org/mailman/listinfo/tcpm
> >
> > _______________________________________________
> > tcpm mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/tcpm
>
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm
>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 14 Dec 2020 10:56:19 +0000

I’m also still concerned about the appendix. I think a link to the expired draft and some summary discussion would be sufficient rather than copying the whole expired draft in the appendix that never reached any consensus in the group.

From: tcpm <[email-masked]> on behalf of Yoshifumi Nishida <[email-masked]>
Date: Sunday, 13. December 2020 at 12:38
To: "Scharf, Michael" <[email-masked]>
Cc: tcpm IETF list <[email-masked]>
Subject: Re: [tcpm] I-D Action: draft-ietf-tcpm-2140bis-06.txt

(chair hat off)
Hi,

I've read the updated version of the draft. But, I personally think the appendix.C still looks a bit too long.
This appendix describes a proposal that can adjust initial cwnd over long timescales, but I'm not very sure if it's worth using 7 pages because It seems to me it doesn't look a very crucial part of the draft.
Also, I am not sure how many readers want to implement this or there are some implementations that have already adopted it.

Thanks,
--
Yoshi

On Thu, Nov 26, 2020 at 6:13 AM Scharf, Michael <[email-masked]<mailto:[email-masked]>> wrote:
The appendix was the only remaining open issue I am aware of. If I there are no objections to -06, I will close the WGLC and prepare my shepherd write-up.

Thanks!

Michael

> From: tcpm <[email-masked]<mailto:[email-masked]>> On Behalf Of Michael Welzl
> To: tcpm IETF list <[email-masked]<mailto:[email-masked]>>
> > On 26 Nov 2020, at 00:04, [email-masked]<mailto:[email-masked]> wrote:
> >
> >
> > This draft is a work item of the TCP Maintenance and Minor Extensions WG
> of the IETF.
> >
> > until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.
> >
> > [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
tcpm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tcpm

---

From: Joseph Touch <[email-masked]>
Date: Mon, 14 Dec 2020 19:43:12 -0800

> This appendix describes a proposal that can adjust initial cwnd over long timescales, but I'm not very sure if it's worth using 7 pages because It seems to me it doesn't look a very crucial part of…

It’s tracked for informational. I agree with your assessment, but only because there are no “crucial” portions to ANY informational document.

> Also, I am not sure how many readers want to implement this or there are some implementations that have already adopted it.

That argument held when 2140 was originally published 23 years ago, but aspects of it were implemented many years later. This update anticipates the same possibility and timeline.

The appendix takes *only* 7 pages to explain the details of how to adapt the methods in the rest of the paper to long timescales, which could replace the need to repeatedly update the IW, which took 12 pages the first time, 15 pages the second time, and 18 pages the third time. I.e., that’s 7 pages in this doc vs. 45 pages to date in other docs. That should be considered a bargain.

If you look at those 7 pages, it provides pseudocode, mechanisms that have since become BCP for ECN, and recommendations on configurations of defaults. It would be useful if you could point to a specific section of that appendix that you think could be compressed or removed.

Joe

---

From: Joseph Touch <[email-masked]>
Date: Mon, 14 Dec 2020 19:51:46 -0800

To the WG:

> On Dec 14, 2020, at 2:56 AM, Mirja Kuehlewind <mirja.kuehlewind=[email-masked]> wrote:
> 

We have addressed these comments before and disagree with them.

The material was available to the WG for several months and has received no objections except Mirja's during WGLC and Youshifumi’s now many months after WGLC.

The content of expired I-Ds can be removed from public view at any time, per:
https://ietf.org/about/groups/iesg/statements/internet-draft-removal/ <https://ietf.org/about/groups/iesg/statements/internet-draft-removal/>

Finally, see the *explicit* instructions in the required boilerplate of every I-D:

	...It is inappropriate to use Internet-Drafts as
   reference material ...

I will let my co-authors address how to proceed.

Joe

---

From: Michael Welzl <[email-masked]>
Date: Tue, 15 Dec 2020 09:15:16 +0100

Hi,

> On Dec 15, 2020, at 4:51 AM, Joseph Touch <[email-masked]> wrote:
> 
> To the WG:
> 
>> On Dec 14, 2020, at 2:56 AM, Mirja Kuehlewind <mirja.kuehlewind=[email-masked] <mailto:mirja.kuehlewind=[email-masked]>> wrote:
>> 
> We have addressed these comments before

Indeed: this comment appears to refer to an earlier version of the draft.

> and disagree with them.

You made our position clear; the next steps are at the discretion of the chairs at this point.

Cheers,
Michael