Subject: [tcpm] 793bis: default R2 value for SYNs

From: Wesley Eddy <[email-masked]>
Date: Wed, 9 Dec 2020 22:38:49 -0500

In review comments, it's been suggested that the requirement is too 
high, saying the number of retries on SYNs needs to allow 
retransmissions for at least 3 minutes.

For reference, the text in question is:

    However, the values of R1 and R2 may be different for SYN and data
    segments.  In particular, R2 for a SYN segment MUST be set large
    enough to provide retransmission of the segment for at least 3
    minutes (MUST-23).  The application can close the connection (i.e.,
    give up on the open attempt) sooner, of course.

I would prefer not to change this in 793bis, but to leave it as a topic 
for the WG to look at separately, since I imagine it could be something 
that takes more discussion, leverages measurements, application surveys, 
etc.

So, my plan is to leave this alone unless there's a strong feeling that 
this should be changed now, and that the WG agrees on how to change it / 
what it should be changed to.

Any thoughts on this are welcome.

---

From: Joseph Touch <[email-masked]>
Date: Thu, 10 Dec 2020 08:02:36 -0800

No.

Please see my other message about these sort of changes. 

I like the idea of “if anyone thinks this needs to be changed, we can have the WG look at it separately”.

But unless we’re holding up this update for that work to *conclude*, this update isn’t a vehicle to open new change topics.

Joe

> On Dec 9, 2020, at 7:38 PM, Wesley Eddy <[email-masked]> wrote:
> 
> In review comments, it's been suggested that the requirement is too high, saying the number of retries on SYNs needs to allow retransmissions for at least 3 minutes.
> 
> I would prefer not to change this in 793bis, but to leave it as a topic for the WG to look at separately, since I imagine it could be something that takes more discussion, leverages measurements, application surveys, etc.
> 
> So, my plan is to leave this alone unless there's a strong feeling that this should be changed now, and that the WG agrees on how to change it / what it should be changed to.
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm