Subject: [tcpm] IPR check for draft-ietf-tcpm-rfc793bis-22

From: "Scharf, Michael" <[email-masked]>
Date: Mon, 17 May 2021 16:37:45 +0000

Wes, all,

In preparation of the shepherd write-up, the formal IPR check is required. Given the importance of 793bis, I run the IPR check on the TCPM mailing list.

@Wes as editor: Please confirm that any and all appropriate IPR disclosures required for full conformance with the provisions of BCP 78 and BCP 79 have already been filed.

Section 7 in draft-ietf-tcpm-rfc793bis-22 acknowledges work from at least 40 contributors to the TCPM working group. Given that 793bis is not intended to change the TCP protocol as compared to existing standards, I don't believe that IPR conformations are required from everybody who ever contributed text to 793bis. I assume that each TCPM contributor knows the IETF Note Well very well.

Thanks

Michael

---

From: Wesley Eddy <[email-masked]>
Date: Wed, 19 May 2021 09:19:22 -0400

> @Wes as editor: Please confirm that any and all appropriate IPR disclosures required for full conformance with the provisions of BCP 78 and BCP 79 have already been filed.

Other than one case below, I'm not aware of any IPR.

There is an IPR disclosure in the datatracker on RFC 5961, which is one 
source of changes included in 793bis:

https://datatracker.ietf.org/ipr/421/

In all places in 793bis where the recommendations from 5961 are 
mentioned, 5961 is prominently referenced (making the IPR also easy to 
find) and they are described as optional / "MAY", not required.

Perhaps that disclosure should be updated by Cisco to link to 793bis as 
well?

---

From: "Scharf, Michael" <[email-masked]>
Date: Thu, 20 May 2021 14:31:52 +0000

Hi all,

The IPR disclosure related to RFC 5961 is documented e.g. in datatracker for a long time (since year 2004) and it should thus be well-known. RFC 5961 mostly affects MAY-12 in 793bis, and MAY-12 is not mandatory to implement.

At least I have no means to verify whether patents related to RFC 5961 apply to the wording in 793bis, or not.

As document shepherd, I plan to record the potential applicability of the IPR disclosure related to RFC 5961 in my write-up for 793bis.

In my understanding, the TCPM working group is aware of the IPR disclosure related to RFC 5961, and the TCPM working group is fine with the currently proposed text in 793bis related to RFC 5961.

Yet, I'd like to double check that this is indeed TCPM consensus, just to be on the safe side.

Michael

> -----Original Message-----
> From: Wesley Eddy <[email-masked]>
> Sent: Wednesday, May 19, 2021 3:19 PM
> To: Scharf, Michael <[email-masked]>; [email-masked]
> Subject: Re: IPR check for draft-ietf-tcpm-rfc793bis-22
> 
> > In preparation of the shepherd write-up, the formal IPR check is required.
> Given the importance of 793bis, I run the IPR check on the TCPM mailing list.
> >
> > @Wes as editor: Please confirm that any and all appropriate IPR disclosures
> required for full conformance with the provisions of BCP 78 and BCP 79 have
> already been filed.
>