Subject: Re: [tcpm] Additional editorial comments on draft-ietf-tcpm-rfc793bis-20

From: Wesley Eddy <[email-masked]>
Date: Mon, 17 May 2021 10:34:47 -0400

On 3/12/2021 5:13 AM, Gorry Fairhurst wrote:
> I did some very careful reading of a few sections of  rfc793bis, and 
> have additional some late editorial comments.
>
> I suspect these really are minor, but I'd hope worthwhile:
>
> ---
>
> (1a) The text uses /may not/, in these two places:
>
> /Note that some options may not be included on all segments/
>
> - I wonder if this is umambiguous to all English speakers (it's not so 
> clear to me), I think it could be better as
>
> /Note that some options might not be included on all segments/
>
> or ...
>
> /Some of the segments might not include include all options/
>
> ... of something like that this?
>
> ---
>
> (1b) I'd suggest similarly avoiding /may not/ in the description of IP 
> Option processing.
>
> ---
>
> (2) The document seems to be missing an IPv6 "view" of extensions in 
> the IP Options part, section 3.6.1 (This is mentioned in the 
> pseudo-header compuation). I suggest we add a brief sentence saying 
> the calculation of "IPv6 Extension Headers" follows thar for IP Option 
> size.

I missed your couple of comments above in the prior -21 revision, but 
Michael S. reminded me of them, and I've incorporated them into the -22 
revision just posted.  On the IPv6 comment, I changed the notion of "IP 
options" in a couple of places to "IPv4 options or IPv6 extension 
headers" which I think accomplishes the right thing.

---

From: "Scharf, Michael" <[email-masked]>
Date: Mon, 17 May 2021 16:10:02 +0000

Hi all,

As document shepherd, I have reviewed all (Post-) WGLC comments. In my understanding, Wes has addressed all known comments in version -22.

As a result, I believe I can close the WGLC and submit the document to the IESG.

In particular to those who have commented on 793bis during WGLC: If for whatever reason version -22 does not resolve your comments, please speak up ASAP!

Thanks

Michael

> -----Original Message-----
> From: tcpm <[email-masked]> On Behalf Of Wesley Eddy
> Sent: Monday, May 17, 2021 4:35 PM
> To: [email-masked]
> Subject: Re: [tcpm] Additional editorial comments on draft-ietf-tcpm-
> rfc793bis-20
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: [email-masked]
Date: Thu, 27 May 2021 19:22:42 +0200

> On 17. May 2021, at 16:34, Wesley Eddy <[email-masked]> wrote:
> 
>> I did some very careful reading of a few sections of  rfc793bis, and have additional some late editorial comments.
>> 
>> - I wonder if this is umambiguous to all English speakers (it's not so clear to me), I think it could be better as
>> 
>> (1b) I'd suggest similarly avoiding /may not/ in the description of IP Option processing.
>> 
>> ---
>> 
>> (2) The document seems to be missing an IPv6 "view" of extensions in the IP Options part, section 3.6.1 (This is mentioned in the pseudo-header compuation). I suggest we add a brief sentence saying the calculation of "IPv6 Extension Headers" follows thar for IP Option size.
> 
> 
> I missed your couple of comments above in the prior -21 revision, but Michael S. reminded me of them, and I've incorporated them into the -22 revision just posted.  On the IPv6 comment, I changed the notion of "IP options" in a couple of places to "IPv4 options or IPv6 extension headers" which I think accomplishes the right thing.
Hi Wes,

I just noted one typo on page 73:

OLD TEXT:

         fourth check the SYN bit

            This step should be reached only if the ACK is ok, or there
            is no ACK, and it the segment did not contain a RST.

NEW TEXT:

         fourth check the SYN bit

            This step should be reached only if the ACK is ok, or there
            is no ACK, and if the segment did not contain a RST.
                           ^^

Best regards
Michael