Subject: [tcpm] TCP Protocol

From: Ron Smith <[email-masked]>
Date: Tue, 12 Oct 2021 12:44:23 -0500

Sir/Ma'am,

My name is Ron Smith and I am a Cyber Warfare Instructor for the DoD and we
reference many of the RFCs on your site frequently throughout the course of
our instruction. One issue I'm having is that we reference a 4 layer TCP
model based on a couple of RFCs but I keep finding references to a 5-layer
model.  In fact, one of the tools we use, Wireshark, also utilizes
dissectors based on the 5-layer model.  Is there an updated RFC or some
guidance that pertains to this updated model?

v/r
Ron Smith

---

From: Jeremy Harris <[email-masked]>
Date: Wed, 13 Oct 2021 17:04:31 +0100

On 12/10/2021 18:44, Ron Smith wrote:
> In fact, one of the tools we use, Wireshark, also utilizes
> dissectors based on the 5-layer model.

Wireshark dissectors correspond to actual protocols and not to
a model.
-- 
Cheers,
   Jeremy

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 13 Oct 2021 09:04:39 -0700

Ron,

It might be useful to review the charter of this WG (and thus the purpose of this list), as well as the Tao of the IETF; you can find both via search engines.

I’ll contact you further off-list with additional info.

Joe

—
Joe Touch, temporal epistemologist
www.strayalpha.com

> On Oct 12, 2021, at 10:44 AM, Ron Smith <[email-masked]> wrote:
> 
> Sir/Ma'am,
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: "Scharf, Michael" <[email-masked]>
Date: Wed, 13 Oct 2021 17:00:21 +0000

For what it is worth, I believe that it is a valid question that is not entirely out-of-scope of TCPM.

As TSV-ART reviewer I quite frequently run into the term „layer-4 protocol“ for TCP, e.g., in documents from other IETF areas… 

And a 5-layer „hybrid“ reference model is used in a lot of books (e.g., Tanenbaum) and that sort of thinking is thus not uncommon – at least outside the IETF.

Michael - well, as professor ;-)

From: tcpm <[email-masked]> On Behalf Of [email-masked]
Sent: Wednesday, October 13, 2021 6:05 PM
To: Ron Smith <[email-masked]>
Cc: [email-masked]
Subject: Re: [tcpm] TCP Protocol

Ron,

Joe

—

www.strayalpha.com <http://www.strayalpha.com> 

On Oct 12, 2021, at 10:44 AM, Ron Smith <[email-masked] <mailto:[email-masked]> > wrote:

Sir/Ma'am,

v/r
Ron Smith

_______________________________________________
tcpm mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/tcpm

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 13 Oct 2021 10:14:00 -0700

If you want to go there:

Besides the info I posted, here’s some additional info:

- the OSI 7-layer reference model is really just the last two words - a reference model
	it is used so we can discuss the differences between stacks; it was not originally intended as an implementation blueprint
	note that it WAS actually implemented (ISODE -  the ISO development environment) but only marginally distributed and never widely operationally used

- the OSI model is based on some assumptions we now know to be wrong
	that each protocol function “lives” at a single layer in a stack
		we now know they repeat at nearly every layer
	that layers never repeat
		we routinely use direct repetition IP in IP, Ethernet in Ethernet, or multilayer repeating layers (IP over Ether over IP over Ether)
	that there are 7 layers
		we routinely use what OSI needs to call decimal or shim layers, e.g., MPLS as layer 2.5 or IPsec as layer 3.5

Although OSI remains the basis of most textbooks, it is not the only way to teach networking. I developed a different model that accommodates not only the issues above, but a few others as well, called the Recursive Network Architecture (RNA), in which:
	- protocol functions can live at any layer
	- layers can repeat either directly or indirectly
	- the number of layers can be as few as 1 or as many as desired
	- layers can be composed dynamically and vary for each message in a ‘connection', if needed
	- OSI and the IETF approaches to layering are degenerate cases of RNA

I developed a complete intro to networking class based on RNA that has been used at USC and UCLA for several years now and is in development as a textbook. 

In summary, if you find that OSI doesn’t match what you see in real networks, that’s because you’re correct and it is not.

—

> On Oct 13, 2021, at 10:00 AM, Scharf, Michael <[email-masked]> wrote:
> 
> From: tcpm <[email-masked] <mailto:[email-masked]>> On Behalf Of [email-masked] <mailto:[email-masked]>
> To: Ron Smith <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>
> www.strayalpha.com <http://www.strayalpha.com/>
> 
> 
> On Oct 12, 2021, at 10:44 AM, Ron Smith <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Sir/Ma'am,
> 
> https://www.ietf.org/mailman/listinfo/tcpm <https://www.ietf.org/mailman/listinfo/tcpm>
>  
> https://www.ietf.org/mailman/listinfo/tcpm <https://www.ietf.org/mailman/listinfo/tcpm>