Subject: Re: [tcpm] Moving forward draft-touch-sne on independent stream?

From: Martin Duke <[email-masked]>
Date: Mon, 29 Nov 2021 11:29:21 -0800

The conflict review is now in my inbox, and we will discuss it on December
2nd. If there are any concerns about this, please say so immediately.

On Tue, Jul 6, 2021 at 1:05 PM Scharf, Michael <
[email-masked]> wrote:

> Hi all,
>
> Joe has submitted draft-touch-sne to the ISE asking for publication of an
> RFC on the Independent Stream. (Background: An RFC on Independent Stream is
> not an IETF standard.)
>
> Publication on independent stream would be possible provided that the
> document does not conflict with TCPM or other IETF work. An obvious
> alternative would be homing the document in TCPM (or TSVWG) as an official
> WG item - but this is not what is currently proposed.
>
> A link to the document is:
>
> https://datatracker.ietf.org/doc/html/draft-touch-sne
>
> Note that the current header field "TCPM" would have to be replaced in the
> further publication process, as documents on the independent stream are not
> the outcome of an IETF WG.
>
> The TCPM chairs have reviewed draft-touch-sne. Our current understanding
> that there would be no harm caused by such an independent stream
> publication. As far as RFC 5925 is affected, we assume that an Errata would
> be possible and sufficient.
>
> Before we get back to the ISE regarding this document, we would like to
> cross-check whether our understanding is indeed the TCPM consensus:
>
> Are there any concerns inside the TCPM community regarding a publication
> of draft-touch-sne draft-touch-sne on independent stream? If so, please
> speak up!
>
> Thanks
>
> Michael
> on behalf of all chairs
>
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm
>

---

From: Yoshifumi Nishida <[email-masked]>
Date: Mon, 29 Nov 2021 12:28:57 -0800

Hi Martin,

This is just my opinion as an individual contributor.
I prefer to discuss this draft in the WG more rather than publishing it as
an IS.
I think SYN option space extension is an important feature for TCP's
future, so I think it would be better to have a standardized solution for
it.
Also, I don't see strong benefits to publish it for now.
--
Yoshi

>> Note that the current header field "TCPM" would have to be replaced in
>> the further publication process, as documents on the independent stream are
>> not the outcome of an IETF WG.
>>

---

From: Martin Duke <[email-masked]>
Date: Mon, 29 Nov 2021 13:04:03 -0800

SYN option space is not the subject of the draft.

On Mon, Nov 29, 2021 at 12:29 PM Yoshifumi Nishida <[email-masked]>
wrote:

>> The conflict review is now in my inbox, and we will discuss it on
>> December 2nd. If there are any concerns about this, please say so
>> immediately.
>>
>
>>> Joe has submitted draft-touch-sne to the ISE asking for publication of
>>> an RFC on the Independent Stream. (Background: An RFC on Independent Stream
>>> is not an IETF standard.)
>>>

---

From: Yoshifumi Nishida <[email-masked]>
Date: Mon, 29 Nov 2021 13:12:31 -0800

Oh. I'm very sorry for it. I mistook it as a different one.
--
Yoshi

On Mon, Nov 29, 2021 at 1:04 PM Martin Duke <[email-masked]> wrote:

>> I prefer to discuss this draft in the WG more rather than publishing it
>> as an IS.
>>>> The TCPM chairs have reviewed draft-touch-sne. Our current
>>>> understanding that there would be no harm caused by such an independent
>>>> stream publication. As far as RFC 5925 is affected, we assume that an
>>>> Errata would be possible and sufficient.
>>>>
>>>> Are there any concerns inside the TCPM community regarding a
>>>> publication of draft-touch-sne draft-touch-sne on independent stream? If
>>>> so, please speak up!
>>>>
>>>> Thanks
>>>>
>>>> Michael
>>>> on behalf of all chairs
>>>>

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 29 Nov 2021 13:30:07 -0800

Yoshi,

I believe you are referring to draft-touch-tcpm-tcp-syn-ext-opt; I am awaiting WG decision on having that doc become an experimental WG doc.

The query below is for the sequence number extension solution that primarily affects TCP-AO option implementations and other such uses of sequence numbers. The two docs are not related.

The sequence number extension is example code; it need not be a standard.

Joe

—
Joe Touch, temporal epistemologist
www.strayalpha.com

> On Nov 29, 2021, at 12:28 PM, Yoshifumi Nishida <[email-masked]> wrote:
> 
> Hi Martin,
> 
> I prefer to discuss this draft in the WG more rather than publishing it as an IS.
> I think SYN option space extension is an important feature for TCP's future, so I think it would be better to have a standardized solution for it.
> On Mon, Nov 29, 2021 at 11:29 AM Martin Duke <[email-masked] <mailto:[email-masked]>> wrote:
> The conflict review is now in my inbox, and we will discuss it on December 2nd. If there are any concerns about this, please say so immediately.
> 
> On Tue, Jul 6, 2021 at 1:05 PM Scharf, Michael <[email-masked] <mailto:[email-masked]>> wrote:
> Hi all,
> 
> Joe has submitted draft-touch-sne to the ISE asking for publication of an RFC on the Independent Stream. (Background: An RFC on Independent Stream is not an IETF standard.)
> 
> Publication on independent stream would be possible provided that the document does not conflict with TCPM or other IETF work. An obvious alternative would be homing the document in TCPM (or TSVWG) as an official WG item - but this is not what is currently proposed.
> 
> https://datatracker.ietf.org/doc/html/draft-touch-sne <https://datatracker.ietf.org/doc/html/draft-touch-sne>
> 
> Note that the current header field "TCPM" would have to be replaced in the further publication process, as documents on the independent stream are not the outcome of an IETF WG.
> 
> The TCPM chairs have reviewed draft-touch-sne. Our current understanding that there would be no harm caused by such an independent stream publication. As far as RFC 5925 is affected, we assume that an Errata would be possible and sufficient.
> 
> Before we get back to the ISE regarding this document, we would like to cross-check whether our understanding is indeed the TCPM consensus:
> 
> Are there any concerns inside the TCPM community regarding a publication of draft-touch-sne draft-touch-sne on independent stream? If so, please speak up!
> 
> Thanks
> 
> Michael
> on behalf of all chairs
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tcpm <https://www.ietf.org/mailman/listinfo/tcpm>

---

From: Yoshifumi Nishida <[email-masked]>
Date: Mon, 29 Nov 2021 22:05:07 -0800

Hi Joe,
Yes. I am very sorry for the confusion. I've read the draft before and I
don't have any objections to proceeding with this draft.
One minor comment I have is that the method described in the draft
is focusing on providing protection against wrapping.
But, I think it does not provide protection against duplicates from old
sessions.
I believe it is fine for TCP-AO, but it may need a bit more attention on
this point when it's used for other purposes.
--
Yoshi

On Mon, Nov 29, 2021, 1:30 PM [email-masked] <[email-masked]>
wrote:

> Yoshi,
>
> I believe you are referring to draft-touch-tcpm-tcp-syn-ext-opt; I am
> awaiting WG decision on having that doc become an experimental WG doc.
>
> The query below is for the sequence number extension solution that
> primarily affects TCP-AO option implementations and other such uses of
> sequence numbers. The two docs are not related.
>