Subject: TCP over VSAT

From: [email-masked]
Date: Tue, 10 Nov 1998 11:01:19 +0100

Hi ,

Is there someone with experience about the following subject : TCP over
VSAT ?

 We are using NT servers on the remotes and centrally SUN Solaris 2.3 and
2.6 server.

Many Thanks,
Guy

---

From: [email-masked]
Date: Fri, 13 Nov 1998 09:25:50 +0100

Hi Dave,

We are using also Hughes systems : PES6000, ISBN 7.B (soon 7.D). Our
problem is that TCP is not performing very well over this network, although
we are using NT with SP3 (which includes Fast retransmission/recovery) and
on the host Solaris 2.6 which also support this. Reading a lot of
documents, the above techniques are presented as the solution for the
TCP/VSAT problem (if I understand correctly). My question is : are there
any other techniques/ method's that improve TCP/VSAT ?

Thanks,
Guy Raymakers
EDS

PS.: the window size is 40880, and some timing parameters are also changed.

Hi:

We are using Hughes Network Systems VSAT in 13 countries. We have a Unix
based system, but soon we will be moving to NT. Specifically what do you
want to know ?

Kamal Dave
Galaxy latin America (Sub. Hughes Electronics)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of [email-masked]
Sent: Tuesday, November 10, 1998 5:01 AM
To: [email-masked]
Subject: TCP over VSAT

Hi ,

 We are using NT servers on the remotes and centrally SUN Solaris 2.3
and
2.6 server.

Many Thanks,
Guy

---

From: "Jack Stiekema" <[email-masked]>
Date: Fri, 13 Nov 1998 15:54:45 +0100

Dear Guy,

I checked my notes:
using NT4-sp3 120kps should be possible.

But this is only possible with:
No errors, no resending, no other services/programs on the machines, no collisions on the local network, do not touch the mouse, do
not open/close windows, do not have any programs started/stopped,
Missing only a twice a bit/packet within a second can degrade performance heavily.

Maybe you should use tcpdump/tcptrace on the Unix box to see why the windowsize is not fully used.

Jack Stiekema

Cap Gemini Nederland
Phone: +31 (0)30 252 9219
Fax: +31 (0)598 398008

-----Original Message-----
From: [email-masked] <[email-masked]>
To: Jack Stiekema <[email-masked]>
Cc: [email-masked] <[email-masked]>
Date: vrijdag 13 november 1998 13:57
Subject: Re: TCP over VSAT

Hi Jack,

Couple more details :
- we have an inroute of 128 kbps and an outroute of 512kps.
- ftp traffic is carried over Transaction Reservation on VSAT

Doing an ftp , I get 30 kps on the outroute and less on the inroute (19
kps). Although I'm not the only user on the VSAT network, I expected a
higher performance (the usage is only 20 % on inroute and 30 % on
outroute).

Best regards,
Guy

Dear Guy,

What do you expect,
and what do you get as performance?

Jack Stiekema

Cap Gemini Nederland
Phone: +31 (0)30 252 9219
Fax: +31 (0)598 398008

    -----Original Message-----
    From: [email-masked] <[email-masked]>
    To: Dave, Kamal N <[email-masked]>
    Cc: [email-masked] <[email-masked]>
    Date: vrijdag 13 november 1998 12:01
    Subject: RE: TCP over VSAT

    Hi Dave,

    We are using also Hughes systems : PES6000, ISBN 7.B (soon 7.D). Our
    problem is that TCP is not performing very well over this network,
although
    we are using NT with SP3 (which includes Fast retransmission/recovery)
and
    on the host Solaris 2.6 which also support this. Reading a lot of
    documents, the above techniques are presented as the solution for the
    TCP/VSAT problem (if I understand correctly). My question is : are
there
    any other techniques/ method's that improve TCP/VSAT ?

    Thanks,
    Guy Raymakers
    EDS

    PS.: the window size is 40880, and some timing parameters are also
changed.

    Hi:

    We are using Hughes Network Systems VSAT in 13 countries. We have a
Unix
    based system, but soon we will be moving to NT. Specifically what do
you
    want to know ?

    Kamal Dave

    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]]On
    Behalf Of [email-masked]
    Sent: Tuesday, November 10, 1998 5:01 AM
    To: [email-masked]
    Subject: TCP over VSAT

    Hi ,

    Many Thanks,
    Guy

---

From: "Vivek Gupta" <[email-masked]>
Date: Fri, 13 Nov 1998 12:38:19 -0500

Guy,

Are you aware of the product called DirecPC Enterprise Edition, which
upgrades your existing PES hubs to allow throughputs on outroute
of upto 2Mbps? I don't have a lot of details on that, but you might want 
to talk to your contacts at HNS about the feasibility of this for
your application.

Vivek

>>Attachment Converted: "h:\workarea\eudora\att-11.htm"
>>
>>Attachment Converted: "h:\workarea\eudora\Jack Stiekema2.vcf"
>>
>*********************************************
>William D. Ivancic
>NASA Lewis Research Center
>21000 Brookpark Rd.   MS 54-8
>Cleveland, Ohio  44135
>USA
>Phone:   1 216 433 3494
>FAX:     1 216 433 8705
>Email:   [email-masked]
>         [email-masked] 
>*********************************************
>

---

From: [email-masked]
Date: Fri, 13 Nov 1998 09:25:50 +0100

Hi Dave,

Thanks,
Guy Raymakers
EDS

Hi:

Kamal Dave

-----Original Message-----

Hi ,

Many Thanks,
Guy