Subject: RE: improve SACK?

From: Tang Oo <[email-masked]>
Date: Fri, 15 Jan 1999 09:33:30 +0800

Dear all:
I haven't received any response from you. Could you give me some comments?

> -----Original Message-----
> From:	Tang Oo 
> Sent:	Sunday, January 10, 1999 6:45 PM
> To:	[email-masked]'
> Subject:	improve SACK?
> 
> I have some ideas about improving the performance of TCP with SACK, but
> don't know if they are new and feasible ideas.
> I have read Matthew's paper on FACK and IETF RFC on SACK. Since the Sack
> provides much more information than ack, why not make use of these
> statistics? With Sack, we can get these information: The number of
> received segments during the last RTT, the number of lost segments. With
> these data, we can calculate: The average transmission rate at sender
> side, the arrival rate at receiver side(measured with timestamp), the loss
> rate at receiver side. Then adjust the window size according to the
> achieved throughput and loss rate during previous RTT. Now I am working on
> the algorithm of window adjustment. If somebody else has worked out the
> same idea or a good algorithm, pls inform me. Or if it is really a new
> idea, pls send me some comments.
> Thanks a lot.
> 
> 
> Tang Oo 	Research Engineer
> Network Technology Research Center
> Nanyang Technological University, Singapore
> Tel: (65)7905362	Fax: (65)7926894
>

---

From: Tang Oo <[email-masked]>
Date: Fri, 15 Jan 1999 09:33:30 +0800

Dear all:

---

From: Sally Floyd <[email-masked]>
Date: Wed, 27 Jan 1999 11:29:39 PST

>don't know if they are new and feasible ideas.

For a web page with pointers to other approaches to congestion control
that involve measuring the achieved throughput and the loss rate,
you could see the following:
"http://www.psc.edu/networking/tcp_friendly.html".

This issue is also being addressed on the mailing list of the
Reliable Multicast Research Group, "http://www.east.isi.edu/RMRG/".

- Sally