Subject: Re: HTTP performance issues

From: Joe Touch <[email-masked]>
Date: Thu, 18 Feb 1999 15:11:53 -0800 (PST)

> From [email-masked] Thu Feb 18 11:00:58 1999
> From: [email-masked]
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: HTTP performance issues
> Date: 22 Jan 1999 08:42:46 -0500
> Lines: 30
> 
> [email-masked] writes:
> 
> > Hi ,
> > 
> > We are now in the process of rolling-out web based applications to a number of
> > remote VSAT connected sites. With the tests we did, I have to conclude that the
> > performance of HTTP is rather poor. Now one factor that might have an impact is
> > that we use Transaction reservation on the VSAT inroutes. (TR give round trip
> > times of about 1500msec). We don't have any choice, we cannot use Stream for all
> > remote sites. Is there a way to improve the performance, we know for example the
> > product Venturi (from Fourelle) but that product turns the HTTP protocol into
> > something proprietary protocol. What I'm trying to find out is : are there
> > tunings possible to the existing standard HTTP protocol ?
> > 
> > Many Thanks,
> > Guy Raymakers
> > 
> > 
> 
> Unless you use http 1.1 and use the persistent TCP connections (forgot
> the real name, sorry) that do not open a TCP connection for each HTTP
> request then you are pretty much out of luck. With 1.5 sec RTT, you
> will get awful performance for HTTP traffic (on the order of
> 8Kbytes/sec or so). Your best bet is to use one of the available TCP
> spoofing/proxy boxes and break the end-2-end semantics. 

Why? 1.1 and persistent connections doesn't require the spoofing stuff...

Joe

---

From: Lloyd Wood <[email-masked]>
Date: Fri, 19 Feb 1999 00:27:09 +0000 (BST)

On Thu, 18 Feb 1999, Joe Touch wrote:

>>> performance of HTTP is rather poor.

end-to-end performance of HTTP is always poor. That's why we have
proxy caches. Are you using proxy caches, and if so where are they
located?

(And if not, why not? http://ircache.nlanr.net/ etc.)

L.

<[email-masked]>PGP<http://www.ee.surrey.ac.uk/Personal/L.Wood/>

---

From: Fred Baker <[email-masked]>
Date: Fri, 19 Feb 1999 08:32:16 -0800

>> spoofing/proxy boxes and break the end-2-end semantics. 

I disagree, based one two things. One is Mark Allman's research on the ACTS
satellite, which I'm sure you're aware of, and the other is the semantics
of HTTP. If you operate in a transaction mode, it really doesn't matter how
many toys you play with, the transactions clock the process - and the
transactions are going across the bird.

It seems to me that the HTTP answer has got to be a combination of
effective use of persistent TCP connections plus the TCP mechanisms -
starting with 2-3 data messages in the first data burst, large windows,
SACK - to make it run well over a high delay*bandwidth link. And I think
ECN is likely to be important as well, although that has much less
operational experience behind it.

---

From: [email-masked]
Date: Fri, 19 Feb 1999 09:19:55 -0500

> Why? 1.1 and persistent connections doesn't require the spoofing stuff...

The reason why I mention 1.1 and persistent connections is not due to
the spoofing but due to the fact that most HTTP transactions do not
send enough data to fill the pipe in a satellite channel and never get
out of slow start. If you do
locate a proxy that sits between the host and the satellite channel
and use a version of TCP that is modified, then the so-called spoofing
boxes may be helpful.

However, they still break the end2end semantics unfortunately and may
not work with anetwork that uses end2end IPSEC for VPNs or such.

Bora

ps. The email that "re-started" this thread was sitting in a mailer
queue for a couple months and I discovered this yesterday and flushed
the queue.