Subject: Re: HTTP performance issues

From: [email-masked]
Date: 22 Jan 1999 08:42:46 -0500

[email-masked] writes:

> Hi ,
> 
> We are now in the process of rolling-out web based applications to a number of
> remote VSAT connected sites. With the tests we did, I have to conclude that the
> performance of HTTP is rather poor. Now one factor that might have an impact is
> that we use Transaction reservation on the VSAT inroutes. (TR give round trip
> times of about 1500msec). We don't have any choice, we cannot use Stream for all
> remote sites. Is there a way to improve the performance, we know for example the
> product Venturi (from Fourelle) but that product turns the HTTP protocol into
> something proprietary protocol. What I'm trying to find out is : are there
> tunings possible to the existing standard HTTP protocol ?
> 
> Many Thanks,
> Guy Raymakers
> 
> 

Unless you use http 1.1 and use the persistent TCP connections (forgot
the real name, sorry) that do not open a TCP connection for each HTTP
request then you are pretty much out of luck. With 1.5 sec RTT, you
will get awful performance for HTTP traffic (on the order of
8Kbytes/sec or so). Your best bet is to use one of the available TCP
spoofing/proxy boxes and break the end-2-end semantics. 

-- 
Bora Akyol, PhD
BBN Technologies
GTE Internetworking

---

From: [email-masked]
Date: Fri, 19 Feb 1999 14:03:41 +0100

Hi John,

Following url is a good start : http://www.flash-networks.com

Best regards,
Guy

To:   Guy Raymakers@EDSBELGIUM
cc:   [email-masked]
Subject:  Re: HTTP performance issues

Hello,

Does anyone have information on Satbooster, a Web site mabye ?

Thanks

john

>
>Hi
>
>The plan is to us proxies on each remote and one on the VSAT HUB.  We are now
>testing Satbooster and Venturi, do you know similar products like this ?
>
>Guy
>
>
>Please respond to Lloyd Wood <[email-masked]>
>
>To:   Joe Touch <[email-masked]>
>cc:   Guy Raymakers@EDSBELGIUM, [email-masked], [email-masked]
>Subject:  Re: HTTP performance issues
>
>
>
>
>On Thu, 18 Feb 1999, Joe Touch wrote:
>
>>>> Hi ,
>>>>
>>>> performance of HTTP is rather poor.
>
>end-to-end performance of HTTP is always poor. That's why we have
>proxy caches. Are you using proxy caches, and if so where are they
>located?
>
>(And if not, why not? http://ircache.nlanr.net/ etc.)
>
>L.
>
><[email-masked]>PGP<http://www.ee.surrey.ac.uk/Personal/L.Wood/>
>
>
>

---

From: Bob Nobis <[email-masked]>
Date: Fri, 19 Feb 1999 07:23:58 -0800

I am also looking for information on Satbooster.

Thank you.

Bob

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, February 19, 1999 4:38 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: HTTP performance issues

Hello,

Thanks

john

>>>> We are now in the process of rolling-out web based applications to
a number
>of
>>>> remote VSAT connected sites. With the tests we did, I have to
conclude that
>the

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 19 Feb 1999 13:43:38 -0600

Joe, I thought I had heard about WREC before, but I kind of assumed that it
corresponded to either the PILC or RUTS BOFs, which both met at Orlando. Is
this in fact the case? If not, do you have a pointer to WREC?

Spencer

(Oh, lord, not ANOTHER transport-level working group!)

> From:	Joe Touch [SMTP:[email-masked]]
> Sent:	Friday, February 19, 1999 11:28 AM
> To:	[email-masked]; [email-masked]
> Cc:	[email-masked]
	deleted stuff down to ...
>  We're working on a more comprehensive list of this, to be reviewed
> in the WREC WG (pending its creation)...
> 
> Joe

---

From: Joe Touch <[email-masked]>
Date: Fri, 19 Feb 1999 15:02:54 -0800 (PST)

> From [email-masked] Fri Feb 19 11:58:40 1999
> From: "Spencer Dawkins" <[email-masked]>
> To: "'Joe Touch'" <[email-masked]>
> Cc: [email-masked], "'Vern Paxson'" <[email-masked]>
> Subject: RE: HTTP performance issues
> Date: Fri, 19 Feb 1999 13:43:38 -0600
> 

PILC, very roughly, is 
	how can existing Internet be tuned for specific link layers
	what link layer requirements does the Internet need,
		and how to provide them

RUTS, very roughly, is
	what transport protocols, other than TCP, might be useful
	is it better to augment TCP, or have separate transports

WREC is completely different, much more at the app layer, and being
done out of the transport area mostly to keep it coordinated with its
transport underpinnings, not because it's a transport issue, per se:
	what are the common bases of web caching and replication protocols

These are my own views on the matter; see the IETF WG web pages for more info,
as below:

	PILC: http://www.ietf.org/proceedings/98dec/43rd-ietf-98dec-140.html

	RUTS: http://www.ietf.org/proceedings/98dec/43rd-ietf-98dec-142.html

	WREC: http://www.ietf.org/proceedings/98dec/43rd-ietf-98dec-43.html

		or the current "WG" proposed charter page:

		http://www.terena.nl/tech/wrec/

FWIW...

Joe

Joe

---

From: [email-masked]
Date: Fri, 19 Feb 1999 15:40 -0800 (PST)

I guess if it's a transport area group it would be....
     
     Tra(i)n WREC
     
     :^)

     --aaron

______________________________ Reply Separator _________________________________
Subject: RE: HTTP performance issues
Author:  [email-masked] at mime
Date:    2/19/99 11:43 AM

Spencer

> in the WREC WG (pending its creation)...

RFC-822-headers:
Date: Fri, 19 Feb 1999 13:43:38 -0600
From: Spencer Dawkins <[email-masked]>
Subject: RE: HTTP performance issues
Sender: [email-masked]

---

From: Vern Paxson <[email-masked]>
Date: Fri, 19 Feb 1999 16:25:04 PST

> 	what are the common bases of web caching and replication protocols

It's in APPS, not TSV - name is "webrepl".

		Vern