Subject: Re: BER and TCP/IP performance

From: Anurag Kumar <[email-masked]>
Date: Thu, 1 Apr 1999 10:23:03 +0530 (IST)

With reference to Aaron Falk's mail excerpted below:

Recently several analyses have been published
that account for correlated losses (for example, as would occur
in wireless fading channels). The results are quite different from
those obtained for independent and identically distributed losses.
As would be expected, in addition to the *average* bit error rate,
the lengths of the good and bad periods of the channel become important.
It turns out that rapid fading and very slow fading are both better
than fade rates comparable to the RTT. If the link layer is always
able to recover from losses, then essentially it is as if TCP sees
a bottleneck link with a time varying bit rate.

My papers on this topic an be found at http://ece.iisc.ernet.in/~anurag

There are other papers by Zorzi & Rao (CISS 97 or 98 ?), Anjum and Tassiulas
(Sigmetrics 99). And I am sure there are other papers too.

-- Anurag

On Wed, 31 Mar 1999 [email-masked] wrote:

> Jamshid-
> 
> Thank you for raising an important point. Not all bit errors are equivalent.
> Most (all?) satellite links utilize FEC. Block coding results in lost blocks
> when uncorrectable errors occur. The packet loss rate due to corrupted blocks is
> much different that that due to a uniform distribution of bit errors. So, the
> translation of channel BER (after FEC) to packet loss rate (which is necessary
> to interpret the results of the reference below will depend heavily on the
> adaptation of IP to link layer.
> 

_______________________________________________________________________________
Anurag Kumar				     |e-mail: [email-masked]
Professor  				     |Phone: (+91)-80-334 0855 or
and Coordinator ERNET Project		     |       (+91)-80-309 2387
Dept. of Electrical Communication Engg. (ECE)|Fax:   (+91)-80-334 7991 or
Indian Institute of Science (IISc)           |       (+91)-80-334 1683
Bangalore, 560 012, INDIA                    |http://ece.iisc.ernet.in/~anurag
-------------------------------------------------------------------------------

---

From: Cannara <[email-masked]>
Date: Wed, 31 Mar 1999 19:15:52 -0800

FYI Eric, you may also be interested in the performance of an NT4 TCP over a
400-mile path with only 0.25% T1 frame loss -- sounds like just a little loss,
but the 1-minute transaction (~2MB transfer) took 40% longer than when no
errors occurred, all because TCP can't distinguish error loss from congestion
loss and so backs off for the wrong reason. 

In the attached, the blue triangles represent ~30kB blocks from the NT box and
spaces between them indicate dead time, while TCP is timing out.  The upward
movements in the red curve correspond to loss, or making no real progress
(burning daylight), while downward movements are progress at faster than the
average rate.  Because of TCP's behavior, this T1 link was only fractionally
utilized.  NT defaults for TCP also limit it, in terms of maximum send window
-- inadequate for this bit-rate x round-trip time, and contribute another >10%
efficiency loss.

Alex
PS: This is actually an example from a QoS paper to be presented at IEEE
WECWIS-WIP in Santa Clara next Friday.

Eric Travis wrote:
> 
> >Having said all that, my understanding is that to get 'decent'
> >performance out of TCP (ie., a window > 1) packet losses should
> >be limited to less than 1 per RTT.
> 
> Only if the definition of 'decent' translates to an effective
> cwnd of ~1 or 2 segments :o(
> 
> You really want your (non-congestion based) losses bunched within
> single RTTs that are fairly widely spaced [how wide will depend
> on what your optimal cwnd for the path would be]. Otherwise TCP
> will be severely under driving your link.
> 
> >There was a thread recently on the pilc list (see
> >http://pilc.grc.nasa.gov/pilc) on channel BER that might be
> >of interest to tcpsat participants. I am crossposting to the
> >pilc list and would like to recommend continuing this
> >discussion there.
> 
> Is it me, or haven't we already seen this thread replay
> itself a half dozen times already on this *very* mailing
> list? :o)
> 
> This seems like a good time to plug the excellent tcpsat
> mailing list archive that Mark makes available off of:
> 
> http://tcpsat.grc.nasa.gov
> 
> I'm confident that if one pulls the archive and does a
> grep on BER, errors or loss - you will be able to extract
> virtually all the collected wisdom/opinions from the cyclic
> (and often passionate) "BER Wars" thread that appear every
> 2-3 months during 1998. I'm pretty sure it is all there
> already (several times).
> 
> The stuff its there for those who want to dig it out;
> Archives are there available, so let's not replay the
> old stuff again on either tcpsat or pilc? New stuff
> would be fantastic.
> 
> Eric

---

From: AL-HUSSEIN ABOU-ZEID <[email-masked]>
Date: Thu, 08 Apr 1999 13:32:44 PDT

Hi,

I have been conducting some analysis/ns simulations with TCP over typical 
satellite links (LEO and GEO). I have come to the same conclusions as
Anurag's. However, my results show that the throughput is worse when the
average fade duration is close to the packet transmission time (which is a
function of the packet size and the bit rate) rather than the RTT (and
hence the IETF recommendation regarding using large segment size is 
still applicable for this problem).

Regards,

--Hussein.

> 
> 
> ----- Begin Included Message -----
> 
> >From [email-masked] Mon Apr  5 18:36:22 1999
> X-Authentication-Warning: raptor.CS.Berkeley.EDU: tomh owned process doing -bs
> Date: Mon, 5 Apr 1999 18:39:53 -0700 (PDT)
> From: Tom Henderson <[email-masked]>
> Reply-To: [email-masked]
> To: [email-masked]
> Subject: Re: BER and TCP/IP performance (fwd)
> Organization: UC Berkeley Computer Science
> X-Url: http://www.cs.berkeley.edu/~tomh
> MIME-Version: 1.0
> Content-Type: TEXT/PLAIN; charset=US-ASCII
> Content-Length: 2508
> 
> Murat,
> I came across this message on the tcpsat mailing list today and thought
> you might be interested in these references concerning TCP modelling for
> non-IID loss channels.
> 
> Tom
> 
> ---------- Forwarded message ----------
> Date: Thu, 1 Apr 1999 10:23:03 +0530 (IST)
> From: Anurag Kumar <[email-masked]>
> To: [email-masked]
> Cc: [email-masked], [email-masked], [email-masked],
>     [email-masked]
> Subject: Re: BER and TCP/IP performance
> 
> ----- End Included Message -----
> 
>