Subject: Remote NT tools over satellite

From: [email-masked]
Date: Thu, 14 Oct 1999 16:27:14 +0100

We are currently using Windows NT 4.0 (SP3) servers with TCP.
Currently our Helpdesk is using PC Anywhere from Symantec to take over the NT
screens.
This software is working as long as the RTT are around 1.5 to 2.5 s (typ for our
VSAT setup).
Above these values the application starts having problems (very very slow or the
application hangs up).

Does anyone has experience with other remote tools that are performing good over
the Satellite link ?

Jan Broux
EDS

---

From: [email-masked]
Date: 14 Oct 1999 13:12:53 -0700

I use SSH and have no problems.
Dave

jan> We are currently using Windows NT 4.0 (SP3) servers with TCP.
jan> Currently our Helpdesk is using PC Anywhere from Symantec to take over the NT
jan> screens.
jan> This software is working as long as the RTT are around 1.5 to 2.5 s (typ for our
jan> VSAT setup).
jan> Above these values the application starts having problems (very very slow or the
jan> application hangs up).

jan> Does anyone has experience with other remote tools that are performing good over
jan> the Satellite link ?

jan> Jan Broux
jan> EDS

---

From: [email-masked] (Jim Mercer)
Date: Thu, 14 Oct 1999 19:05:09 -0400 (EDT)

> I use SSH and have no problems.

unless this is a different ssh (secure-shell www.ssh.fi), than i'm thinking,
the original message effectively controlling remote desktops.

this is more of a VNC type application.

check out http://www.uk.research.att.com/vnc/

it may be more resilient to latency and packet loss.

> jan> Currently our Helpdesk is using PC Anywhere from Symantec to take over
> jan> the NT screens.
> jan> This software is working as long as the RTT are around 1.5 to 2.5 s
> jan> (typ for our VSAT setup).
> jan> Above these values the application starts having problems (very very
> jan> slow or the application hangs up).
> 
> jan> Does anyone has experience with other remote tools that are performing
> jan> good over the Satellite link ?

-- 
[ Jim Mercer    Reptilian Research      [email-masked]   +1 416 410-5633 ]
[ The telephone, for those of you who  have forgotten, was a commonly used ]
[ communications technology in the days before electronic mail.            ]
[ They're still easy to find in most large cities. -- Nathaniel Borenstein ]

---

From: "Richard Wood" <[email-masked]>
Date: Fri, 15 Oct 1999 14:32:06 +0100

> it may be more resilient to latency and packet loss.

I have sucessfully used VNC over a asymetric satellite link (return path via
dialup & lan).

I have yet to test it via a bi-directional satellite link.

Richard
~~~~~~~~~~~~~~~~~~~~~~~~~~
Richard Wood - [email-masked]
Technical & Sales Support Engineer

Satellite Media Services
Lawford Heath Earth Station
Rugby, Warwickshire,CV23 9EU

T: +44 1788 523 000
F: +44 1788 523 001
URL:http://www.sms.co.uk/

---

From: Jamshid Mahdavi <[email-masked]>
Date: 15 Oct 1999 11:23:28 -0700

I pointed out a "feature" of TCP on pilc a while back, which is the
following.  If the RTT is longer than 3 seconds, the initial SYN which
is sent takes a timeout (because the default initial RTO is 3
seconds).  This causes a retransmission of the SYN, and causes
ssthresh to be set to 1 or 2 packets.

This would effectively prevent any slowstart from occuring on such a
path, and cause any sort of bulk-transfer application to be extremely
slow.

I don't know if this would apply to the problem you are seeing, but
the fact that you work well up to 2.5 seconds sounds like it might...

--Jamshid