Subject: Re: [email-masked]: Help in Satellite comunications

From: "Graham Fennie" <[email-masked]>
Date: Wed, 10 Nov 1999 16:52:43 -0500

Greg,

Absolutely correct... Since MetaFrame simulates a 'realtime' client / server environment it is *extremely* sensitive to latency - although its bandwidth requirements are fairly low (33-56 kbits / sec).

Also, MetaFrame should be avoided in graphics intensive applications such as Photoshop, PageMaker, etc. The increased graphics requirements of these applications can quickly consume 192+ kbits or more.

-Graham

Graham A. Fennie
Systems Engineer
Western NY Computing Systems, Inc.
(716) 381-4120 x7334
[email-masked]

>>> "Gregory D. Otto" <[email-masked]> 11/10/1999 4:36:40 PM >>>
I have found that if you have latencies approaching 200 ms, Citrix users
will complain of unacceptable performance.

At 12:25 PM 11/10/99 -0500, Graham Fennie wrote:
>Citrix Metaframe is a "thin client" software package that runs on top of
Windows NT Terminal Server. It is essentially a 'throwback' to the old days
of dumb terminals and mainframe computing.
>
>All processing and I/O is done on the Windows NT Server - which clients
can connect to using the Citrix client software... the client sends
keystrokes & mouse clicks to the server, and receives screen updates
(similar to PC Anywhere). For more information:
>
>www.citrix.com 
>
>Granted my experience with MetaFrame is limited to land-lines and dial-up
connections - but I don't see how the software would adversely effect your
satellite bandwidth.... and on a 128kbps connection (assuming low latency),
you should be able to support 3-5 concurrent users.
>
>Regards,
>Graham
>
>
>
>
>Graham A. Fennie
>Systems Engineer
>Western NY Computing Systems, Inc.
>(716) 381-4120 x7334
>[email-masked] 
>
>>>> Dan Shell <[email-masked]> 11/09/1999 2:58:41 PM >>>
>Just what is a metaframe?
>
>And using TDMA should not cause a performance problem.
>As Mark can tell you that the link utlilization in TCP/IP depends on the
>quality of TCP/IP protocol stack and
>if it has enable large windows (very important) adjustable buffers etc.)
>
>
>At 01:53 PM 11/9/99 -0500, Mark Allman wrote:
>> 
>>The following was sent to an old version of the tcpsat mailing list
>>that doesn't exist.
>>
>>allman
>>
>>
>>------- Forwarded Message
>>
>>From: [email-masked] 
>>To: [email-masked], [email-masked], [email-masked],
>>        [email-masked] 
>>Date: Fri, 5 Nov 1999 19:10:14 -0400
>>Subject: Help in Satellite comunications
>>
>>
>>     At the moment we are working in a project that requires the use of
>>satellite
>>communication.
>>Looking for information in the Internet I arrived to your web page. We need
>>to clarify some topics and maybe you can help us or give us  references
>>where to find answers.
>>The scene it is more or less this:
>>
>>Four locations of work exist, each one of them consists of a network
>>Ethernet with platform NT,
>>gateway, the connection between this locations are by means of satellite
>>communication using
>>TDMA with Dynamic Location of  Time, a bandwidth of 512 Kbps and using
>>Metaframe of citrix with
>>the TCP/IP protocol.
>>
>>The main problem to face is the possibility that this bandwidth is not well
>>used: some of the technicians of the project argue that with metaframe  the
>>transmission is limited to 128 kbps and the 512 Kbps available will not be
>>used, due to the TDMA with Dynamic Location of  Time. For this reason my
>>concern  is to find a similar systems in operation that uses this
>>technology.
>>
>>The system looks like this:
>>
>>Two Ethernet networks with platform NT, communicated by means of satellite
>>using technology
>>TDMA (Dynamic Location of Time) with a bandwidth of 512kb. On one side we
>>have applications servers and in the other side we have around about 20
>>concurrent clients of relatively heavy applications using protocol TCP/IP.
>>
>>My questions are:
>>
>>1) It is true that with this technology  (TDMA with DLT) the maximum
>>bandwidth that I will be able to use
>>is 128 Kbps even if I have a channel of 512 kbps ?
>>
>>2)  If  the previous is true, how would be the way to increase the
>>bandwidth
>>an at what cost of the communication channel? What would be maximum real
>>bandwidth of this 512 Kbps channel ?
>>
>>3) Could someone give me references of similar projects that have been made
>>? Any reference on the use of the metaframe with satellite communication
>>(TDMA with DLT) ?
>>
>>I will appreciate any help ...
>>
>>Thanks in advance.
>>
>>
>>
>>
>>------- End of Forwarded Message
>>
>>
>
>Dan Shell
>CISCO Systems Engineer Federal
>Advanced Technologies
>Wireless and Satellite
>216 643 2422
>
>
>

     "The quality of a network is not based on complexity but
     on it's  simplicity and adherence to solid fundamentals."

=====================================================================
| Greg Otto                            e-mail:  [email-masked]        |
| Network Engineer                     voice:   (713) 995-4778x102  |
| New Frontier Consulting, Inc.        fax:     (281) 754-9170      |
| Houston, Texas                       www:     http://www.newf.com |
=====================================================================

---

From: "Gregory D. Otto" <[email-masked]>
Date: Wed, 10 Nov 1999 16:12:13 -0600

I also just got done doing a week long study on CIFS over satellite and
found that at about 150 ms RTT, performance degradates drastically
regardless of bandwidth.  TCP window sizes make little difference.  It is a
problem in block size negotiation for CIFS and the use of only one
outstanding request at any one time.  There is also a patch needed for NT
servers to prevent premature TCP timeout retransmissions which prevent the
TCP congestion window from ever becoming stable.

Greg

At 04:52 PM 11/10/99 -0500, Graham Fennie wrote:
>Greg,
>
>Absolutely correct... Since MetaFrame simulates a 'realtime' client /
server environment it is *extremely* sensitive to latency - although its
bandwidth requirements are fairly low (33-56 kbits / sec).
>
>Also, MetaFrame should be avoided in graphics intensive applications such
as Photoshop, PageMaker, etc. The increased graphics requirements of these
applications can quickly consume 192+ kbits or more.

---

From: Henrik Jonson <[email-masked]>
Date: Wed, 10 Nov 1999 15:00:21 -0800

Please take me off this damn mailing list !
I've tried everthing I've been told and nothing works !
[email-masked] or/and
[email-masked]

---

From: "Alireza Abaye" <[email-masked]>
Date: Thu, 11 Nov 1999 10:22:37 -0600

I have the same problem. Please remove my name from the list too. Thank you.

[email-masked]
[email-masked]

> -----Original Message-----
> From:	Henrik Jonson [SMTP:[email-masked]]
> Sent:	Wednesday, November 10, 1999 6:00 PM
> To:	[email-masked]
> Cc:	[email-masked]
> Subject:	RE: [email-masked]: Help in Satellite comunications
>