Subject: Re: packet loss probability

From: [email-masked]
Date: Wed, 17 Nov 1999 12:40:45 +0530

Hi,

Assume packet size = p bits. (note that p is only useful payload)
Assume bit error rate = b (after taking into account the advantage gained by
FEC, etc.)

PER = 1 - (1 - b)^^p (^^ Indicates exponential)(superscript:  )
For small b, this comes to approximately bp.

Is this reasonable?

Regards,
Abheek

Giacomo Morabito <[email-masked]> on 11/17/99 03:18:56 AM

Please respond to [email-masked]

To:   [email-masked]
cc:    (bcc: Abheek Saha/HSS)

Subject:  packet loss probability

Please, I have a question.

What are the typical values of the "packet loss probabilities"
due to link errors in satellite links, or, alternatively,
what are the values of the packet loss probability corresponding
to a BER going from 10^{-9} to 10^{-4}?

I hope that someone can help me.

Best regards,
Giacomo

-----------------------
Dr. Giacomo Morabito
Research Engineer
Broadband & Wireless Networking Laboratory
School of Electrical and Computer Engineering
Georgia Institute of Technology
Atlanta, GA 30332

Tel.: (404) 894-6616
Fax.: (404) 894-7883
E_mail: [email-masked]
http://www.ee.gatech.edu/~giacomo

---

From: Lloyd Wood <[email-masked]>
Date: Wed, 17 Nov 1999 12:17:49 +0000 (GMT)

> For small b, this comes to approximately bp.

Only if your ACKs are the same size as your packets...

TCP's performance will be heavily affected by loss at the higher-error
end of the range, and your formula doesn't reflect that.

Some of the discussion in the PILC archives (which most of this list
is subscribed to anyway) covers this in more detail.

L.

<[email-masked]>PGP<http://www.ee.surrey.ac.uk/Personal/L.Wood/>

---

From: "Dr. Andreas Alef" <[email-masked]>
Date: Thu, 18 Nov 1999 10:47:22 +0100

Dear tcpsat community,

Scientific Consulting, the consultancy I am with, is engaged in several
satellites projects.

In the article "...tcpsat-res-issues-12.txt" I found an excellent summary of
ongoing issues.

Some additional questions:

-Do you know, to what extent the suggested mitigations are implemented?
-How do you estimate the timeline for implementations?
-Does anyone know how current implementations for tcpsat are operated (e.g.
skydsl in Germany, DirecPC etc.)
-Is ther any estimation concerning effectiveness figures of all these
mitigations outlined in the above mentioned article?

Friendly regards from Germany,

Dr. Andreas Alef
Scientifc Consulting
Mathias-Brueggen-Straße 87-89
50829 Koeln
Germany
+49 (0) 221 59700 52