Subject: Re: RFC1323 Window scale behavior

From: "JTEOIETF" <[email-masked]>
Date: Wed, 17 Jan 2001 15:29:14 -0500

Both client and server are configured to operate with window scaling...Tcp1323opts = 1, tcpwindowsize = 524 k, etc. During some SYN, ACK/SYN handshaking sequences, the scaling option is on and at the correct scale factor.  Other times it is not...especially when I need it, such as file transfer.  Any other thoughts...
thanks
Jim
  -----Original Message-----
  From: gabriel olariu <[email-masked]>
  To: JTEOIETF <[email-masked]>; [email-masked] <[email-masked]>
  Date: Wednesday, January 17, 2001 2:40 PM
  Subject: Re: RFC1323 Window scale behavior

  You need to verify that both server and client have the stack configured with Tcp1323Opts=1.
  Also, the window sizes need to exceed 64K for large windows to kick in.
  Look at the TCP options exchanged in the SYN sequence and you'll see who's doing 
  large windows and who's not.
  For the registry parameters that need to be set, consult "Microsoft Windows 2000 Server" white paper.
  Only Win98/98SE/ME/2000 support large windows. Win98 has a documented bug.
  gabriel
    ----- Original Message ----- 
    From: JTEOIETF 
    To: [email-masked] 
    Sent: Wednesday, January 17, 2001 1:46 PM
    Subject: RFC1323 Window scale behavior

    Hello,

    I have been performing simulations in preparation of an upcoming on-orbit test of TCP applications over satellite.  The problem is the RFC 1323 window scaling option does not always operate as expected.  For example, capturing the packets for an FTP session reveals the scaling option is on during the initial session setup (I.e. login, cd-ing, etc) but when a file transfer is requested and another session opens, the window scale options are not present, therefore limiting to a 64k window.  I have a roundtrip delay upwards of 2500 ms and bandwidth of 1.544 Mbps.  Any input to this behavior is appreciated.

    Equipment:

    -IBM ThinkPad 600 w/ Windows 2000 sp1
    -Cisco 2611 routers, using high speed serial ports on WAN side
    -KIV-19 crypto (capable of 13 Mbps)
    -Adtech SX12 link simulator

    Thank you,

    Jim

---

From: William D Ivancic <[email-masked]>
Date: Wed, 17 Jan 2001 15:51:23 -0500

I seem to remember hearing that some FTP applications do not call the large
windows options in TCP.  I suggest checking you FTP application to ensure it
utilizes large windows.  If not, even though large windows is setup on your
machine, the FTP application does not utilize it.  I hope I'm not giving you
false information.  Good Luck.

Will Ivancic

At 03:29 PM 1/17/01 -0500, JTEOIETF wrote: 
>
> Both client and server are configured to operate with window
> scaling...Tcp1323opts = 1, tcpwindowsize = 524 k, etc. During some SYN,
> ACK/SYN handshaking sequences, the scaling option is on and at the correct
> scale factor.  Other times it is not...especially when I need it, such as
> file transfer.  Any other thoughts...
> thanks
> Jim

---

From: Eric Travis <[email-masked]>
Date: Wed, 17 Jan 2001 16:23:00 -0500 (EST)

Most likely your FTP client (and or server) is
explicitly setting the send/receive buffers
thus overriding the default values you tweaked.
Do you have access to an alternative FTP client
and/or server?

Eric

On Wed, 17 Jan 2001, JTEOIETF wrote:

> Both client and server are configured to operate with
> window scaling...Tcp1323opts = 1, tcpwindowsize = 524 k,
> etc. During some  SYN, ACK/SYN handshaking sequences,
> the scaling option is on and at the correct scale factor.
> Other times it is not...especially when I need it, such
> as file transfer.  Any other thoughts...