Subject: Re: RFC1323 Window scale behavior

From: Markus Buchhorn <[email-masked]>
Date: Thu, 18 Jan 2001 11:08:05 +1100

The Windows (NT4) ftp client has an option (-w) to set the buffer size for
transfers. This seems to work (it significantly increased performance on
our ATM network) (although on NT4 we can't go past 64k, of course).

C:\>ftp -?
  [...]
  -w:buffersize  Overrides the default transfer buffer size of 4096.

Why, oh why, do they do this....

You haven't said anywhere how you are doing file transfers? ftp, smb, http,
... ?

Cheers,
	Markus

At 16:23 17/01/01 -0500, Eric Travis wrote:
>
>Most likely your FTP client (and or server) is
>explicitly setting the send/receive buffers
>thus overriding the default values you tweaked.
>Do you have access to an alternative FTP client
>and/or server?
>
>Eric
>
>
>
>On Wed, 17 Jan 2001, JTEOIETF wrote:
>
>> Both client and server are configured to operate with
>> window scaling...Tcp1323opts = 1, tcpwindowsize = 524 k,
>> etc. During some  SYN, ACK/SYN handshaking sequences,
>> the scaling option is on and at the correct scale factor.
>> Other times it is not...especially when I need it, such
>> as file transfer.  Any other thoughts...
>
>
>
Markus Buchhorn, Faculty of Engineering and IT,          | Ph: +61 2 61258810
email: [email-masked], mail: CSIT Bldg #108  |Fax: +61 2 61250010
Australian National University, Canberra 0200, Australia |Mobile: 0417 281429
               ** Note new address and phone numbers **

---

From: "joe black" <[email-masked]>
Date: Wed, 17 Jan 2001 19:51:07 -0800

Hi Marcus,

 I'm from Uni Science M'sia. I have a few questions:

1) I would like to know if there is any tool to determine the TCP window size in Linux Redhat 6.2. (kernel 2.2.16)?
Or can I know the default window size? Also, is there any tool that can be used to control the window size??

2) If I enable TCP_WINDOW_SCALING, how can I know how big is the window size? 

 If any of you can help, I would be very grateful.

Rgds,
joe

-----Original Message-----
From:    Markus Buchhorn [email-masked]
Sent:    Thu, 18 Jan 2001 11:08:05 +1100
To:      [email-masked], [email-masked]
CC:      [email-masked]
Subject: Re: RFC1323 Window scale behavior

C:\>ftp -?
  [...]

Cheers,
	Markus

___________________________________________________________________________
Visit http://www.visto.com/info, your free web-based communications center.
Visto.com. Life on the Dot.

---

From: Saad Biaz <[email-masked]>
Date: Thu, 18 Jan 2001 08:32:23 -0000

I wonder if Linux has a tool similar to trpt that we find under Free BSD. With trpt, you would be able to monitor the window size. 
Another way would be to do a very simple hack on the tcp code.

Hope this helps.

-----Original Message-----
From:	joe black [SMTP:[email-masked]]
Sent:	jeudi 18 janvier 2001 03:51
To:	[email-masked]; [email-masked]; [email-masked]
Cc:	[email-masked]
Subject:	Re: RFC1323 Window scale behavior

Hi Marcus,

Rgds,
joe

-----Original Message-----
From:    Markus Buchhorn [email-masked]
Sent:    Thu, 18 Jan 2001 11:08:05 +1100
To:      [email-masked], [email-masked]
CC:      [email-masked]
Subject: Re: RFC1323 Window scale behavior

C:\>ftp -?
  [...]

Cheers,
	Markus

---

From: "Mike Jagdis" <[email-masked]>
Date: Thu, 18 Jan 2001 11:18:33 -0000

> 1) I would like to know if there is any tool to determine the TCP 
> window size in Linux Redhat 6.2. (kernel 2.2.16)?
> Or can I know the default window size? Also, is there any tool 
> that can be used to control the window size??

You can get/set the default and maximum (that an application can
set via setsockopt() syscalls) through the proc files:
/proc/sys/net/core/[rw]mem_{default,max}.

  You can turn window scaling on and off through, um...,
/proc/sys/net/ipv4/tcp_window_scaling.

  If you want to know what is happening on the wire you need to
watch packets - good old tcpdump (or iptraf for those who need
something more graphical).

				Mike

---

From: "Megabert" <[email-masked]>
Date: Thu, 18 Jan 2001 14:02:50 +0100

The two FTP clients that are installed on my PC, namely CuteFTP and WS_FTP
both have settable options for the receive and xmit network buffer size. The
default sizes in Cute are 4096, in WS_FTP the xmit size only is 512 bytes.

Eric