Subject: RFC1323 Window scale behavior

From: "JTEOIETF" <[email-masked]>
Date: Wed, 17 Jan 2001 13:46:03 -0500

Hello,

I have been performing simulations in preparation of an upcoming on-orbit test of TCP applications over satellite.  The problem is the RFC 1323 window scaling option does not always operate as expected.  For example, capturing the packets for an FTP session reveals the scaling option is on during the initial session setup (I.e. login, cd-ing, etc) but when a file transfer is requested and another session opens, the window scale options are not present, therefore limiting to a 64k window.  I have a roundtrip delay upwards of 2500 ms and bandwidth of 1.544 Mbps.  Any input to this behavior is appreciated.

Equipment:

-IBM ThinkPad 600 w/ Windows 2000 sp1
-Cisco 2611 routers, using high speed serial ports on WAN side
-KIV-19 crypto (capable of 13 Mbps)
-Adtech SX12 link simulator

Thank you,

Jim

---

From: "gabriel olariu" <[email-masked]>
Date: Wed, 17 Jan 2001 14:40:17 -0500

You need to verify that both server and client have the stack configured with Tcp1323Opts=1.
Also, the window sizes need to exceed 64K for large windows to kick in.
Look at the TCP options exchanged in the SYN sequence and you'll see who's doing 
large windows and who's not.
For the registry parameters that need to be set, consult "Microsoft Windows 2000 Server" white paper.
Only Win98/98SE/ME/2000 support large windows. Win98 has a documented bug.
gabriel
  ----- Original Message ----- 
  From: JTEOIETF 
  To: [email-masked] 
  Sent: Wednesday, January 17, 2001 1:46 PM
  Subject: RFC1323 Window scale behavior

  Hello,

  Equipment:

  Thank you,
   
  Jim

---

From: "gabriel olariu" <[email-masked]>
Date: Wed, 17 Jan 2001 16:53:36 -0500

Could you please post the name of the ftp client/server you're using (if possible).
I was wrong saying that the app does not interfere. It can definitely override the 
registry settings, as noted by other persons earlier.
This looks to be your case.
Thanks,
gabriel
  ----- Original Message ----- 
  From: JTEOIETF 
  To: [email-masked] 
  Sent: Wednesday, January 17, 2001 1:46 PM
  Subject: RFC1323 Window scale behavior

  Hello,

  Equipment:

  Thank you,
   
  Jim