Subject: Re: spoofing standard??

From: Anil Agarwal <[email-masked]>
Date: Mon, 15 Jan 2001 18:31:16 -0500 (EST)

On Jan 15, 2001, Manish Karir wrote:

>I think there is probably enough support on this list and real
>implementation experience to generate some sort of a spoofing
>standard?
>
>if nothing else an informational document which summarizes the
>most "correct" way of implementing this.  I know there have been
>papers and descriptions of this before, but something which has the
>blessings of more than just the authors would be quite useful...that way
>we would atleast have a common base to argue about :)
>
>does anyone else agree on the need for such a document??
>
>manish karir

I agree wholeheartedly.

It would certainly provide value to the Internet to have
"robust" spoofing implementations, even though their use may not be
encouraged, except for special environments, such as satellite or wireless
networks.

Anil Agarwal
LMGT
22300 COMSAT Drive
Clarksburg, MD 20871
301-428-4655

---

From: Alhussein Abouzeid <[email-masked]>
Date: Mon, 15 Jan 2001 20:35:33 -0800 (PST)

> >does anyone else agree on the need for such a document??

Same Here.

-Hussein.

---

From: Mingyan Liu <[email-masked]>
Date: Tue, 16 Jan 2001 10:55:17 -0500 (EST)

As a matter of fact spoofing is not only widely used 
in satellite systems but also frequently proposed to 
improve TCP performance over wireless mobile links. 

I think some form of standard on spoofing (or similar 
operation that violates the end-to-end semantics) 
would be very helpful. 

-mingyan 

P.S. I got an email from a friend asking 
"Can anyone on that list name an ISP that does not 
implement caching?  Although caches are not necessarily 
spoofers I would bet that the TCP connection from the 
cache to the origin server does not resemble the 
connection from the client to the cache. So, unless I 
am missing something, it is nearly impossible to have 
true end to end TCP with HTTP transactions. "
I post it here for your comments. 

> encouraged, except for special environments, such as satellite or wireless

========================
Mingyan Liu
Assistant Professor
EECS Department, Rm 4211 EECS
University of Michigan
Ann Arbor, MI 48109-2122
Tel:(734)764-9546