Subject: CRC32 Or Checksum????

From: Daniel Pradeep <[email-masked]>
Date: Fri, 27 Apr 2001 19:38:00 -0700

I would like to know whether the DSM-CC packet has Checksum or CRC32? How do
I figure this out?? Which field in the section header should I look into to
know that the section has Checksum and not CRC32 and vice versa???

Thanks
Daniel

---

From: Colin Paul Gloster <[email-masked]>
Date: Mon, 30 Apr 2001 08:17:54 +0100 (BST)

CRC32 is preferred but the checksum is there to be intended
to be used in cases where the systems have difficulty in
calculating a CRC_32. Your DSM-CC checksum or CRC32 dilemma
is solved as follows. With the section_syntax_indicator as
zero use checksum, otherwise if one use CRC_32.
Colin Paul Gloster

On Fri, 27 Apr 2001, Daniel Pradeep <[email-masked]> wrote:
"I would like to know whether the DSM-CC packet has Checksum or CRC32? How do
I figure this out?? Which field in the section header should I look into to
know that the section has Checksum and not CRC32 and vice versa???

Thanks
Daniel"