Subject: [teas-3272bis-design-team] Git primer (was: Draft DT slides for TEAS meeting in Prague)

From: <[email-masked]>
Date: Tue, 19 Mar 2019 13:30:57 +0000

Hi Acee, Lou,

me too - since I grew up with rcs and cvs, and didn't do any kind of developing based on git yet, I could also use a quick primer.

BTW: do we need some kind of agreement for how to use branches, merges etc?

Best regards, Martin

P.S.: yes, I do use a Mac. FreeBSD, Linux and Windows as well, but the Mac is the one for writing.

> -----Ursprüngliche Nachricht-----
> Von: Teas-3272bis-design-team <teas-3272bis-design-team-
> [email-masked]> Im Auftrag von Acee Lindem (acee)
> Gesendet: Samstag, 16. März 2019 13:29
> An: Loa Andersson <[email-masked]>; [email-masked]; teas-3272bis-design-
> [email-masked]
> Betreff: Re: [teas-3272bis-design-team] Draft DT slides for TEAS meeting in
> Prague
> 
> Hi Loa,
> 
> I can help you with GitHub. Do you use Mac?
> 
> Thanks,
> Acee
> 
> On 3/16/19, 1:30 AM, "Teas-3272bis-design-team on behalf of Loa
> Andersson" <[email-masked] on behalf of
> [email-masked]> wrote:
> 
>     Adrian,
> 
>     nice slides! They work for we. The only thing I can think of is that
>     the references in 3272 were very important and that we will update (and
>     possibly add) references.
> 
>     /Loa
> 
>     If someone can take 30 min in Prague to help me get started on GitHub I
>     will try to do a first spin on updating the old references.
> 
>     - find obsoletes and replaces with the new doc
>     - find updates and include them (when appropriate)
>     - fin "work in progress" that are now RFCs
>     - check if all the non-IETF document are still available at the
>        addresses given
> 
>     /Loa
> 
>     On 2019-03-16 02:20, Adrian Farrel wrote:
>     > Any thoughts?
>     >
>     > Adrian
>     >
>     >
> 
>     --
> 
> 
>     Loa Andersson                        email: [email-masked]
>     Senior MPLS Expert
>     Bronze Dragon Consulting             phone: +46 739 81 21 64
> 
>     --
>     Teas-3272bis-design-team mailing list
>     [email-masked]
>     https://www.ietf.org/mailman/listinfo/teas-3272bis-design-team
> 
> 
> --
> Teas-3272bis-design-team mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas-3272bis-design-team

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 19 Mar 2019 13:41:15 +0000

Hi Martin, 

On 3/19/19, 9:31 AM, "[email-masked]" <[email-masked]> wrote:

    Hi Acee, Lou,

Although, I've never worked on a draft with this many authors. In the past, we've just allowed collaborators to "git pull" (to assure you have the latest), edit, "git add", "git commit", and "git push". We could use branches and pull requests where an editor (Adrian?) does the merge contingent on approval. 

Thanks,
Acee
    
    Best regards, Martin

---

From: Tarek Saad <[email-masked]>
Date: Tue, 19 Mar 2019 13:43:43 +0000

FWIW, the following 2 apps are useful if you opt to not use CLI. There should be variants for MAC and Windows.
https://desktop.github.com/
https://www.sourcetreeapp.com/

Regards,
Tarek

On 3/19/19, 9:31 AM, "Teas-3272bis-design-team on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Acee, Lou,

    
    Best regards, Martin

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 19 Mar 2019 13:46:26 +0000

Hi Tarek, 
Do you use Git Desktop? I used it a few years back and got fed up with not knowing what it was doing under the covers. 
Thanks,
Acee

On 3/19/19, 9:44 AM, "Tarek Saad" <[email-masked]> wrote:

    Regards,
    Tarek

        Hi Acee, Lou,

        
        Best regards, Martin

---

From: Tarek Saad <[email-masked]>
Date: Tue, 19 Mar 2019 13:52:07 +0000

Hi Acee,

I use CLI and SourceTree when I want it to get fancier. I recommend SourceTree as it integrates with github and bitbucket too.

Regards,
Tarek

On 3/19/19, 9:46 AM, "Acee Lindem (acee)" <[email-masked]> wrote:

    Hi Tarek, 

        
        Regards,
        Tarek

            Hi Acee, Lou,

            
            Best regards, Martin

---

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 19 Mar 2019 13:57:59 +0000

Are we going to write a draft or a new operative system? 😃

I don't think more than 2 people will work on each paragraph, and then we'll all do a review, right? Can't we assign paragraphs to those people and have a person putting all the contributions together?

Daniele  

-----Original Message-----
From: Teas-3272bis-design-team <[email-masked]> On Behalf Of Tarek Saad
Sent: den 19 mars 2019 14:52
To: Acee Lindem (acee) <[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [teas-3272bis-design-team] Git primer (was: Draft DT slides for TEAS meeting in Prague)

Hi Acee,

Regards,
Tarek

    Hi Tarek, 

        
        Regards,
        Tarek

            Hi Acee, Lou,

            
            Best regards, Martin

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 19 Mar 2019 14:07:05 +0000

Yes - let's start with the simple work flow (pull, edit, add, commit, push) and revisit if it gets out of control.
Thanks,
Acee

On 3/19/19, 9:58 AM, "Teas-3272bis-design-team on behalf of Daniele Ceccarelli" <[email-masked] on behalf of [email-masked]> wrote:

    
    Daniele  
    
    -----Original Message-----
    From: Teas-3272bis-design-team <[email-masked]> On Behalf Of Tarek Saad
    Sent: den 19 mars 2019 14:52
    To: Acee Lindem (acee) <[email-masked]>; [email-masked]; [email-masked]
    Cc: [email-masked]
    Subject: Re: [teas-3272bis-design-team] Git primer (was: Draft DT slides for TEAS meeting in Prague)
    
    Hi Acee,

    Regards,
    Tarek

        Hi Tarek, 

            
            Regards,
            Tarek

                Hi Acee, Lou,

                
                Best regards, Martin

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 22 Mar 2019 19:41:21 -0700

BTW - there’s github tools meeting on Sunday.

Cheers,
Jeff

> On Mar 19, 2019, at 7:07 AM, Acee Lindem (acee) <[email-masked]> wrote:
>