Subject: [Teas-ns-dt] Getting started

From: Jari Arkko <[email-masked]>
Date: Sun, 22 Sep 2019 14:07:58 +0000

All right everyone, we have setup a design team, perhaps we can get started on the actual work as well!

I thought that for the first call we'd first go around the team, and see what goal people have (everyone should prepare something to say here). We will also talk about scope, as that has been requested as a key initial deliverable. If you can, please post or bring a suggestion on what you'd like to see as the scope. But first, we need to agree on logistics.

Agenda for the first call:

* Way of working, logistics, etc
* Expectations
* Discussion of scope

Other suggestions, changes, additions?

For the logistics, I'd suggest we have a weekly, short call to check status but work mostly on list otherwise. The call is needed though as a deadline for all of us who are busy on many fronts; I'd like to make weekly progress. The first call will last an hour, but we can possibly get by half an hour on subsequent calls if there's enough progress otherwise. Other thoughts on arrangements? Feel free to comment and send suggestions, that is always appreciated!

Here are some potential times for a call, starting in the coming week. Please respond to the doodle:

https://doodle.com/poll/m5mqcf6zz2pm53f2

Jari

----

TEAS Network Slicing Design Team

The topic of “Slicing” has received significant industry attention due to its  role in 5G networks.  General background on slicing can be found in [1], but it is a broad topic that covers many different aspects from business roles to services and networks.

Within the IETF the discussion has largely focused on the narrower topics of “Network Slicing” and “Service Chaining”. [2] provides a sample list of related individual contributions. Much of the IETF discussion has focused on how the combination of VPN and TE technologies can be used to deliver Network Slices. The TEAS Network Slicing Design Team (NSDT) is being formed to develop a framework for providing Network Slicing using IETF TE technologies. The expectation is for IETF technologies such as IP, MPLS and GMPLS, to  be used to create specific, isolated, and managed network instances. The use of such technology in networks and other SDOs is up to others; this work does not imply that the IETF specifies how slicing in any particular setting should be done.

The primary goal of the design team is to determine how existing technologies can be used, but it is possible that some extensions to those technologies are needed. If such extensions relate to technology from another working group, any eventual work belongs to that group. The reuse of definitions and technologies developed by other SDOs is also in scope, although extensions to such will be done in the appropriate SDO. An important early deliverable to the working group from the design team will be a proposed refinement of what is in-scope and what is out-of-scope for the WG on this topic.

The design team will have the flexibility to decide on how best to develop, document and present its work. The design team will provide regular updates and reports to the TEAS working group.  It will present an update on their status and plans at IETF 106 (Singapore) - which will hopefully include an initial discussion on scope.  For  IETF 107 (Vancouver) the goal for the design team is an initial design team framework, and possibly draft, in time for discussion at the meeting.  A stable draft is targeted for discussion at IETF 108. Note authorship of design team draft(s) will be based on contribution to the work, not membership in the design team. Once the draft is accepted as a working group document, it will progress per TEAS working group normal process.

The design team mailing list has been set up with the membership of this list limited to the design team and the chairs, but its archive is open and any may send to this list.  Design team meetings will be announced on the list and open to all.  The specific workings, including meeting schedules, of the design team are the discretion of the team.

The mailing list for the design team is: [email-masked]
The archive can be found at: https://mailarchive.ietf.org/arch/browse/teas-ns-dt/

The members of the design team are:
    Aijun Wang <[email-masked]>
    Belo, Sergio <[email-masked]>
    Dong Jie (Jimmy)  <[email-masked]>
    Eric Gray <[email-masked]>
    Geng Xuesong <[email-masked]>
    Jari Arkko <[email-masked]>                 [Lead]
    Jeff Tantsura <[email-masked]>
    John E Drake <[email-masked]>
    Luis M. Contreras <[email-masked]>
    Rakesh Gandhi  <[email-masked]>
    Ran Chen <[email-masked]>
    Ricard Vilalta <[email-masked]>
    Rokui, Reza <[email-masked]>
    Ron Bonica <[email-masked]>
    Tomonobu Niwa <[email-masked]>
    Xufeng Liu <[email-masked]>

---

From: "Aijun Wang" <[email-masked]>
Date: Mon, 23 Sep 2019 17:02:13 +0800

Hi, Jari:

Thanks for your efforts.

For the scope of discussion, I have the following considerations:

1.Will our work focus only on the E2E QoS assurance (Separation/Bandwidth/Delay/Jitter etc. ) in IP/MPLS/Optical network? These are the strong points of our team members.

2.Can we focus mainly on the candidate technologies/proposals to fulfill the requirements of the NS?  We can illustrates the pros/cons of these technologies to accomplish the NS aim respectively.

3.The NS solution should cover intra- and inter-domain that under the administrator of one operator.

4.Finally We can give some recommendations for the implementation of NS in IP/MPLS/Optical network, or the coordination between different layers accordingly.

If the above points are accepted, we can first define the structures of our initial draft for network slicing in IP/MPLS/Optical network.

Best Regards.

Aijun Wang

China Telecom

发件人: [email-masked] [mailto:[email-masked]] 代表 Jari Arkko
发送时间: 2019年9月22日 22:08
收件人: [email-masked]
主题: [Teas-ns-dt] Getting started

* Expectations

* Discussion of scope

Jari

----

---

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Mon, 23 Sep 2019 17:11:47 +0000

Hi Jari et al,

Thanks for taking a leading on this activity.

These are the topics that I think should be covered by 5G Design Team:

  *   Clearly distinguish between 5G E2E network slicing and 5G transport slicing. The role of IETF 5G Design Team will be the latter one, i.e. 5G Transport Slices.
  *   We need to have liaisons with BBF, 3GPP and MEF to make sure they are aware of our 5G transport slice activities. Those DSOs will address other aspects of the 5G E2E network slicing, namely “5G RAN Slice” and “5G Core Slice”. This way, a complete solution will be addressed for 5G E2E network slicing.
  *   We have to address how IETF work on 5G will complement existing IETF works (e.g. work on ACTN, L3SM, L2SM etc) or future IETF works. To this end, the interface (6) shown below needs to be addressed at IETF. Please see the presentation for more details https://datatracker.ietf.org/meeting/105/materials/slides-105-teas-sessa-03-5g-transport-slice-connectivity-interface-00

Looking forward to working with 5G desing team.

Cheers,

Reza Rokui

From: Teas-ns-dt <[email-masked]> on behalf of Aijun Wang <[email-masked]>
Date: Monday, September 23, 2019 at 5:02 AM
To: 'Jari Arkko' <jari.arkko=[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [Teas-ns-dt] 答复: Getting started

Hi, Jari:

Thanks for your efforts.

Best Regards.

Aijun Wang
China Telecom

Jari

----

The mailing list for the design team is: [email-masked]<mailto:[email-masked]>
The archive can be found at: https://mailarchive.ietf.org/arch/browse/teas-ns-dt/

The members of the design team are:
    Aijun Wang <[email-masked]<mailto:[email-masked]>>
    Belo, Sergio <[email-masked]<mailto:[email-masked]>>
    Dong Jie (Jimmy)  <[email-masked]<mailto:[email-masked]>>
    Eric Gray <[email-masked]<mailto:[email-masked]>>
    Geng Xuesong <[email-masked]<mailto:[email-masked]>>
    Jari Arkko <[email-masked]<mailto:[email-masked]>>                 [Lead]
    Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
    John E Drake <[email-masked]<mailto:[email-masked]>>
    Luis M. Contreras <[email-masked]<mailto:[email-masked]>>
    Rakesh Gandhi  <[email-masked]<mailto:[email-masked]>>
    Ran Chen <[email-masked]<mailto:[email-masked]>>
    Ricard Vilalta <[email-masked]<mailto:[email-masked]>>
    Rokui, Reza <[email-masked]<mailto:[email-masked]>>
    Ron Bonica <[email-masked]<mailto:[email-masked]>>
    Tomonobu Niwa <[email-masked]<mailto:[email-masked]>>
    Xufeng Liu <[email-masked]<mailto:[email-masked]>>

---

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Tue, 24 Sep 2019 13:14:29 +0000

Dear Jari , all

Thanks a lot for the effort to guide the DT.

I would avoid to repeat what Reza already said below but I share this proposed skeleton of the activity.
In particular having work in ACTN and VN , I’m very interested to understand how far what already defined  in this context is with respect 5G Transport Slice requirement .

Cheers
Sergio

From: Teas-ns-dt <[email-masked]> On Behalf Of Rokui, Reza (Nokia - CA/Ottawa)
Sent: Monday, September 23, 2019 7:12 PM
To: Aijun Wang <[email-masked]>; 'Jari Arkko' <jari.arkko=[email-masked]>; [email-masked]
Cc: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Subject: Re: [Teas-ns-dt] 答复: Getting started

Hi Jari et al,

Cheers,

Reza Rokui

From: Teas-ns-dt <[email-masked]<mailto:[email-masked]>> on behalf of Aijun Wang <[email-masked]<mailto:[email-masked]>>
Date: Monday, September 23, 2019 at 5:02 AM
To: 'Jari Arkko' <jari.arkko=[email-masked]<mailto:jari.arkko=[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Teas-ns-dt] 答复: Getting started

Hi, Jari:

Thanks for your efforts.

Best Regards.

Aijun Wang
China Telecom

发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] 代表 Jari Arkko
发送时间: 2019年9月22日 22:08
收件人: [email-masked]<mailto:[email-masked]>
主题: [Teas-ns-dt] Getting started

Jari

----

---

From: Eric Gray <[email-masked]>
Date: Fri, 27 Sep 2019 17:12:09 +0000

Reza,

Some clarifications for potential confirmation:

  1.  In your second bullet below, I assume you meant SDO, as opposed to DSO; it would be good to point out (or remind folks) that this bullet might be misleading as grouping “BBF, 3GPP and MEF” together and then associating these SDOs with addressing “other aspects of the 5G E2E network slicing” specifically providing “5G RAN Slice” and “5G Core Slice” as examples;  the issue is (of course) that this is misleading in at least the following aspects –
     *   BBF has as its main concern exactly the same “5G Transport” aspects of Network Slicing (as opposed to “other aspects”) – but from the perspective of exactly how these would be supported using specific technologies and a selected subset of the capabilities that might be defined in our IETF work
     *   MEF also concerns itself with transport aspects – both from a perspective of providing transport services for mobile networks (which will include at least some high-level aspects of network slicing) and from a perspective of orchestration of network slicing services
     *   As a result, the work in the BBF and MEF – unlike that in 3GPP – includes a substantial overlap with the work we undertake in this project.

Otherwise, while we have had related discussions in BBF about the practicality of having a single interface to Transport Network Slicing, the rest of what you outline below makes sense.

--
Eric

Sent: Monday, September 23, 2019 1:12 PM

Hi Jari et al,

Cheers,

Reza Rokui

Hi, Jari:

Thanks for your efforts.

Best Regards.

Aijun Wang
China Telecom

Jari

----