Subject: Re: [Teas-ns-dt] 答复: Definition of transport network slicing

From: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>
Date: Thu, 17 Oct 2019 03:01:23 +0000

Hi Aijun,

The isolation of transport slices shall be possible and it depends on the use-case and customer’s request (aka tenant).

For example let’s assume the customer (aka Tenant) City Of New York would like to have an E2E network slice to connect all the CCTVs in the buses across the city. In this case it asks the MNO (e.g. AT&T) to create an e2e network slice which in turn results in creation of one or more transport slices (in addition to RAN Slice and Core slice). If for example customer City of NY is gold customer for AT&T, it will decide to have dedicated transport slices to make sure the SLAs are met.
It is also possible for AT&T to share one or more transport slices for a few customers.

In summary, shared or dedicated transport slices is up to the MNO which in turn depends on level of customers (i.e. customer is Gold, Silver etc) and customers’ use-cases. Not all the use cases need strict SLA.

Cheers,
Reza

From: Aijun Wang <[email-masked]>
Date: Thursday, October 17, 2019 at 6:40 AM
To: Reza Rokui <[email-masked]>, "'Dongjie (Jimmy)'" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: 答复: [Teas-ns-dt] Definition of transport network slicing

Hi, Reza,Jie and all:
For the transport, do we need to emphasize the isolation? Is any solution that can meet the application’ SLA  acceptable?
From the 5G document, the isolation concept refer mainly to its functional entities.

Best Regards.

Aijun Wang
China Telecom

发件人: [email-masked] [mailto:[email-masked]] 代表 Rokui, Reza (Nokia - CA/Ottawa)
发送时间: 2019年10月16日 21:57
收件人: Dongjie (Jimmy); [email-masked]
抄送: Rokui, Reza (Nokia - CA/Ottawa)
主题: Re: [Teas-ns-dt] Definition of transport network slicing

Hi Jie and all,

Your definition is correct. However, the following is my view. Please add comments.

In general a transport slice has a definition and a realization (aka implementation). The transport slice definition is whatever Jie mentioned below and I rephrase it here. i.e.

  *   Transport slice definition: A set of connections each with appropriate isolation and specific Service Level Agreement (SLA).

However an transport slice has an implementation (or realization) as well. To clarify, let’s have an example.
The following picture shows the most complex 5G network (i.e. Cloud RAN where it contains fronthaul, midhaul and backhaul networks. In this picture there are 4 different transport slices for a single E2E network slice.

Each of transport slices 1 to 4 has an implementation which potentially has different technologies and different techniques. For example, the transport slice 3 can be realized on IP network using L3VPN or VPN+ or any other techniques to satisfy certain SLAs. The fact is that we can realize the transport slice 3 using different techniques but the regardless of that, the definition of the transport slice 3 does not change (which is connectivity of CUs to Core network).

Another example is the transport slice 2 in midhaul which its definition is connectivity between DUs to CUs. In majority of  deployments, this transport slice will be realized using PON technique or IP VPNs. Again regardless of implementation, the transport slice 2’s definition is DUs to CUs connectivity with certain SLAs.

If needed, I can present a few slides during our call on Oct 17th.

Cheers,
Reza

From: Teas-ns-dt <[email-masked]<mailto:[email-masked]>> on behalf of "Dongjie (Jimmy)" <[email-masked]<mailto:[email-masked]>>
Date: Monday, October 14, 2019 at 5:57 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Teas-ns-dt] Definition of transport network slicing

Hi,

As one of the action points of the design team conference call in last week, we will discuss and give the definition of transport network slicing. Here I’d like to reference the definition in https://tools.ietf.org/html/draft-ietf-teas-enhanced-vpn-03 as the starting point:

“A transport network slice is a virtual (logical) network with a particular network topology and a set of shared or dedicated network resources, which are used to provide the network slice consumer with the required connectivity, appropriate isolation and specific Service Level Agreement (SLA). “

Please feel free to provide your comments and suggestions.

Best regards,
Jie

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Thu, 17 Oct 2019 13:22:41 +0000

Hi Reza, all,

Regarding: “shared or dedicated transport slices is up to the MNO which in turn depends on level of customers (i.e. customer is Gold, Silver etc) and customers’ use-cases. Not all the use cases need strict SLA” some thoughts come to my mind.

I think there is also a dependency on the level of control that could be granted to the customer/tenant for his/her slice, in the sense that if the customer requires control (e.g., reconfiguring of paths or modification of their characteristics) any action from this customer could collide with actions from others. In consequence, a separated slice would be required to be allocated. Different levels of control could be identified, and in base of that, maybe some customers could coexist on top of the same slice or not.

Best regards

Luis

De: Teas-ns-dt <[email-masked]> En nombre de Rokui, Reza (Nokia - CA/Ottawa)
Enviado el: jueves, 17 de octubre de 2019 0:01
Para: Aijun Wang <[email-masked]>; 'Dongjie (Jimmy)' <[email-masked]>; [email-masked]
CC: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>
Asunto: Re: [Teas-ns-dt] 答复: Definition of transport network slicing

Hi Aijun,

Cheers,
Reza

From: Aijun Wang <[email-masked]<mailto:[email-masked]>>
Date: Thursday, October 17, 2019 at 6:40 AM
To: Reza Rokui <[email-masked]<mailto:[email-masked]>>, "'Dongjie (Jimmy)'" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: 答复: [Teas-ns-dt] Definition of transport network slicing

Hi, Reza,Jie and all:

Best Regards.

Aijun Wang
China Telecom

发件人: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] 代表 Rokui, Reza (Nokia - CA/Ottawa)
发送时间: 2019年10月16日 21:57
收件人: Dongjie (Jimmy); [email-masked]<mailto:[email-masked]>
抄送: Rokui, Reza (Nokia - CA/Ottawa)
主题: Re: [Teas-ns-dt] Definition of transport network slicing

Hi Jie and all,

Cheers,
Reza

Hi,

Best regards,
Jie

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Kiran Makhijani <[email-masked]>
Date: Thu, 17 Oct 2019 13:59:43 +0000

Hello Luis,
any action from this customer could collide with actions from others.
^^^^
Did you mean with in the set of resources allocated to the customer or otherwise? If it is with in the allocated resources, there should not be collision. Otherwise, in my opinion customer interface should only be  allowed to request resource changes via the slice operator – which in turn will be able to figure out if such a request is possible..

--
Regards,
Kiran

From: Teas-ns-dt <[email-masked]> on behalf of LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Thursday, October 17, 2019 at 3:23 PM
To: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]>, Aijun Wang <[email-masked]>, "'Dongjie (Jimmy)'" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Teas-ns-dt] 答复: Definition of transport network slicing

Hi Reza, all,

Best regards

Luis

Hi Aijun,

Cheers,
Reza

Hi, Reza,Jie and all:

Best Regards.

Aijun Wang
China Telecom

Hi Jie and all,

Cheers,
Reza

Hi,

As one of the action points of the design team conference call in last week, we will discuss and give the definition of transport network slicing. Here I’d like to reference the definition in https://tools.ietf.org/html/draft-ietf-teas-enhanced-vpn-03<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-teas-enhanced-vpn-03&data=02%7C01%7Ckiranm%40futurewei.com%7Cdf51b7a5bdef4a7e930d08d753051e7a%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637069153824385941&sdata=gPj6StzF5QQ6LJCwaSvOTvOAHPFCXQ6y0t2Qi4naPDU%3D&reserved=0> as the starting point:

Best regards,
Jie

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Thu, 17 Oct 2019 22:27:29 +0000

Hi Kiran

Let me explain better, focusing on the idea of transport slice discussed today. In case the tenant would require control and management capabilities of the transport slice (e.g.,  setup / tear down a path, divert traffic from one path to another, etc) this would probably cannot be accommodated in the same slice with the connectivity for other tenants, since can be impacts or “interferences”. As you point out, maybe the slice operator could mediate on that operations, if the API offers those possibilities, limiting the capabilities about what the tenant can do.

More control and management capabilities in the tenant side will probably imply to go to dedicated resources in the network side, and viceversa.

Somehow I see similarities between this and the concept of managed and un-managed services that the operators offer today for connectivity services. I explored in the past this different approaches with the idea of provider-managed vs tenant-managed slices, you can check the following article if interested: https://sdn.ieee.org/newsletter/january-2018/a-network-service-provider-perspective-on-network-slicing

Best regards

Luis

De: Kiran Makhijani <[email-masked]>
Enviado el: jueves, 17 de octubre de 2019 11:00
Para: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>; Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]>; Aijun Wang <[email-masked]>; 'Dongjie (Jimmy)' <[email-masked]>; [email-masked]
Asunto: Re: [Teas-ns-dt] 答复: Definition of transport network slicing

Hello Luis,

--
Regards,
Kiran

From: Teas-ns-dt <[email-masked]<mailto:[email-masked]>> on behalf of LUIS MIGUEL CONTRERAS MURILLO <[email-masked]<mailto:[email-masked]>>
Date: Thursday, October 17, 2019 at 3:23 PM
To: "Rokui, Reza (Nokia - CA/Ottawa)" <[email-masked]<mailto:[email-masked]>>, Aijun Wang <[email-masked]<mailto:[email-masked]>>, "'Dongjie (Jimmy)'" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teas-ns-dt] 答复: Definition of transport network slicing

Hi Reza, all,

Best regards

Luis

De: Teas-ns-dt <[email-masked]<mailto:[email-masked]>> En nombre de Rokui, Reza (Nokia - CA/Ottawa)
Enviado el: jueves, 17 de octubre de 2019 0:01
Para: Aijun Wang <[email-masked]<mailto:[email-masked]>>; 'Dongjie (Jimmy)' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
CC: Rokui, Reza (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>
Asunto: Re: [Teas-ns-dt] 答复: Definition of transport network slicing

Hi Aijun,

Cheers,
Reza

Hi, Reza,Jie and all:

Best Regards.

Aijun Wang
China Telecom

Hi Jie and all,

Cheers,
Reza

Hi,

Best regards,
Jie