Subject: [Teas-ns-dt] Notes from the first call (Sept 30)

From: Jari Arkko <[email-masked]>
Date: Mon, 7 Oct 2019 12:00:32 +0000

Here are brief notes from last week’s call. This week’s call is starting in about an hour (Central Europe 15:00, New York 09:00).

Notes from the design team call, September 30, 2019.

PARTICIPANTS

Xufeng Liu
Aijun Wang
Himanshu
Jie Dong
John Drake
Luis M. Contrares
Rakesh Gandhi
Ricard Vilalta
Sergio Belotti
Tomonobu Niwa
Xuesong Geng
Jeff Tantsura
+ maybe 1-2 whose names were missed

WELCOME

Jari opened the meeting and thanked the volunteers.

INTRODUCTIONS AND EXPECTATIONS

The participants introduced themselves. Some of the participants discussed what expertise they can bring to the group and what they expect to see as results. Experienced varied, from routing technologies to VPNs, traffic engineering, open source, network management, etc.

The expectations included work on data models, being able to handle both data and control planes, clarification of terms and scopes, understanding how transport fits into the end-to-end slicing story, how transport networks work with 3GPP networks, how to achive QoS slicing, and a preference for concrete results and documentation of the use of existing technologies for slicing as opposed to inventing many new things.

WAY OF WORKING AND LOGISTICS

The group discussed briefly the charter. The team has set up to develop a framework for providing Network Slicing using IETF TE technologies. The expectation is for IETF technologies such as IP, MPLS and GMPLS, to  be used to create specific, isolated, and managed network instances.

The team has pretty free hands to decide how to do our work, but needs to report back to the working group. There's an expectation of being able to talk to the WG at least about our thoughts on scope for the work in Singapore.

The group operates in an open manner, anyone may send to the list, see the archives, or join the calls. On the first call, for instance, we had a participant outside the designated design team members. The members are expected to put in work towards the goals of the team, but input and work from others is also very welcome.

Jari suggested that the team primarily work on the list, discuss different topics, make contributions. On the calls we can perform a status check and talk about hard issues that benefit from real-time discussion over phone.

For practical arrangements, the group will need a place in WG github to store notes and other materials. This is ongoing. The group also wanted to use Etherpad for editing notes from calls. The next call notes will be edited at https://etherpad.net/p/teas-ns-dt-call2 (as etherpad.ietf.org seems to be down). Jari asked if there was any objection to recording the calls. There was not.

Jari promised to run a second doodle poll to determine a suitable permanent meeting slot.

SCOPE

The question was how can we decide what of the many topics under this broader context we shall handle.

Jari's approach was from a practical perspective, what's achievable -- we should start small, expand from there: how to use IETF TE tech to do certain things.

Jeff noted that the BOF failed because they tried to boil the ocean. He believed that the  northbound interface to 3GPP isn't defined, and  looking coherently at the northbound interface towards 3GPP would be useful.

Xufeng believed that we need to provide isolation and performance, can provide these via a TE network.

Jeff noted that step 0 is instantiation of a slice as requested by the 3GPP network. Feedback loops etc are further steps, maybe further work. Jari agreed with Jeff that cannot boil the ocean. Jeff said that the team needs to understand better what 3GPP requires from transport networks, can people read up/familizare themselves with those requirements? Jeff noted that radio part needs to be understood, there's pre-emption etc.

Xufeng noted that no document requires separation, but rather resource separation.  Jeff agreed.

Jeff noted that a slice is just high level intent, will not describe anything like a VPN. The implementation details are up to us, they just need the intent fulfilled.

There was a question about 3GPP slice templates? They probably do not detail much of the transport capabilities. May need an extension if we want to describe more of the detailed aspects. Jeff answered that he believes the templates need to ask for things we can deliver, sometimes hardware can pre-empt, sometimes, not. etc. hard vs. soft slices.

Luis Promised to look at slice templates and report back in the next meeting.

Jeff, John, Xuesong, and Jari promised to look at the 3gpp requirements.

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Mon, 7 Oct 2019 12:53:04 +0000

Hi Jari and all,

For the record, during the conference call we also discussed how to review and make use of the existing network slicing related drafts. I suggested people to take a look at the enhanced VPN framework draft and other related drafts to see if the transport network slicing definition and the architecture there could be reused or extended.

Best regards,
Jie

From: Teas-ns-dt [mailto:[email-masked]] On Behalf Of Jari Arkko
Sent: Monday, October 7, 2019 8:01 PM
To: [email-masked]
Subject: [Teas-ns-dt] Notes from the first call (Sept 30)

PARTICIPANTS

Xufeng Liu
Aijun Wang
Himanshu
Jie Dong
John Drake
Luis M. Contrares
Rakesh Gandhi
Ricard Vilalta
Sergio Belotti
Tomonobu Niwa
Xuesong Geng
Jeff Tantsura

WELCOME

SCOPE